Jump to content
Cassio

"Still waiting for root device" com kernelcache

Recommended Posts

Para quem tem o problema de "still waiting for root device" quando usa kernelcache (ou só funciona usando -f), aplique este patch que adiciona um delay de 200 ms no início da kext IOAHCIBlockStorage, resolvendo o problema.

 

patch-ahci-mlion-0.1.zip

 

Update (10.8.x)

patch-ahci-mlion.pl.0.3.zip

 

Créditos: bcc9

http://www.insanelymac.com/forum/topic/280062-waiting-for-root-device-when-kernel-cache-used-only-with-some-disks-fix/

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Posso ter postado em lugar errado, mas esse erro do "Still waiting for root device" acontece comigo quando mudo de AHCI pra RAID na bios.


Gostaria de saber como faço para salucionar???

•Processador: Intel Core i5 2500k 3.3Ghz

•Placa Mãe: Asus Maximus Gene-Z (Intel Z68)

•Memória: G.skill 8GB DDR3 1600Mhz

•Audio: Realtek ALC889

•Rede: Intel 82579V Gigabit Ethernet

•Armazenamento: Maxtor 320gb @ OSX Mountain Lion GM

•Video: Nvidia 9400GT

Link to comment
Share on other sites

Provavelmente seu hardware RAID não é suportado. Acho que você tem que fazer por software (Apple Software RAID), ou usar uma placa compatível.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Provavelmente seu hardware RAID não é suportado. Acho que você tem que fazer por software (Apple Software RAID), ou usar uma placa compatível.

 

Desculpe pois acho que não fui muito claro.


Eu ja possuo um Raid0 controlado pelo propio Chipset com o Windows 7, e estava querendo informação para resolver o problema.


Pois queria, deixa a bios em RAID pro windows e o MAC funcionando pra fazer um dual boot no Chamaleon.

•Processador: Intel Core i5 2500k 3.3Ghz

•Placa Mãe: Asus Maximus Gene-Z (Intel Z68)

•Memória: G.skill 8GB DDR3 1600Mhz

•Audio: Realtek ALC889

•Rede: Intel 82579V Gigabit Ethernet

•Armazenamento: Maxtor 320gb @ OSX Mountain Lion GM

•Video: Nvidia 9400GT

Link to comment
Share on other sites

Nesse caso depende da sua controladora ser suportada, e pelo jeito não é (pelo menos não nativamente).

 

Realmente axava q teria solução, mas pelo q li para eu utilizar seria preciso ligar o HD onde esta instalado em outra controladora SATA.


No meu caso, somente as portas E-Sata são controladas pelo JMicron JMB362. Pois a minha MB é M-ATX, e as 6 portas sata "On-board" da MB são controladas pelo chipset Intel.


Desculpa por ter poluido o topico com duvidas com solução diferente a q seu topico ajuda a resolver.

•Processador: Intel Core i5 2500k 3.3Ghz

•Placa Mãe: Asus Maximus Gene-Z (Intel Z68)

•Memória: G.skill 8GB DDR3 1600Mhz

•Audio: Realtek ALC889

•Rede: Intel 82579V Gigabit Ethernet

•Armazenamento: Maxtor 320gb @ OSX Mountain Lion GM

•Video: Nvidia 9400GT

Link to comment
Share on other sites

segue a versão atualizada que funciona tanto na 10.8 quanto na 10.8.1:

patch-ahci-mlion.pl.0.1.zip

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

 

deu certim aki também! :D

NB Dell N4110

Placa Mãe: Intel 6 Series

Processador: Core i5 2410M 3MB Turbo Boost

Chipset: Mobile Intel® HM67 Express Chipsets

AMD Radeon HD 6470M - Seymour XT 1GB

Intel Centrino Wireless-N 1030 1x2 bgn + Bluetooth3.0

Audio: ALC 269 HD

Link to comment
Share on other sites

olá


esse fix n pertence a essa pessoa , k não passa de um vulgar ladrão do trabalho dos outros, sem sequer mencionar onde foi buscar essa informação.


agradeço k n postem sobre esse blog..


http://www.insanelymac.com/forum/topic/280062-waiting-for-root-device-when-kernel-cache-used-only-with-some-disks-fix/page__hl__%20still%20%20waiting%20%20for%20%20root%20%20device%20%20fix



bom hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Olá,


abra o terminal e rode

sudo perl Downloads/patch-ahci-mlion.pl

Se estiver em outra pasta, mude Downloads pelo local do script.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

para 10.8.5 pode usar esse fix tambem? no PC deu KP após atualizar para a buid 12F45 10.8.5 só consigo entrar com -F USEKERNELCACHE=NO

ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE

X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA

Link to comment
Share on other sites

Ola!


resolvi o problema trocando a fakesmc e AppleIntelCPUPowerManagement.kext!


obrigado

ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE

X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...