Jump to content
MaLd0n

How to mount EFI partition on MacOS or Windows

Recommended Posts

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

 

-Mount EFI partition on MacOS

Download ESP Mounter Pro - https://olarila.com/files/Utils/ESP Mounter Pro.app_v1.9.1.zip

3gn1vuI.png


-Mount EFI Partition on Windows

 

1- Install MiniTool Partition Wizard Free Edition
https://tinyurl.com/w8z8474q

Open App
Right-Click the EFI partition and click Change Letter

cNnbjLg.png
Select an unused drive letter ( x or z for example)
Click OK and Apply

zY6Y5r2.png
 

2- Now we need Access & Edit EFI partition

Download Explorer++
https://tinyurl.com/3ulohd2k

Open App with "Run as administrator" Option

oEKAifh.png

 

You should now see your EFI folder which you can open and make changes too through the Explorer++ program.

QJtKD50.png

 

Credits: @pg7

  • Like 4
  • Thanks 3

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

OK,

 

Tried it again....

I must have made a mistake earlier, all seems to run as it should (so far)

I have gone into disk utility and erased my target SSD (GUID & APFS)

I am installing onto that SSD right now.

Will let you know if I get into a snag again.

Thanks for your help.

I made another $10 donation for your time.

Link to comment
Share on other sites

OK, I did the Disk Utility and followed your instructions to format GUID and APFS.

I then began the installation of macOS Big Sur

When it says that there is about 12 minutes remaining, I get  "An error occurred loading the update."

I have snapped a picture of the installer log.JSWoods4-4.7z

It appears that a volume is not formatted as Mac OS Extended (Journaled), but I did not see that in your steps to format the drive.  I thought that "Erasing" the drive was all that was needed, and that it would format as part of that operation.

 

Link to comment
Share on other sites

  • Administrators
9 hours ago, Jswoods4 said:

It appears that a volume is not formatted as Mac OS Extended (Journaled), but I did not see that in your steps to format the drive.

Step 5 - Formatting SSD on Installer

5a) On Disk Utility Change "View" options to "Show All Devices"

NPUnFEV.png

JjYQPNl.png

5b) Selecting and formatting SSD. Use GUID and APFS

6TAyBkT.png

 

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Maldon,

 

I see no command to format the drive.  Only erase it.  I have followed your steps...  Is there a format command?  If so, it must be eluding me.

 

So when I right click on the actual SSD (mine is Samsung SSD 840 PRO Series Media), I see the following options

Get Info
Run First Aid...
Eject (grayed out)
Image from Samsung SSD 840 PRO Series Media
Restore...
Partition...
Erase...

 

The only thing that looks close to format is "Erase".  I chose that option

After selecting "Erase", I see the following:

Name: Untitled (I named this "Hackintosh")
Format: APFS
Scheme: GUID Partition Map

I then hit the "Erase" button

Erasing Samsung SSD 840 PRO Series Media (disk0) and creating "Hackintosh"

 

Unmounting disk
Creating the partition map
Waiting for partitions to activate
Formatting disk0s2 as Mac OS Extended (Journaled) with name Hackintosh
Initialized /dev/disk0s2 as a 477GB case-insensitive HFS Plus volume with a 40960K journal
Mounting disk
Creating a new empty APFS Container
Unmounting Volumes
Switching disk0s2 to APFS
Creating APFS Container
Created new APFS Container disk2
Preparing to add APFS Volume to APFS Container disk2
Creating APFS Volume
Created new APFS Volume disk2s1
Mounting APFS Volume
Setting volume permisions

Operation successful.

I then click "Done"  (it says Erase process is complete.  Click Done to continue)

I close the Disk Utility and I am back to the Recovery menu that has 4 options

 

Restore from Time Machine

Install macOS Big Sur

Safari

Disk Utility

 

I then select the Install macOS Big Sur

 

When there is about 12 minutes remaining, I get the error

 

"An error occurred loading the update"

Same set of error messages as previously sent to you (in the 7zip file)

 

Any ideas?

 

Edited by Jswoods4
Link to comment
Share on other sites

  • Administrators

some mistery. what gpu?

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

burn image again. something wrong

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Maldon,

 

I have been away from my computer for a while, sorry for not responding sooner....

OK, I re-created the image with all fresh downloads.

Same issues as listed above

So, I tried switching USB ports

I also removed the GeForce 760 card and am now using the native GPU

Tried everything again.

The one thing that is different is that I now always have the issue when there is exactly 12 minutes remaining.

I am getting Error 1004: "An error occured loading the update"

I did try to look this up on the web, and it says that the OS is trying to reach an apple site then supposed to reboot

I do have the computer hooked up to ethernet, and I can run Safari from the Recovery menu and all works

Anyhow, I have attached a screenshot of the installer log:

I am going to try to connect my target SSD drive to Disk0s1.  Right now it is connected as Disk2s1.  Don't know if that will make a difference, but at this point, I am somewhat out of options.

JWoods4-6.7z

Link to comment
Share on other sites

  • Administrators

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

create ur video patch with hackintool

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Maldon,

 

I have tried to follow your guide.  It looks like you are suggesting that I change the bootloader to Clover.

So, I tried that, and my USB boots to Clover, but I do not see any items to select the installer.  Must have missed a step somewhere.  

Do I have it right that your guide 6185 creates the .dmg on the desktop, then after all steps are completed, I then need to convert from .dmg to .raw, then burn to USB from Apple desktop using Rufus on a PC or something like that?

I do have another Hackintosh that you helped me create a few years ago, that works perfectly fine with your software.  It is running Mojave.  So I do have an "Apple" computer in my house.  I am planning on using this one at work, as I am a technology coordinator at a high school in Chicago that has many Mac computers.  Want my computer to be a dual architecture for that reason.

I did try to download a fresh installer from Apple, and I did replace the installer on your original Big Sur Vanilla image, but same error occurs again.

 

So, I guess I have a few questions.  If you could help me understand, it would be helpful

1) Is the error  that I get "An error occurred loading the update" have anything to do with the bootloader?

2) Would updating the OpenCore to 0.77 be worth my time?  Your bootloader is OC 0.63.  I am not sure how to do that, but I will try to figure it out.

3) Are you recommending that I go to Clover instead?  Do you think that would help with fixing this error?

4) Right now, I am trying Vanilla Catalina to see if I can get past this issue.  Will let you know how it goes...

I am back at work again, so my time is more limited.  However, I do not give up easily.

Link to comment
Share on other sites

  • Administrators

with folder haswell desktop n eed work

i tested many times

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators
7 hours ago, Faok Giak said:

it work for mbr and legacy for  hacintosh?

Yes

EFI partition only if u format with GUID

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

  • Administrators

this app work perfect. something wrong in ur system or other thing.

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 - BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115 - PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

Hi, I'm stuck on this step of the process, I've completed every step behind.

When I go to mount the disk to paste the EFI folder, it doesn't show any other disk rather than the usb I'm booting from.

I have 2 drives, one for windows and one for hackintosh. When I click on "Show All Disks" it shows the two partitions of the hackintosh disk: One is the APFS container which holds the main storage and then there's a 16MB small partition where I should put the EFI folder, but it appears as "Microsoft reserved" and I can't mount it.

 

Any ideas? Should I format it to EFI? if so, how?

Thanks a lot.

  • Like 1
Link to comment
Share on other sites

Sonic exe

On 11/13/2022 at 1:04 PM, Steven Van said:

Having issues ejecting drives with ESP Mounter Pro with Ventura.  Shame the app hasn't been updated in years.  I just want to mount without being asked for a password each time which is why I like it.

Asking for a password every time you log in is also a bit annoying. But I find it also has its own benefits. And you should also upgrade your machine if it is outdated.

Link to comment
Share on other sites

BaseBoard Manufacturer    RPL

BaseBoard Product    Compass_RTX

BaseBoard Version    V1.10

cpu code name: raptor lake

Processor    13th Gen Intel(R) Core(TM) i7-13700HX, 2100 Mhz, 16 Core(s), 24 Logical Processor(s)

BIOS Version/Date    INSYDE Corp. V1.10, 03-05-2023

SMBIOS Version    3.4

Acer Predator Helios Neo 16 13th Gen Intel Core i7 (Windows 11 Home/16 GB/1 TB SSD/NVIDIA GeForce RTX 4050)

https://store.acer.com/en-in/acer-predator-helios-neo-16-13th-gen-intel-core-i7-windows-11-home-16-gb-1-tb-ssd-nvidiar-geforce-rtxtm-4050-phn16-71-wuxga-display-obsidian-black-2-6-kg-nh-qltsi-006?utm_campaign=pmaxshopping-()-add_to_cart-2023-in&utm_source=google&utm_medium=search&utm_term=product-()-()-()-()&gclid=Cj0KCQjwmvSoBhDOARIsAK6aV7hXpnLclum31ZgKilz2RQ8YfZwPH8-c0beujPTVayO09GB7mwQk5mMaAtNJEALw_wcB

i need efi file and installation detail.laptop version

Edited by rajeev
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...