Jump to content
garcia de moura

Match 0 file has bad magic number - erro de boot do Mountain

Recommended Posts

Saudações hackintosheanas!


Estou com o Lion 10.7.4 na máquina e baixei o Mountain Lion DP4 pra testar a instalação antes de sair a versão final.

Segui este tutorial: http://translate.google.com.br/translate?hl=pt-BR&sl=en&u=http://thetecherra.com/2012/07/10/tutorial-run-os-x-mountain-lion-10-8-gm-on-a-pc-hackintoshosx86-video/&prev=/search%3Fq%3Dmach%2B0%2Bfile%2Bhas%2Bbad%2Bmagic%2Bnumber%26start%3D20%26hl%3Dpt-BR%26sa%3DN%26biw%3D1920%26bih%3D940%26prmd%3Dimvnsfd&sa=X&ei=5vkKULzXJ4no0gGn1aDFAw&ved=0CGMQ7gEwBDgU


versão original em inglês: http://translate.google.com.br/translate?hl=pt-BR&sl=en&tl=pt&u=http%3A%2F%2Fthetecherra.com%2F2012%2F07%2F10%2Ftutorial-run-os-x-mountain-lion-10-8-gm-on-a-pc-hackintoshosx86-video%2F&anno=2


Resumidamente:

criei uma partição de 20 Gb para o instalador via Disk Utility - que chamei de InstallerOSX (estou sem pendrive de 8 Gb)

Montei o DMG do Mountain Lion e apareceu o OS X Install ESD no desktop

Exibi os arquivos ocultos usando o ShowHiddenFiles e montei o BaseSystem.dmg

Pelo Disk Utility, restaurei esse BaseSystem.dmg para a partição que servirá de arranque para instalar o sistema, minha InstallerOSX

Abri a partição InstallerOSX pelo Finder e naveguei até System/Installation e deletei o link "packages"

Nesse mesmo local, criei uma pasta chamada Packages, com P maiúsculo, pra não ter erro.

Copiei todo o conteúdo da pasta Packages do Mac OS X Install ESD para a pasta Packages recém criada na partição InstallerOSX

Baixei esses arquivos (http://translate.googleusercontent.com/translate_c?hl=pt-BR&rurl=translate.google.com.br&sl=en&tl=pt&u=http://bit.ly/OZh98b&usg=ALkJrhjxYuOjaqfzg0jLQESBhTcFaUghmA)

e descompactei-os no desktop


Esse anexo baixado tem os seguintes arquivos:


FakeSMC.kext

NullCPUPowerManagement.kext

OSInstall

OSInstall.mpkg

Chameleon_2.1svn_r1820_trunk_10.8.pkg


As duas kexts (FakeSMC e NullCPUPowerManagement) foram copiadas para S/L/E da unidade InstallerOSX. Aproveitei para colocar aí também a AppleVIAATA.kext, cuja qual sem ela meu sistema não entra!

O arquivo OSInstall foi copiado para InstallerOSX / System / Library / PrivateFrameworks / Install.framework / Frameworks / OSInstall.framework / Versions / A /., substituindo o arquivo que já está lá.

O arquivo OSInstall.mpkg foi copiado para InstallerOSX / Sistem / Installation / Packages /, substituindo o arquivo que já está lá.

Instalei o Chameleon_2.1svn_r1820_trunk_10.8.pkg na partição InstallerOSX, escolhendo a SMBIOS de um iMacPro 8.1, que é a mesma que uso atualmente no Lion

Copiei o mach_kernel do Mac OS X Install ESD para a raiz da partição InstallerOSX

Copiei também o pacote de instalação do chameleon para a raiz da partição InstallerOSX, como orientado no tutorial acima referido.


Daí em diante era apenas reiniciar, bootar e começar a instalação, mas quando o boot acontece e seleciono a partição InstallerOSX, dá um erro que não dá tempo de fotografar e que após seguidas vezes consegui ler que diz: Match 0 file has bad magic number e imediatamente o carregamento da instalação é interrompido voltando no prompt do chameleon.

Tentei usar as bandeiras conhecidas: arch=i386, -v, -x, -s, -f mas sem sucesso.

Alguém conhece esse problema ou teve experiência com isso?

Baixei o bootloader Clover desse tópico http://www.Olarila.com/forum/viewtopic.php?f=9&t=1032 e nem o Lion subia mais, ficava parado

na tela preta com o curso parado também, sem piscar. Corrigi o problema bootando pelo DVD do iATKOS L1 e reinstalando meu bootloader atual.

Tentei seguir esse tutorial aqui: http://www.Olarila.com/forum/viewtopic.php?f=26&t=995, que no início diz para

montar o InstallESD.dmg que se encontra na pasta Contents/SharedSupport do Install OS X Mountain Lion Preview X.app, mas quando monto a imagem do instalador do Mountain Lion DP4,

não há nenhuma pasta chamada SharedSupport dentro de Contents, nem em modo invisível.

Também usei a ferramenta de pesquisa do Olarila pelo erro mencionado (Match 0 file has bad magic number) e não achei nada.

No google aparecem milhões de coisas incompreensíveis, sites mal traduzidos, dicas sobre mudar o cd de boot (tentei e não deu certo), outros falando sobre versão de kernel, placa gráfica,

controladoras de disco rígido, deixar a BIOS no modo AHCI (já está) e meu HD está particionado em GUID.


Se alguém souber um caminho a seguir, ficarei muito agradecido. ;)

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Já vi "Mach-o", nunca "Match 0".


Isso normalmente é arquivo corrompido, imagem baixada com problema. Sugiro baixar o dmg novamente, aproveite e baixe o build mais recente (12A269).


Também pode baixar o pen drive pronto http://Olarila.com/forum/viewtopic.php?f=26&t=1618

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Já vi "Mach-o", nunca "Match 0".


Isso normalmente é arquivo corrompido, imagem baixada com problema. Sugiro baixar o dmg novamente, aproveite e baixe o build mais recente (12A269).


Também pode baixar o pen drive pronto http://Olarila.com/forum/viewtopic.php?f=26&t=1618

 

É isso aí!!!

Baixei esse pen drive pronto e foi certinho. Só precisei abri-lo pelo TransMac e remover as kexts da AppleIntelHdGraphics pra poder instalar.

Subiu de primeira após a remoção das referidas kexts, mas lógico que o vídeo está em 1024*768 sem QE nem CI. Infelizmente meu notebook

possui esta placa gráfica ingrata para nós "hackintoshers" [intel HD Graphics chipset Intel ironlake] e não há muito o que fazer, aliás fiz tudo o que pesquisei sem nenhum sucesso. Paciência,

vou instalar o Mountain no PC, esse sim dá certo.

Obrigado, Cássio!

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Deu problema:


Conforme a citação acima, consegui instalar no meu note, mas quando fui instalar o Mountain Lion no meu PC,

deu novamente o erro "match-o file has bad magic number"


Meu PC é o da assinatura, o note é um Dell N4030, core i3, 4 Gb RAM, Intel Ironlake

Intel HD Graphics


Instalei o pen drive pronto http://Olarila.com/forum/viewtopic.php?f=26&t=1618 que o Cassio sugeriu


Alguma ideia? Pode ser algum problema no bootloader?

Grato.

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Como eu já disse, isso é problema de arquivos corrompidos, eu diria que esse pen drive tá com problema. Você tentou subir o instalador no laptop de novo, depois que deu problema no desktop?

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Sim. Sobe normal até a tela de escolha de idiomas e depois fecho.

Vi em um forum que foi sanado o problema mudando o bootloder, então bootei com o CD iBoot Legacy

e a tela do carregamento para aqui:

 

tela.thumb.jpg.304f25216fe7441759ece03e296ea387.jpg

 

Tentei bootar também pelo CD rBoot e forçar subir em 64 bit (arch=x86_64) dessa forma

começa a carregar aquelas milhares de linhas que sobem pelo monitor, mas em dado momento reinicia.

Tenho certeza que não é problema no pen drive, pois no laptop a instalação inicia.

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Eu acho que isso deve ter alguma a ver com os bits do PC...

No meu note instalou (Core i3) e meu PC é bem mais antigo... Core 2 Duo

Deve ter alguns kexts que estão em desacordo com o hardware antigo. Vou pesquisar a respeito.

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Nessa foto aparece "kernel 10.6", isso é pra Snow Leopard, o ML não vai subir com esse CD.


Também não adianta "forçar" 64 bit, o ML nem tem i386, é só x86_64 mesmo.


Se o pen funciona no laptop, deve ser algum problema com a USB do desktop. Tente USBBusFix=yes ou usar outra porta USB.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Ok, grande!

Vou tentar e depois reporto.

Qual é o bootloader mais indicado para o ML?

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Ah! Outra coisa:

No meu note depois da instalação do ML, instalei o chameleon e o mesmo parece que não instalou.

Não foi criado o org.chameleon.boot.plist e nem a pasta /extra.

No note tenho HD particionado com o windows 7 e está em GUID. Sabe o que pode ser?

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Você fala sobre instalar manualmente? Bom...

Muito bem, fiz conforme vc falou, usando a bandeira USBBusFix=Yes, mudei a porta USB, nada.

Se eu NÃO usar a bandeira arch=x86_64, dá aquele bendito "match -o file has bad magic number",

se eu USAR a bandeira arch=x86_64, o carregamento inicia, mas interrompe repentinamente e entra em reboot.


Segundo o log do Console, eis as últimas linhas do carregamento: (não dá pra tirar foto...)


Jul 29 21:37:16 localhost kernel[0]: BSD root: disk0s2, major 14, minor 2

Jul 29 21:37:16 localhost kernel[0]: USBMSC Identifier (non-unique): 20060413092100000 0xbda 0x151 0x5195

Jul 29 21:37:16 localhost kernel[0]: USBMSC Identifier (non-unique): 001CC07CEAD9BB31A92500EA 0x951 0x1642 0x100

Jul 29 21:37:16 localhost kernel[0]: BootCache: cache size (1105068032 bytes) too large for physical memory (2147483648 bytes), capping at 1073741824 bytes

Jul 29 21:37:22 localhost kernel[0]: macx_swapon SUCCESS

Jul 29 21:37:22 localhost kernel[0]: Waiting for DSMOS...

Jul 29 21:37:31 Garcias-Mac-Pro kernel[0]: SMC::smcReadKeyAction ERROR $Num kSMCKeyNotFound(0x84) fKeyHashTable=0x0

Jul 29 21:37:31 Garcias-Mac-Pro kernel[0]: Previous Shutdown Cause: 3

Jul 29 21:37:31 Garcias-Mac-Pro kernel[0]: SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode

Jul 29 21:37:32 Garcias-Mac-Pro kernel[0]: Apple16X50ACPI1: Identified Serial Port on ACPI Device=UAR1

Jul 29 21:37:32 Garcias-Mac-Pro kernel[0]: Apple16X50UARTSync1: Detected 16550AF/C/CF FIFO=16 MaxBaud=115200

Jul 29 21:37:32 Garcias-Mac-Pro kernel[0]: NVDANV50HAL loaded and registered.

Jul 29 21:37:37 Garcias-Mac-Pro kernel[0]: ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out

Jul 29 21:37:38 Garcias-Mac-Pro kernel[0]: DSMOS has arrived

Jul 29 21:37:45 Garcias-Mac-Pro kernel[0]: HFS: Low Disk: freeblks: 28138, warninglimit: 49026

Jul 29 21:37:47 Garcias-Mac-Pro kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=188[CleanMyMacHelper] clearing CS_VALID

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: LITTLE_ENDIAN

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: 604956 moschipUsbEthernetController::start - this, provider.: 131590144 135330560 trts

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: Moschip- Message e0000101

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: 801790 moschipUsbEthernetController::message - unknown message: 0 -536870655 Usem

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: 870011 moschipUsbEhternetController::start - It is REV-C: 0 0 -FRa

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: Starting device....

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: registerWithPolicyMaker

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: initialPowerStateForDomainState

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: setPowerState - power 1

Jul 29 21:38:22 Garcias-Mac-Pro kernel[0]: moschipUsbEthernetController: Ethernet address 00:13:3b:00:14:32

Jul 29 21:38:51 Garcias-Mac-Pro kernel[0]: IOSurface: buffer allocation size is zero

Jul 29 21:39:21: --- last message repeated 3 times ---

Jul 29 21:39:23 Garcias-Mac-Pro kernel[0]: IOSurface: buffer allocation size is zero

Jul 29 21:41:15 Garcias-Mac-Pro kernel[0]: USBF: 251.563 AppleUSBEHCI[0x514c000]::unlinkAsyncEndpoint - pED[0x7330400] seems to still be the AsyncListAddr after doorbell

Jul 29 21:42:27 Garcias-Mac-Pro kernel[0]: USBF: 323.611 AppleUSBEHCI[0x514c000]::unlinkAsyncEndpoint - pED[0x7330400] seems to still be the AsyncListAddr after doorbell

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Você fala sobre instalar manualmente? Bom...

Não, falo sobre clicar no botão "personalizar" no instalador.


Sobre o desktop, não tenho idéia.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Obtive êxitos!


Consegui fazer a instalação usando o Cd de boot HackBoot: http://www.Olarila.com/forum/viewtopic.php?f=26&t=1616

usei o primeiro Cd de boot (HackBoot normal), porque não tive problemas nem com gráficos, nem com ApplePolicyControl.kext, pelo menos por enquanto;

e instalei o pendrive pronto: http://www.Olarila.com/forum/viewtopic.php?f=26&t=1618. A instalação foi OK!

ao reiniciar deu erro "still waiting root device", que resolvi colocando a AppleVIAATA.kext em S/L/E na partição do Mountain Lion,

fiz isso pelo Lion, mas ao reiniciar novamente depois de colocar a kext para controle do HD, aparece o seguinte erro:

 

KP.thumb.jpg.18201d75fb11b88a8f290326f25cde18.jpg

 

O que isto significa? Algo errado com a kext de gestão de energia?

Thanks! :P

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Eba! Terminei a instalacao (desculpe pela acentuacao, ainda nao personalizei o teclado!)


Agora so faltam os ajustes, a comecar pelo video, que esta em 1024x768 sem QE / CI e

nao esta em tela cheia.

Vou tentar colocar em S/L/E as kexts GeForce e Nvidia do Lion e ver o que acontece

e vou dar uma olhada sobre injetar as propriedades se nao funcionar.

Caramba, o sistema nao reconheceu nada!!! Esse vai dar trabalho.


Obrigado, Cassio!!! :D

Gigabyte GA-B75M-D3H UEFI

Corsair 1X4 Gb 1600 Mhz Vengeance

Intel i3 3240

Fonte Corsair CX 600

EVGA NVidia GT 630 2Gb

Storage SSD Corsair Force GT 120 Gb

Samsung Syncmaster P2370

OS X macOS Sierra 10.12.6 Olarila Version

MacBook Pro 2008, sim: 2008!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...