Jump to content
ArkCyD

Problemas com a Geforce GTX 550ti

Recommended Posts

Olá pessoal! Bom...

Eu instalei normalmente o OSx no meu pc, consegui ativar a placa de rede e a de som etc. A placa de vídeo foi detectada normalmente, porém todos os jogos que tento rodar nela ficam com muito lag como HoN, starcraft2 etc, até na pior qualidade de gráficos. Estes que jogava normalmente no windows na config máxima.


Nas informações do Mac aparece a placa de vídeo, só q com a memória de 1558mb mas na verdade ela tem 1gb.


Minha placa mãe é uma P7P55D.


Obrigado pela ajuda! Grande abraço.

Link to comment
Share on other sites

Ah vou tentar este aqui! Mas uma pequena dúvida:


No meu identificador de modelo tá escrito MacPro3,1, e na plist do AGPM não tem a key com ele (provavelmente este é o problema). Então eu posso editar ou duplicar qualquer uma key com MacProX,X para o meu SMproductname (MacPro3,1)?

Link to comment
Share on other sites

Então talvez não seja esse o problema, pois o MacPro3,1 não é influenciado pela AGPM, por isso ele não aparece no plist da kext.


Tem certeza de que os drivers de vídeo estão ativados? http://Olarila.com/forum/viewtopic.php?f=2&t=40


Pela sua placa mãe, acredito que MacPro3,1 não seja o modelo mais indicado para você usar. Use o Chameleon Wizard para localizar um modelo mais adequado ao seu CPU.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Realmente vi que não teve diferença duplicando uma key, criando a MacPro3,1 e colocando as informações da minha placa de video, então substitui de volta o arquivo que salvei de backup e reiniciei, ficou como era antes, ai fui ver que O GraphicsEnabler tava YES, então eu tentei colocar os IDs no NVDAGF100Hal como o fala o tutorial;


Estava assim:


IOPCIPrimaryMatch


0x06c010de&0xffe0ffff

0x0dc010de&0xffc0ffff

0x0e2010de&0xffe0ffff

0x0ee010de&0xffe0ffff

0x0f0010de&0xffc0ffff

0x104010de&0xffc0ffff

0x124010de&0xffc0ffff

0x108010de&0xffe0ffff

0x120010de&0xffe0ffff



Ficou assim:


IOPCIPrimaryMatch

0x124410de


salvei e reiniciei, então meu segundo monitor parou de funcionar, e a placa de vídeo não foi detectada no OpenGL Extension Viewer, mas no relatório do sistema aparecia normal com os IDs memoria e tudo mais, mas só um monitor e a resolução só tinha 1024x720. O jogo disse que minha placa de video não é compatível para roda-lo. Então voltei o arquivo NVDAGF100Hal de backup para como estava antes e reiniciei e mesmo assim não detectou. Então eu reinstalei com o multishit e rodei o "repair permissions", reiniciei novamente e pronto tudo como era antes, mas continua lento os jogos.


PS: não entendi muito o que o tutorial do cara passava. A sequência é

Ativar GraphicsEnabler > Usar o Lizard para adicionar a key PCIroot no arquivo de boot > Adicionar uma nova key neste arquivo chamada device-properties e colocar a string hexadecimal EFI > Colocar os IDs na kext NVDAGF100Hal e pronto?

Fiquei com dúvida se era para fazer o device-properties, não tenho nem idéia do que ele quis dizer com Current Injection ou com aquele código abaixo! rs

Link to comment
Share on other sites

Ah ok! Vou tentar aqui, mas me explica uma coisinha antes:


Ativar GraphicsEnabler > Usar o Lizard para adicionar a key PCIroot no arquivo de boot > Adicionar uma nova key neste arquivo chamada device-properties e colocar a string hexadecimal EFI > Colocar os IDs na kext NVDAGF100Hal e pronto?

Fiquei com dúvida se era para fazer o device-properties, não tenho nem idéia do que ele quis dizer com Current Injection ou com aquele código abaixo! rs


E esse X do IMac11,x pode ser qualquer um ou tenho q instalar no multishit?


5.png

Edited by Guest
Link to comment
Share on other sites

Ou você ativa o GraphicsEnabler, ou usa o string device-properties, não as duas coisas.


O Lizard está desatualizado, recomendo o Chameleon Wizard, ele tem vários "pre-made SMBIOSes". O x quer dizer que pode ser qualquer iMac11, veja qual se assemelha mais ao seu hardware.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Não é bem isso, olhe a LegacyAGPM de exemplo.


Tem que ser algo assim (eu usaria iMac11,1)

			<key>iMac11,1</key>
		<dict>
			<key>LogControl</key>
			<integer>0</integer>
			<key>Vendor10deDevice1244</key>
			<dict>
				<key>BoostPState</key>
				<array>
					<integer>0</integer>
					<integer>1</integer>
					<integer>2</integer>
					<integer>3</integer>
				</array>
				<key>BoostTime</key>
				<array>
					<integer>3</integer>
					<integer>3</integer>
					<integer>3</integer>
					<integer>3</integer>
				</array>
				<key>Heuristic</key>
				<dict>
					<key>ID</key>
					<integer>0</integer>
					<key>IdleInterval</key>
					<integer>100</integer>
					<key>TargetCount</key>
					<integer>5</integer>
					<key>Threshold_High</key>
					<array>
						<integer>80</integer>
						<integer>80</integer>
						<integer>80</integer>
						<integer>100</integer>
					</array>
					<key>Threshold_Low</key>
					<array>
						<integer>0</integer>
						<integer>90</integer>
						<integer>90</integer>
						<integer>90</integer>
					</array>
				</dict>
				<key>control-id</key>
				<integer>17</integer>
			</dict>
		</dict>

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Então ficou assim:


iMac11,1


GFX0


BoostPState


0

1

2

3


BoostTime


3

3

3

3


Heuristic


ID

0

IdleInterval

100

TargetCount

5

Threshold_High


80

80

80

100


Threshold_Low


0

90

90

90



control-id

17


LogControl

1

Vendor10deDevice1244



mas deu a mesma coisa:


6.png


7.png


8.png


Não dá para escolher outra resolução.

Link to comment
Share on other sites

Não cara, o Vendor10deDevice1244 tem que ficar no lugar onde você botou GFX0 e não lá no final. Coloque exatamente como eu botei no post anterior.


Preste atenção, o ajuste na AGPM serve apenas para melhorar o desempenho, não tem nada a ver com a ativação dos drivers. Se os drivers não estiverem ativados, não vai adiantar nada o ajuste na AGPM.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Ah desculpe!


Então ficou assim:

iMac11,1


LogControl

0

Vendor10deDevice1244


BoostPState


0

1

2

3


BoostTime


3

3

3

3


Heuristic


ID

0

IdleInterval

100

TargetCount

5

Threshold_High


80

80

80

100


Threshold_Low


0

90

90

90



control-id

17


 

9.png


Mesmo assim continua lento. :/

Link to comment
Share on other sites

Ah! Será que é isso?

 

07/04/12 14:41:47,399 com.apple.kextcache: Can't read info dictionary for AppleGraphicsPowerManagement.kext: IOCFUnserialize: syntax error near line 2370.

07/04/12 14:41:49,530 com.apple.kextcache: Can't read info dictionary for AppleGraphicsPowerManagement.kext: IOCFUnserialize: syntax error near line 2370.

07/04/12 19:19:44,000 kernel: NVClockX: [Warning] no nVidia graphics adapters found

 

Acho q num muita coisa boa ai n heim. rsrs


O NVclock foi o log da ultima modificação q fiz do post q fiz às 19:35.

Esse do APGM do erro de syntax parece q é antigo, ou seja, agora q ativei não apareceram mais logs recentes sobre ele, acho q talvez seja por causa do erro NVClockX


10.png

Link to comment
Share on other sites

Agora (com LogControl=1) é que deveria aparecer algo no log, como mostrado no tópico sobre AGPM. Você deve ter errado alguma coisa na edição (parece que tem um sobrando). Removeu a chave iMac11,1 original ou deixou as duas?


Recomendo deixar a AGPM original e instalar uma legacy, menos chances de cometer erros. Eu anexei um exemplo de legacy para desktop no tópico da AGPM, você só precisa mudar o device ID e o LogControl.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Vou tentar aqui! Então eu baixo esse legacy, edito o plist para meu ID e coloco o controlog, depois copio ele pro extensions deixando os dois ou eu substituo o plist do legacy q modifiquei no AppleGraphicsPowerManagement.kext ? E onde acho um AGPM original para baixar?

Link to comment
Share on other sites

Recomendo deixar a AGPM original e instalar uma legacy

Acho que está bem claro, as 2 kexts ficam.


A original é a que você tinha antes de editar, se não fez backup, instale novamente.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Tá, mas posso deixar como o nome dela está? "LegacyAGPM.kext" ?

Onde diz para trocar de nome?


Se atenha ao que está escrito, se vai começar a perguntar tudo que surge na sua imaginação, vai ser complicado, nem vou mais responder.

 

Tenho backup, mas instalar novamente vc quer dizer o osx todo de novo?

Se tem backup da kext, reinstale só a kext, obviamente.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Se tem backup da kext, reinstale só a kext, obviamente.

Não cara, vc não entendeu. Eu disse que tenho a original e sei q é só instalar individualmente, mas SE eu não tivesse, oq você chama de "instalar novamente" ? É só para tirar dúvida mesmo.



Bom, fiz como vc disse: Restaurei o AGPM original sem alterar nada, depois abri o plist do legacy procurei a tag Mac11,1 e coloquei os IDs no lugar de uma outra ID que já tinha e coloquei o LogControl em 1, salvei e joguei a kext na pasta extensions e reiniciei.


no log só aparece isso sobre elas:


09/04/12 14:45:12,215 com.apple.kextcache: LegacyAGPM.kext is not authentic; omitting.

09/04/12 14:45:13,667 com.apple.kextcache: AppleGraphicsPowerManagement.kext is not authentic; omitting.


11.png

12.png


Não aparece nada sobre o G-state ou algo do tipo. Porque será que mesmo ativando o logcontrol as informações não aparecem no log ?


PS: vc chegou a ver a PM?

Edited by Guest
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...