Jump to content
elechocruz

I2C Trackpad Patching but not working

Recommended Posts


Hi, I've been trying to fix my trackpad for a while but I can't get it to work.

First of all try to just put the VoodooI2C kext and it didn't work, after that I added the SMCBatteryManager and it worked !! but after restarting my laptop it stops working, if I delete the kext I download them again and put them in the Other folder again, it works again, but again it only works once and when I turn off or restart the laptop it stops working.

Sometimes it works to re-download the kext and sometimes not, I thought it would be a problem because I did not have the battery indicator working, so I fixed it but it did not work either. 

I started to follow this guide: 

because I thought that then it would be a problem to patch, but I think to I patched it and still it does not work.

According to these data:

VoodooI2C State: Loaded

VoodooI2C Version: 2.3

Satellite:

CPU Model: Intel(R) Core(TM) i5 7y54 CPU @1.20GHz

DeviceName: TPDX

IOName: PCT1336

Mode: Interrupt(GPIO)

GPIO Pin: 0x15

That I took out with GenI2C (And previously I had checked in windows and following the methods of the guide) when having a PIN less than 47 the only thing I would have to check. that the name is correct, so I opened my DSDT, search for TPDXX and replaced the RBUF in the method with SBFB but I don't know what else to do.

            Method (_CRS, 0, NotSerialized)  // _CRS: Current Resource Settings
            {
                Name (RBUF, ResourceTemplate ()
                {
                    I2cSerialBusV2 (0x002C, ControllerInitiated, 0x000186A0,
                        AddressingMode7Bit, "\\_SB.PCI0.I2C0",
                        0x00, ResourceConsumer, , Exclusive,
                        )
                    GpioInt (Level, ActiveLow, ExclusiveAndWake, PullDefault, 0x0000,
                        "\\_SB.PCI0.GPI0", 0x00, ResourceConsumer, ,
                        )
                        {   // Pin list
                            0x0000
                        }
                })
                CreateWordField (RBUF, 0x38, TCHI)
                TCHI = GNUM (0x02000015)
                Return (RBUF) /* \_SB_.PCI0.I2C0.TPDX._CRS.RBUF */
            }

This is my method, I just basically replace the RBUF, anyone know what im doing wrong? 

Im using SMCBatteryManager + VirtualSMC and this is my send_me https://filebin.net/gexnolpedhrwwaog

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...