Jump to content
angrist

SNOW LEOPARD 10.6.6i by hazard in Acer 3680 submodel 2367

Recommended Posts

ACER 3680-2367

Specs: Celeron M520 1.6ghz, 533mhz FSB

Intel graphics: GMA950

WIFI broadcom 4311

Bios Version: Original. no updates applied.

cardbus; TEXAS INSTRUMENTS (8039)

memory reader TEXAS INSTRUMENTS (803b)

Many other submodels will apply to his guide since they share almost the same hardware.


Before Installation , get Nawcom ModCD. It saved me a lot of times. If you commit a mistake like installing the wrong kext or Snow leopard not rebuilding extensions cache, simply load from this cd and choose your harddisk. It always let me load Macosx and perform repairs.


Important: Download IOPCIFamily found at http://www.osx86.net/downloads.php?do=file&id=892.

Just to be on safe side Borrow a monitor and a usb mouse.



STEPS


1.- Boot from 10.6.6i disc. (Tried Iatkos S3v2 but install times were horrible)

2.- Make a partition using disk utility.

3.- When you get to the "select your partition" step, choose "personalize setup".


4.- Options:


Bootloader: Choose Boot32. If you choose another, GMA950 kext will not load.

Boot options: Make sure to check 32 bit mode. Its very important.

RTC: Preselected one is ok. Make sure to check only one.

Wireless: Choose BroadcomFIX

Wired: No option in this distro worked for me.

AHCI: Make sure to check legacyPII (Don't remember exact name just look for that in description)

PS2: VoodooPS2 will enable your trackpad basic function (will work like a simple mouse). Uncheck ApplePS2

Sound: VoodooHDA: any version will work


Start installation. Many times seemed to get stuck, try to click once a while so that it refreshes progress bar.


Post Install Fixes:


After install you will notice that Airport is not getting loaded (no aiport icon). No wireless, no ethernet. Your hardware is not being fully detected. Open finder. Inside it click a button that looks like a magnifying glass. Finder will close and reopen. Now you can see hidden files and folders.


In finder, open Applications folder. Copy the IOPCIFamily kext you previously downloaded and drop it over Kext Utility it will ask for your password. Reboot.


Now that your PCI devices are detected, Airport will load. Broadcom 4311 working, Marvell Ethernet now is posible.


This Acer model comes with an on-off switch for WIFI. If Airport is loaded but will not turn ON (clickng Turn Airport On makes nothing) Then reboot, when you see the ACER Boot Logo, switch it. Now when macosx loads, Airport will be on, if it didnt work then repeat procedure. If you happen to remove the battery, you will have to repeat this step.


I had a Iatkos S3 v2 disc, i installed the yukon package from it (8038) and it worked . You can search in the hazard page since it looks like it was done by hazard.


Trackpad: look for voodoops2/trackpad version 1.98 it will enable trackpad options. I had trouble installing this kext sometimes it couldn't create cache extensions file, please borrow a usb mouse just in case it is necessary. Before installing, delete acpips2nub and voodoops2 from extra and extensions folder. I ran kext utility after this then i installed.


What I cannot get to work yet:


Cardbus

Memory reader


They are detected but have no clue about proper kext. As far as i know, memory reader will be a hard task and someone says that will not have a chance to work, until cardbus works. Will try to fix this later.


Hope this helps you.



UPDATE:

FAKESMC : updated to version 3.1.0 now shows no errors (something about key not found, it never stopped macos to load but i dislike error messages).

GMA950: Thought you can see flash videos, quicktime and VLC fail to show a image, Preview will not show images. Even setting VLC to output video through openGL fails (no drawable nswindow). Chess is too slow.


Realized that installed VLC was 64 bit. Downloaded and installed 32 bit version. No luck yet.

Installed this botloader but did no difference. Still here is the link since i kept it installed. http://www.osx86.net/video-graphics/10845-msi-wind-u100-gm950-10-6-6-qe-ci-but-no-opengl.html


Ended up installing 10.6.6 kexts found at http://www.insanelymac.com/forum/index.php?showtopic=210660&st=150 OpenGl now works fine, VLC works fine, Chess is faster. I recommend to install the bootloader, since i remember to have tried this kexts before and they didnt worked.


PCMCIA aka Cardbus: Using Chun nan's IOPCIFamily (Version 8) gets detected without loosing Wifi. Unfotunately cannot test it since i currently have no card at hand.


Texas Memory Reader. Got it detected with IOSDHCIblock.kext (edited Plist) but does nothing when inserting a sdcard.(Except when i insert a sdcard prior to boot, shows some messages but fails).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...