Jump to content
iamcap

please help. I am desperate. error dsdt editor :(

Recommended Posts

Hi guys..

Great forum, hope you can help me.


I have wasted 3 weeks trying to get my hackintosh to work :oops::oops:


my system is


asus p8h67-m pro

i5 2500k

8gb ram

using the hd3000 intel graphics from the 2500k

sata hdd with windows set to ahci

external usb hdd with 2 partitions, 1 xmove lion installer, 1 lion partition (and the mac efi partition of course)


I am now trying to get it all working by using a custom dsdt but i have failed very badly so far :oops:


After i extract dsdt using the editor, i then apply the p8h67 m pro.txt patch from the pack page on Olarila. I then try to compile but when i click on fix errors, i always remain with 2 errors:


line 1591 Min/max/length/gran are all zero but no resource tag

1622 same error.


here is my extracted unedited dsdt that i extracted using editor


I installed a clean copy of lion and booted using rBoot from tonycrap, i only installed realtek network next to come here, and nothing else, no easy beast, no userdsdt, nothing yet. I am trying to install a userdsdt with a custom dsdt for my system because i can't get anything else to work!


Can anyone please help me? this is killing me :oops::oops:


thanks in advance

dsdt.aml.zip

Link to comment
Share on other sites

Thanks for the response! You were right, i managed to save dsdt now!


however now i have new problems :(


I'm not sure how to fix, my board has alc892 audio, and i think that is my new problem. I installed audioHDA rollback (only the rollback, i didn't install any other audio kext)


i have attached my latest kernel panic and the patched dsdt


thank you again for your help already, i hope someone out there can help me with this new problem. I feel like a zombie for 3 weeks!

p8h67.thumb.jpg.1c7ea1f994c52a8c3dd2e861df8231e9.jpg

DSDT.aml.zip

Link to comment
Share on other sites

Only AppleHDA rollback won't work, you need a LegacyHDA or a patched AppleHDA, and an HDEF patch in DSDT (or HDAEnabler).


You can also try VoodooHDA http://Olarila.com/forum/viewtopic.php?f=18&t=454


There's no KP in the attached image.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

thank you very much for your help, i understand all of this more now :D :D



I am going to try those fixes for the hda, but i also noticed something more in the -v.


i notice that there is errors about c-states and p-states, it says they were not loaded even though i have GenerateCStatesYesGeneratePStatesYes in the boot plist. You said there was no kernel panic in the image, but my pc stays frozen at that image for a long time so i think it is stuck, could it be the p-states problem that is stopping the pc?


thanks again

Link to comment
Share on other sites

Hi, thanks for again for the help :)


Unforunately it still doesn't want to work! I deleted the dsdt.aml in the extra folder, then loaded lion using rBoot, so i extracted the dsdt again, applied p8h67-mpro patch, from misc patches -> hdef, duallink, new hpet, lpc and from desktop patches -> dtgp, smbus, irqs, rtc.

I then compiled and fixed errors (0 errors), then saved it it as dsdt.aml into the extra folder. I also edited the info.plist from applehda and changed the layoutID to 12 (it was 8) as the hdef patch had 0xc value, i then repaired permissions and kext cache using kext wizard.

And now in -v i am getting still waiting for root device. Would you know what has happened? It even happens in -x -v mode too. I also always still get the "acpi cpus table not found p-states not generated" same for c-states


Before when i only applied p8h67-m pro patch i could get into lion using -x mode, so it must be something new i did!


Do i need to run repair permissions every time i delete the dsdt.aml file and put a new one in the extra folder?


Is this meant to be this difficult haha? :oops:


p.s i have already patched the cpupowermanagement kext with speedstepper also

Link to comment
Share on other sites

Update: I did a rollback HDA in multishit, and now it loads again without any flags and using a new custom edited dsdt using p8ph67 patch, duallink patch, irq, hdef and dtgp! woo hoo progress!


however, the system doesn't have any sound (still have those efi rom hda-gfx errors in -v) and the intel hd3000 graphics card isn't recognised (chipset model: unknown, no kext loaded)


I installed HDEF patch so i can't use voodoo hda, i have a feeling i have to patch the applehda.kext some how? i have alc8xx kext but when i checked the kext loaded with kext wizard, it is not loaded, only applehda and applehdacontroller are loaded. My applehda has a layoutid of 8, and i think it should be 12 (rollback mustve reverted it back to 8?), should i be playing around with that to patch it?


And I have installed macmini 5,1 smbios because apparently that is what you need for intel hd3000 to be recognized, but it isn't working =/ any ideas on that one?


thanks very much again my friend. this has been one of the most frustrating things i have ever done with a computer! :lol:

Link to comment
Share on other sites

If you apply the p8h67-m pro "pack" you don't need to apply the "misc" patches (except DualLink).


There's no need to update cache after replacing DSDT. I don't know what Kext Wizard does in Lion, but a "sudo touch /System/Library/Extensions" is enough to rebuild kernelcache.


I have no idea about patching AppleHDA, I use VoodooHDA.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...