Jump to content
Emanouel

Kernel panic right after install

Recommended Posts

Hello guys

I'm having an issue with my installed high sierra partition,

I've managed to reach the installer by using -v nv_disable=1, installed it, booted up from the hard drive to finish the installation , but once the installation finished.

I've got stucked when a kernel panic no matter what bootflags I was using :/


can someone help me please ?


MSI h61m p31 w8

i5 3470

GTX 1050ti ZOTAC

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

No idea from KP screen, sorry.


Does it happen only in installed system? Both install stages boot without problem?


Are you using UEFI boot? Which drivers in drivers64UEFI?

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

No idea from KP screen, sorry.


Does it happen only in installed system? Both install stages boot without problem?


Are you using UEFI boot? Which drivers in drivers64UEFI?

 

Yes, only on installed system, I couldn't reach installer earlier with regular self made pen drive following the tutorial available on this section,

I used macpwn high sierra, the installation worked perfectly fine, I booted up again for the 2nd time to finish the installation from the hard drive. Everything was going fine.

End of installation.

when I booted up into the disk , I'm having those kernel panic issues, tried out the -v nv_disable=1, still nothing, I've used a bunch of boot flags with no success.


Yes, I'm using UEFI Boot and there are the drivers installed on the pendrive

drivers.png.eff3cda9052ec453ccd4e71e89725c37.png

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

Are you sure you need OsxLowMemFixDrv-64? Try without it.

 

I've launched macpwn again, to create a fresh usb installer, used OsxAptioFixDrv-64,

aaaand ... I reached the system !


woow can't believe it, I'm installing nvidia web drivers to get my pascal gpu full working !

then i'll just copy the efi usb folder settings into my main harddrive


I'll let you know if I have any issues


Thanks for replying this fast ! THAAANK YOU

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

I also had this problem, needed NVWebDriverLibValFix


https://github.com/mologie/NVWebDriverLibValFix/releases

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

I also had this problem, needed NVWebDriverLibValFix


https://github.com/mologie/NVWebDriverLibValFix/releases

 

seems like the partition isn't booting anymore after installing the nvidia web driver, even unticking the box and putting nv_disable=1 isnt working :/

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

Did you try putting NVWebDriverLibValFix.kext into CLOVER/kexts/Other? It worked for me.


The only way to boot without it was removing the webdrivers (NVDA* and GeForce* in /Library/Extensions).

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Did you try putting NVWebDriverLibValFix.kext into CLOVER/kexts/Other? It worked for me.


The only way to boot without it was removing the webdrivers (NVDA* and GeForce* in /Library/Extensions).

 

holly molly its working !

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

 


I used the brand new VoodooHDA 2.9.0 with DevID injected, it works like a charm man


I'm going to check the network now.

fingers crossed

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

Sorry for the double post,

the network kext you gave me isn't working, and not causing any issues..

therefore I'm having issues with imessage, icloud and all stuff related to that.. :/

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

What's your network device? Use this to get vendor and device ID

https://sourceforge.net/projects/dpcimanager/

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Try this one

https://bitbucket.org/RehabMan/os-x-realtek-network/downloads/


If it doesn't work, try RealtekRTL81xx, RealtekRTL8000SL or AppleRTL8169Ethernet.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Try this one

https://bitbucket.org/RehabMan/os-x-realtek-network/downloads/


If it doesn't work, try RealtekRTL81xx, RealtekRTL8000SL or AppleRTL8169Ethernet.

 


"RehabMan-Realtek-Network-v2-2017-0322.zip" is working like a charm, but I'm still having the iMessage/iCloud issue :/

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

I believe iMessage/iCloud issues are not related to network driver, but to SMBIOS and ROM/MLB values. Use Clover Configurator to generate valid serial numbers in SMBIOS section and ROM/MLB values in Rt Variables.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

I believe iMessage/iCloud issues are not related to network driver, but to SMBIOS and ROM/MLB values. Use Clover Configurator to generate valid serial numbers in SMBIOS section and ROM/MLB values in Rt Variables.

 

I've managed to follow some tutorial on youtube doing that but I get this message :


You cannot sign in to iMessage on this Mac at this time.


my Ethernet is on "en0"

MSI H61M-P31/W8 • Intel Core i5 ™ 3470 @3,20Ghz • 8GB RAM • ZOTAC GTX1050Ti 4GB • DUALBOOT HIGH SIERRA/WINDOWS 10

Link to comment
Share on other sites

No idea then. Are you sure the config changes are applied? I mean, the generated config file is in correct place in boot partition. Also make sure the serials are unique (use "generate new" button).

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...