Jump to content
Neo0001

Ajuda com GA B150M Gaming 3 - Kaby Lake-S

Recommended Posts

Olá pessoal!


Como montei meu hackintosh (acho que perfeitamente, funciona há quase 2 anos) na minha GA-Z97MX-Gaming 5, quis ajudar dois amigos fotógrafos a montar os seus. Porééééém não ta rolando, e pelo que li o problema esta no processador Kaby Lake.


Eu achei que extraindo o SSDT no windows e convertendo eu usaria no boot pra instalar, mas vi que também não é assim.


Então se puderem me ajudar com essa mobo, não só fico agradecido como quero fornecer DSDT da mesma e o que for preciso pq provavelmente terão outras pessoas com o mesmo problema.


Segue config e imagens com mais infos sobre a maquina.


• i5 7400 Kaby Lake-S LG 1151

• Gigabyte GA-B150M-Gaming 3 (chipset B150)

• Gigabyte GTX 1050 Ti

• 16Gb de RAM

• SSD 120Gb (Para o windows 10 pros games)

• SSD 250Gb (MacOS para trabalho)

• HD 500Gb para arquivos pessoais

• HD 500Gb para os jogos no windows


Sigo lendo sobre e desde já agradeço a ajuda.

 

cpuid.thumb.png.5cb8d2652e57d1dea2e5a1b7deb16243.png

cachemem.thumb.png.398b8ae05724e2ad6001656536313ec6.png

gpgpu.thumb.png.d3853a1dbb0bfe85b3bf01249f98e413.png

Link to comment
Share on other sites

Se a versão do instalador for anterior a 10.12.6 não tem suporte a Kaby Lake, você tem que usar a opção FakeCPUID do Clover (dentro de binaries patching) com o ID do Skylake (0x0506E3)

https://clover-wiki.zetam.org/Configuration/KernelAndKextPatches#kernelandkextpatches_fakecpuid

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Se a versão do instalador for anterior a 10.12.6 não tem suporte a Kaby Lake, você tem que usar a opção FakeCPUID do Clover (dentro de binaries patching) com o ID do Skylake (0x0506E3)

https://clover-wiki.zetam.org/Configuration/KernelAndKextPatches#kernelandkextpatches_fakecpuid

 

Isso ja fez muita diferença hehehe


Vou refazer o download do Sierra aqui no meu hack, certamente vem atualizado, e vou recriar o pen.

Link to comment
Share on other sites

Consegui instalar! Que alívio. Mas ainda não ta 100%


[OK] Rede: Intel® GbE LAN - Usei a IntelMausiEthernet v2.2.1.d1

[OK] Memórias: ok

[OK] Processador: ok


[ X ] Realtek® ALC892 codec - Escolhi o mesmo no multishit, nao reconheceu nada

[ X ] GTX 1050Ti - Apesar de instalar os drives, qdo reinicio nao fica no "nvidia web drive" e mostra "Display 7MB"

[ X ] O ssd do windows nao inicia pelo clover

Link to comment
Share on other sites

Áudio tem suporte na AppleALC

https://github.com/vit9696/AppleALC


Pode injetar o layout ID pelo Clover

https://clover-wiki.zetam.org/Configuration/Devices#devices_audio_audio-inject


Usa um dos valores indicados na wiki

https://github.com/vit9696/AppleALC/wiki/Supported-codecs


nVidia tem que ativar NvidiaWeb em SystemParameters

https://clover-wiki.zetam.org/Configuration/SystemParameters#systemparameters_nvidiaweb


O Windows pelo Clover acredito que só se for instalado no modo UEFI (GPT).

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Áudio tem suporte na AppleALC

https://github.com/vit9696/AppleALC


Pode injetar o layout ID pelo Clover

https://clover-wiki.zetam.org/Configuration/Devices#devices_audio_audio-inject


Usa um dos valores indicados na wiki

https://github.com/vit9696/AppleALC/wiki/Supported-codecs


nVidia tem que ativar NvidiaWeb em SystemParameters

https://clover-wiki.zetam.org/Configuration/SystemParameters#systemparameters_nvidiaweb


O Windows pelo Clover acredito que só se for instalado no modo UEFI (GPT).

 


Cara, tentei e nada deu certo, foi frustrante hehehe.


Eu peguei o kext do AppleALC na propria pagina, instalei, nada.


Fiz o inject e não apareceu, acho que fiz errado, os parâmetros eu não soube onde colocar. Pelo menos aprendi sobre o ResetHDA e consertei o meu audio hehehe


Apesar de ligar o NvidiaWeb, segue indo pro drive default.


Quanto ao windows, estranhei, pq instalei ele primeiro no meu hack, depois o macOS e tudo ok e identificado.


Vou anexar meu config pra ti dar uma olhada, pode ser? to usando o clover configurator.

config.plist.zip

 

[EDIT]


GA-GTX 1050Ti

Depois de tentar o procedimento 'problem 6' deste Link do tonycrap.


Resultou em tela preta e não resolveu e tive que tirar o EmuVariableUefi-64


Tentei os kext Lilu e NvidiaGraphicsFixup, sem resultado


Audio

Usei o ALC892 e fix 100/200 do multicast, nada pro audio tb


Ajudaria eu extrait o DSDT do hack?

Link to comment
Share on other sites

Gigabyte GTX 1050Ti e Áudio- SUCESSO [Edit]


1050Ti

O principal problema das falhas de instalação da GTX eram o cabo, use um cabo DVI, pq a porta DVI é a primária, senão não funciona.


Após instalar os drives da Nvidia, segui estas configurações:


Essencial opção multishit do clover UEFI + Emulated NVRAM, isso instala o EmuVariableUefi-64 que auxilia no reconhecimento da placa

Se ja tiver com o clover instalado, so habilitar o EmuVariableUefi-64 pelo clover configurator

boot: uncheck nvda_drv=1 e nv_disable=1

System Parameters: check NvidiaWeb


Meu SMBIOS é 18,1


Áudio ALC892

Usei a opção 100/200 series audio + a ALC892

Não tinha dado certo antes, mas agora deu.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...