Jump to content
tornado57

[RESOLVIDO] Tudo funciona, mas boot só com pendrive

Recommended Posts

Olá!


Desculpem se esta dúvida foi solucionada em algum outro tópico, mas li todos com o titulo que remetia ao mesmo problema que o meu e não vi nenhuma solução.


Consegui fazer a instalação do Yosemite e deixar tudo funcionando (rede, som, etc). Porém, eu só consigo dar boot se for com o pendrive.

Instalei o clover e fiz as alterações no config.plist. Creio que estejam corretas pois agora eu não preciso mais digitar os args, é só dar enter no menu do clover no boot que tudo funciona.


No BIOS eu deixei:

boot mode: UEFI only

secure boot: disabled


Quando tento dar boot sem o pendrive a mensagem que me aparece é esta:

Error 1962: No operating system found. Boot sequence will automatically repeat.


No BIOS aparece Mac OS X no Primary Boot Sequence.

Consigo montar a EFI do HD usando o comando sudo mount -t msdos /dev/disk0s1 sem problemas e ver o config.plist, etc.


Alguém tem uma ideia do que faltou eu fazer?

Que informações ajudariam a identificar o problema para que eu possa enviar por aqui?


Obrigado!

Edited by Guest
Link to comment
Share on other sites

O pós-instalação vc segue esse link: http://Olarila.com/forum/viewtopic.php?f=2&t=1713


"O argumento de boot (kernel flag) kext-dev-mode=1 permite que kexts não assinadas (ou com assinatura inválida) sejam incluídas no kernelcache, ou seja, para poder instalar kexts modificadas ou sem assinatura em /System/Library/Extensions é necessário usar esse argumento. Se você colocar essas kexts na pasta EFI/CLOVER/kexts/10.10 o parâmetro não será necessário."

10.15.1 NvmeM2 SSD 500 GB X570 Aorus Elite - Ryzen 7 5800X - 32 GB DDR4 3600 MHz - Radeon RX 580 8GB

10.15.7 SSD120 GB GA-EP45T-DS3R - 16 GB DDR3 1600 MHz - GTX 760 2GB.

Link to comment
Share on other sites

Já segui o roteiro de pos-instalação, as kexts estão funcionando, som, rede, tudo ok conforme eu comentei.


A única coisa que não está funcionando é o boot sem o pendrive. Já tentei instalar o Clover de diversas maneiras e de forma alguma funciona.


Já tentei também marcar a partição usando o fdisk, o que só piorou a situação (meu HD some do menu de boot do Clover).

Link to comment
Share on other sites

Você fez isto?

Faça boot novamente pelo pen drive. No menu do Clover, entre na opção Clover Boot Options e selecione Add as UEFI boot option. A partir de agora você conseguirá iniciar sem o pen drive, pelo Clover da partição EFI, no modo UEFI.

http://Olarila.com/forum/viewtopic.php?f=3&t=2831


O boot pelo pen drive funciona no modo UEFI only?

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Olá pernacabeluda! Obrigado pela ajuda.


No menu do meu Clover, existem duas opções "Clover Boot Options"


A primeira começa com PciRoot(0x0)\Pci(0x1D,0x0), ...

A segunda começa com PciRoot(0x0)\Pci(0x1F,0x2), ...


Em nenhuma delas existe a opção "Add as UEFI boot option"


As opções que aparecem são:


Add Clover boot options for all entries

Remove all Clover boot options

Print all UEFI boot options to log

Return


Desculpe minha ignorância, mas não sei lhe responder se o boot pelo pendrive funciona no modo UEFI only. Isso seria escolhendo que opção? Se for a Boot UEFI internal from EFI, quando seleciono essa opção aparece outro menu com outro tema, onde seleciono o boot pelo meu HD e fica apenas um cursor na tela por um tempo e depois volta para o mesmo menu.

Link to comment
Share on other sites

Se aparece o menu "Clover Boot Options" o boot foi no modo UEFI.


Ele aparece duas vezes porque tem dois drives com o Clover, o pen drive e o HD.


Talvez o problema seja que no BIOS está selecionado o Clover do USB como boot primário. Tenta usar a opção "Remove all Clover boot options" depois "Add as UEFI boot option" somente no menu "Clover Boot Options" referente ao SATA (0x001F0002).

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

pernacabeluda, muitíssimo obrigado! Agora funcionou com suas dicas.


Entrei nas duas opções "Clover boot options" (acho que não precisava ir nas duas, mas fiz pra garantir), depois entrei na segunda opção que começava com PciRoot(0x0)\Pci(0x1F,0x2) conforme recomendou, e escolhi a opção "Add Clover boot options for all entries", já que não tem a opção "Add as UEFI boot option" que recomendou.


Depois disso removi o pendrive e funcionou o boot normalmente!!! Valeu mesmo... Resolvido!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...