Jump to content
Giatuareg

Yosemite Vaio Vpceb3m1e

Recommended Posts

Hi guys, after one year here I am again with some issues regarding 10.10 installing.

Thank you guys of the raw image, I've installed the OS with no problems, installed FakeSMC and Power Management. I'm getting crazy with the ATI mobility 5650. I've modified the kext ATI 5000 and AMD3000X adding my device id under IOPCIMATCH line, tried several AtiConfig (Langur, Megalodon, Zonalis and Orangutan..)

It worked for maverick with the force edid but no luck with yosemite. It works when i plug and HDMI but no luck with the laptop screen, with some AtiConfigs i see the backlight but no image, Please any ideas?

thank you so much guys

Link to comment
Share on other sites

hello


my ati 5470 is working native in yose .. with clover .. in the installer and in system


InjectAti=true

InjectEdid=true

LoadVbios=true

FBname=Langur


the 5650 is not native in ati kext


maybe need to fakeid to 68e01002 .. native in kext .. that is the dev id for 5470


http://clover-wiki.zetam.org/Configuration/Devices#FakeID


if u try that .. use the original kext .. make a new usb pen..


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Hi there Arthur is good to see you again. One quick question what you mean with official supported? i've found the 5650 Device and produce id into the amd5000 kext by default, i had just to add into the amd3000x kext one, i've seen 4 IOPCIMATCH in there, i've add the 5650 ID under the Redwood family class (is the class of the 5650 according to wiki). Also is possible that it was working right under maverick ( i m not sure how i made it working cause i modified the 717 edid AND added also the IOPCIMATCH lines), had the usual gradient problem but beside that everything perfect. Should i reverted the graphic kext from 10.10 to the 10.9? blasphemy? :)

Sorry but never tried the fake id way, have to study that cause don't really know how to use..

greeting fixers

Link to comment
Share on other sites

hello


what i mean .. is that .. 68e0 is native in apple kext .. and should be under cedar family .. i think


and reverted kext .. i think not work .. u can try..


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

ohh i got it, thanks i'll try with fake id, even if according to the original amd5000 kext :


0x68981002 0x68991002 0x68E01002 0x68E11002 0x68D81002 0x68C01002 0x68C11002 0x68D91002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002


5650 Device and Prod ID are there :|

Link to comment
Share on other sites

Little update, nothing solved but here is infos that can help other people with the Ati 5650 mobility.

Boot args: Screen_Shot_2014_11_06_at_14_04_06.png

Using the first raw image from Olarilly, don't know if the 2nd one atm on IRC is more updated or such.

Kexts are corrected with the right DEVICE and VENDOR ID which are for Ati5650:

0x68c11002, already inside AMD5000controller.kext by default. Only have to add into ADMRadeonx3000.kext.


Here the results:

 

  • GraphicsEnabler=Yes - No FB

    Backlight internal LCD working, no Image/output
  • GraphicsEnabler=Yes - FB=Zonalis

    Hang at boot
  • GE=Yes, FB=Langur

    Backlight working, No Image /output
  • GE=Yes, FB=Megalodon

    No internal Image, HDMI = FULLY WORKING with QECI (frame buffer loaded)
  • GE=YES FB=Hoolock

    gives memory Allocation Error, System Halted into boot
  • GE=YES, FB=Orangutan

    No Internal/no Hdmi, Backlight working on internal
  • GE=YES FB=Eulemur

    Backlight working, No image No hdmi
  • GE=No, FB=None

    Working on internal screen, without Framebuffer loaded so no QECI and choppy/poor res

:oops:

Link to comment
Share on other sites

I've managed other stuff like bluetooth, wifi and such. With the HDMI/VGA cable connected and FB=Megalodon i have full QE/CI working and let me say that is WAY MORE faster and stable than Maverick. Benchs says that is faster of my windows 8 :lol:

I will not stop until the internal monitor will works right.

Can somebody modify the Title to Ati5650Mobility? cause i think fits more and i'm sure can help more people that are waiting to upgrade from ..10.8/10.9 to 10.10



I've also tried to follow Arthur suggestion about fake ID but i think it's a dead line cause it only hangs on error and also there is natively support to the ati5650m ,Device and Vend IDS are into AMD5000 kext so IT HAS TO WORKS sooner or later :)

The Fake ID leads to:

IMG_0117.jpg



Instead, the Hoolock FB which worked perfect with maverick and my force edid file, Now leads to this:

IMG_0120.jpg


Never seen that message before and i can't find enough informations on the web

greeting fixers

Link to comment
Share on other sites

Hi guy, i have the same vaio vith maverick (everything is working) and yosemite, all working but the hd5650 mobility is detecetd but slow as hell.


Did you find any solution? I ve tried all drviver , fb, and edid without success. Before giving up i will try to get thre gpu bios and patch the binary inside atihd5000 kext file. I will let u know. If anyone has this rom already, please send it to me. I ve tried gpuz but its not working (im testing now other solution to extract the gpu bios)



Thanks for your help

Edited by Guest
Link to comment
Share on other sites

Hi guys, I made it works Vaio VPCEB1m1e with clover full QE/CI :)


it took me long time but I'm so Happy I made it (It is faster than my real MBP 2011).


if you are interrested look here in Vaio section :


http://wiki.osx86project.org/wiki/index.php/HCL_10.10.1/Portables#VPCEB1M1E


I'm Still having to find a way to tweak Sleep issues and test Yukon(Lan) driver, and Brightness control


Cheers

Link to comment
Share on other sites

Hi! I've succeded installing 5650 on vaio EC3M1E but i can't install power management, Please help me :D i've tried to patch dsdt, there was about 180 errors, but dsdt editor fixed it, if i try some HPET for nehalem patch it gives me unfixable errors, LPC patch works, but still no Power Management :/ Please tell me what should i do?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...