Jump to content
oldnapalm

Asus G73Sw

Recommended Posts

  • Administrators

Added kexts:


/System/Library/Extensions/ACPIBatteryManager.kext

/System/Library/Extensions/AppleHDAALC269.kext

/System/Library/Extensions/AsusNBFnKeys.kext

/System/Library/Extensions/EAPDFix.kext

/System/Library/Extensions/FakeSMC.kext

/System/Library/Extensions/GenericUSBXHCI.kext

/System/Library/Extensions/LegacyAGPM.kext

/System/Library/Extensions/RealtekR1000SL.kext

/System/Library/Extensions/VoodooPS2Controller.kext


Added plist:


/System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext/Contents/Resources/MacBookPro8_4.plist


Clover files:


/Volumes/EFI/EFI/CLOVER/ACPI/PATCHED/DSDT.aml

/Volumes/EFI/EFI/CLOVER/config.plist (ROM and CustomUUID zeroed out)

/Volumes/EFI/EFI/CLOVER/TOOLS/Shell64U.efi (default one does not work)

/Volumes/EFI/EFI/CLOVER/drivers64UEFI/HFSPlus-64.efi (replace VBoxHfs-64.efi)


In /Volumes/EFI/EFI/CLOVER/drivers64UEFI you also need (for UEFI boot):


FSInject-64.efi (default)

OsxAptioFixDrv-64.efi (select in Clover installer)

OsxFatBinaryDrv-64.efi (default)

 

Asus G73Sw OS X Yosemite 10.10.zip

 

To avoid black screen problem add the Board-ID into ConfigMap in the file /System/Library/Extensions/AppleGraphicsControl.kext/Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist

                                <key>Mac-942459F5819B171B</key>
                               <string>none</string>

 

For installation and first boot use a compatible Board-ID like Mac-FC02E91DDD3FA6A4

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Hello,

it doesn't work here on my G73 using clover and your setup files... i have copied everything in the right folders, i did all the modifications in the right places but i just have black screen and a reboot . My G73 has bios modification for AICPUPM. I can only install Yosemite with latest chameleon, not with Clover. Any suggestion?

Thank you

K

Link to comment
Share on other sites

  • Administrators

If you use a patched BIOS, maybe your DSDT is different than mine and you can't use my patched one.


Compare your original DSDT with mine (attached), if they are different you need to apply the patches on yours instead of using mine.


Also disable AsusAICPUPM.

DSDT.aml-original.zip

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Hello,

thanks for your reply. My problem is with clover. With chameleon (latest one) i can boot and i can use it(with some problems, audio works just with applehda patched for mavericks etc etc). I would like to use clover for its great patches, that i can use internally in config.plist. Perhaps i have installed clover in a "bad" way. May you please give some more instructions on how to install clover with which exact parameters in this guide ? Thank you very much!

K

Link to comment
Share on other sites

  • Administrators

There are no special parameters for Clover install, just the files included in the package. It works on both UEFI and legacy mode.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

  • Administrators

This installer works for me

http://Olarila.com/forum/viewtopic.php?f=36&t=5009


Just change the Board-ID as I mentioned in OP.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Hi,


I used this installer http://Olarila.com/forum/viewtopic.php?f=36&t=5009 , installed latest clover like here http://www.tonycrapx86.com/yosemite-desktop-guides/144426-how-install-os-x-yosemite-using-clover.html , copied all the files like in instructions (the Board-ID was already there Mac-FC02E91DDD3FA6A4, did not need to add anything), but i still get the black screen!!


This is is the last screen. It stays like this for ~2 mins and then goes black... Can someone please give some advice?

g73sw.thumb.jpg.4c55784954e6c5c41f0013d7d70a5772.jpg

Link to comment
Share on other sites

  • Administrators

If you used my files, the Board-ID in config.plist is Mac-942459F5819B171B, you need to add it in AppleGraphicsDevicePolicy.


Mac-FC02E91DDD3FA6A4 is iMac Board-ID, you may use it to avoid black screen in first boot but I don't recommend keep using it after post install.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Hello everyone,


I've tried this guide but i can't reach te installer :? These are my steps:

1) Extract OSX 10.10 with the unarchiver

2) Use terminal to extract the .raw file on the USB

3) Copy the kexts in this topic in the extension folder

4) Copy the plist

5) Add this string

Mac-942459F5819B171B

none


6) Put the USB in my Asus pc, reach the clover boot loader, select boot mac OSX from OSX install USB and hit enter

7) There will be al lot of lines and by the last line it stops or i get a black screen.


I've tried this many times with other settings:

- With the other string

Mac-FC02E91DDD3FA6A4

none

- With the newest Clover installed with different settings


But none of this works.


Can somebody help me??

Link to comment
Share on other sites

  • Administrators
For installation and first boot use a compatible Board-ID like Mac-FC02E91DDD3FA6A4

That means, enter Clover options menu and change that value before booting the installer.


This other part you will do after installing

To avoid black screen problem add the Board-ID into ConfigMap in the file /System/Library/Extensions/AppleGraphicsControl.kext/Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/Info.plist

                                <key>Mac-942459F5819B171B</key>
                               <string>none</string>

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Hello.

I'm using unishit + multishit combination now, not Clover.

Audio, Network, and other many things are not working.

Is it possible to just patch the attached kext files by using kext installer?

Or should I have to re-install Yosemite using Clover?

Link to comment
Share on other sites

  • Administrators

I have no idea what those beasts do. Attached files are for use in clean install with Clover.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Hi oldnapalm! Thank you very much!!

All is right, Lan, video, etc. but i haven't audio...

I can see in system information an Intel High Definition Audio controller, but not in sound preference panel..

which would be the problem? any recommendation?


Javier

Link to comment
Share on other sites

  • Administrators
I can see in system information an Intel High Definition Audio controller, but not in sound preference panel..

which would be the problem? any recommendation?

Don't forget the original AppleHDA.kext in /S/L/E and extract the attached file in OS X, because AppleHDAALC269.kext has a symbolic link which will be broken if you unzip in Windows.

 

I've done all the steps but I get stuck at the white screen after loading the apple logo.


How can I fix this?

You are probably missing FakeSMC.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

  • Administrators

You need both kexts, original AppleHDA and AppleHDAALC269.


Expand the zip in OS X because AppleHDAALC269 contains a symbolic link.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

So i have to expand the zip in your first post and copy AppleHDALC269 to S/L/E?


Is it a problem that i have installed yosemite with your guide and files, and after finish the installation I installed the kext in your zip with kextwizzard? Or is this not necessary because we copied the kext into the installeren USB?

Link to comment
Share on other sites

  • Administrators

Yes.


Kexts and files are for post installation, you don't need to put them in the installer USB.


For audio you also need the patches in KextsToPatch section of config.plist as in my sample file.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

So this are the steps I have to make:

1) Make bootable USB with unishit of Yosemite 10.10.2

2) Install Clover on USB, with selected drivers64UEFI, OsxAptioFixDrv-64.efi

3) Copy Clover files to USB


/Volumes/EFI/EFI/CLOVER/ACPI/PATCHED/DSDT.aml

/Volumes/EFI/EFI/CLOVER/config.plist (ROM and CustomUUID zeroed out)

/Volumes/EFI/EFI/CLOVER/TOOLS/Shell64U.efi (default one does not work)

/Volumes/EFI/EFI/CLOVER/drivers64UEFI/HFSPlus-64.efi (replace VBoxHfs-64.efi)


4) Copy FakeSMC.kext to USB /Volumes/EFI/EFI/CLOVER/KEXT/10.10


5) Boot USB, change in Clover Board-ID en start the installation with injected kext


6) After installing yosemite and reach the desktop, install Clover on Mac HD, with selected drivers64UEFI, OsxAptioFixDrv-64.efi


7) Copy kexts:


/System/Library/Extensions/ACPIBatteryManager.kext

/System/Library/Extensions/AppleHDAALC269.kext

/System/Library/Extensions/AsusNBFnKeys.kext

/System/Library/Extensions/EAPDFix.kext

/System/Library/Extensions/FakeSMC.kext

/System/Library/Extensions/GenericUSBXHCI.kext

/System/Library/Extensions/LegacyAGPM.kext

/System/Library/Extensions/RealtekR1000SL.kext

/System/Library/Extensions/VoodooPS2Controller.kext


8) Copy plist:


/System/Library/Extensions/IOPlatformPluginFamily.kext/Contents/PlugIns/ACPI_SMC_PlatformPlugin.kext/Contents/Resources/MacBookPro8_4.plist


9) Copy Clover files:


/Volumes/EFI/EFI/CLOVER/ACPI/PATCHED/DSDT.aml

/Volumes/EFI/EFI/CLOVER/config.plist (ROM and CustomUUID zeroed out)

/Volumes/EFI/EFI/CLOVER/TOOLS/Shell64U.efi (default one does not work)

/Volumes/EFI/EFI/CLOVER/drivers64UEFI/HFSPlus-64.efi (replace VBoxHfs-64.efi)


10) After restart everything will work??????


Or should I install the kexts with kext wizzard????

Link to comment
Share on other sites

  • Administrators

7) Copy kexts:

Just copy won't do it, you need to repair permissions (chown 0:0 and chmod 755) and update kernelcache, or use some tool to install (make sure it's updated to work with Yosemite).


You need kext-dev-mode=1 in boot arguments before rebuilding kernelcache or unsigned kexts won't be included.

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
  • Create New...
The popup will be closed in 15 seconds...