Jump to content
gagua50

Hackintosh Dell Inspiron 14r 5421

Recommended Posts

Boa tarde pessoal, vou relatar minha instalação do hackintosh no meu notebook:


Minha configuração é:

Core i7-3537U @ 2.00

2x4GB 1600MHz

Intel hd 4000

Atheros AR9485 Wireless

Realtek RTL8101E/RTL8102E PCI-E



1º) Baixei a imagem usb do forum e subi pelo chameleon com as flags -x -v -f GraphicsEnabler=Yes IntelCapriFB=3 a instalação subiu normal


2º) Segui a instalação corretamente e dei boot com as mesma flags, e instalei as seguintes Kexts (Pelo KextWizzard):


FakeSMC (Necessária)

NullCPUPowerManagement (Necessária caso tivesse problema com as kexts de bateria)

PS2_Voodoo (Para o Touchpad funcionar)

VoodooHDA (Universal para o audio funcionar)

VoodooBattery e AppleACPIPlatform 1.3.6 (http://www.mediafire.com/download/l46x8zez97lta7y/AppleACPIPlatform.kext-1.3.6.zip) (Para a bateria)

GenericUSBXHCI(Para USB)


e removi as kexts NVDA* GeForce* ATI* AMD*.


3º) A seguir instalei o chameleon da seguinte forma:


Baixei o pkg do chameleon (http://Olarila.com/files/Bootloader/Chameleon/Chameleon-2.2svn-r2187.pkg.zip) e instalei ele apenas clicando next, depois instalei ele de novo, mas dessa vez personalizando a instalação para apenas instalar os extras.


Baixei o Chameleon wizzard e configurei ele da seguinte forma:


SMBios: MacBook Pro 9.2 e salvei ela na pasta Extra (que fica na raiz do disco)

org.Chameleon.boot: Como a foto anexa e salvei também na pasta extra


Selecionei o tema como default e então instalei o ele como bult-in.


Pronto, neste momento tive um hackintosh ligando funcional, então desativei minha placa de video Nvidea (http://Olarila.com/forum/viewtopic.php?f=7&t=3084) e o notebook está assim:


Audio: Funcionando

Video: HD4000 funcionando nativamente

Som: Funcionando com a VoodooHDA

HDMI: Funcionando, mas sem saida de som.

TouchPad: Funcionando com VoodooPS2.

USB: Funcionando com GenericUSBXHCI.

Sleep: Funcionando as vezes (problemas com a usb sleep).

Brilho da tela: Não funciona.

Rede WiFi: Atheros AR9485 não é compatível então estou com um usb da Ralink e esperando minha AR5B93 chegar para substituir. edit: minha AR5B93 chegou e está funcionando 100%.

Rede Ethernet não funcional por enquanto. edit: funcionando com este tutorial http://www.insanelymac.com/forum/topic/281410-realtek-lan-rtl8101ertl8136-working-1080-mountain-lion/

Indicador de bateria: Funcionando perfeitamente com VoodooBattery e AppleACPIPlatform 1.3.6.


Caso alguém saiba como corrigir o sleep por favor me ajude.

org.Chameleon_boot.png.0a856c122d47c10c2d64a83e17bc7e56.png

Edited by Guest
Link to comment
Share on other sites

  • Administrators

Olá, seja bem-vindo.


Para obter o audio na HD 4000, veja aqui: http://Olarila.com/forum/viewtopic.php?f=3&t=4602

Gerenciamento de Energia: http://Olarila.com/forum/viewtopic.php?f=2&t=34

Thanks & Regards

IdeaPad Gaming 3i  Aspire A515-52 • Clover / OpenCore
We are in a great Forum, so, let's have some fun and learn from each other!

btn_donate_SM.gif

Link to comment
Share on other sites

olá


testa este

 

[attachment=0]DSDT.aml.zip[/attachment]

 

bom hack

 

Agora o brilho ta funcionando perfeito, obrigado, uma pergunta você sabe no teclado qual teclas devo usar? Outra coisa, o método que eu usava para desativar a geforce não funcionou nesta dsdt que você mandou, sabe o porque?

Link to comment
Share on other sites

olá


nõ sei k método usavas ...


mas n fiz nada no dsdt referente a gráficos.. nem sei teu ig-platform-id..


quanto às teclas também não .. devem ser as que mexem com brilho.. se existirem no teclado.


mas podes sempre ajustar o brilho.. nas preferências de sistema .. monitores


bom hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

O brilho pode ser ajustado tambem com as teclas Fn.


Aqui funciona nativo o controle de volume, já o brilho tem que ser as teclas Pause e ScrLk.

 


Aqui não tenho estas teclas, vou tentar editar depois para funcionar nas teclas Fn



eu usava o metodo que postei acima para desativa-la, estou ainda em busca do que fazer agora.

Link to comment
Share on other sites

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Qual kext você está usando para USB 3.0?

 

Estou usando esta:

GenericUSBXHCI.kext


mas tenho instaladas as seguintes kexts tbm que não sei se podem influenciar:

AHCI_Extended_Injector.kext

AHCIPortInjector.kext

IOAHCIBlockStorageInjector.kext

Link to comment
Share on other sites

Estou também tendo um problema ao logar na App Store que nunca tive antes em outras instalações, aparece o seguinte erro:


Seu dispositivo ou computador não pôde ser verificado. Entre em contato com o suporte para obter assistência.



edit

Já resolvi, só adcionar a interface ethernet como primeira...

Link to comment
Share on other sites

Olá amigo.

Possuo um notebook similar ao seu (inspiron 14R 5420) e segui seu tutorial, porém não estou conseguindo fazer as usb funcionarem..

Se uso a GenericUSBXHCI o sistema não reconhece pendrives e meu mouse usb 2.0.

Depois que o note acorda do sleep o touchpad também não funciona.. Voc conseguiu arrumar isso?

Sabe o que pode ser?


Muito Agradecido, abrass

Edited by Guest

Ryzen 3400G @ 3.7Ghz | 2x8GB DDR4 3000Mhz | Gigabyte B450 Gaming X | Radeon RX 570 4GB | Samsung 750 EVO 250GB | macOS Catalina 10.15.4

Link to comment
Share on other sites

Boa noite, tente utilizar as kexts que citei a cima quando me perguntaram sobre quais eu uso, só subir alguns posts...


Allan, me fale melhor sobre dsdt para usb 3.0, ele elimina o uso da kext? resolveria meu problema de sleep?

Link to comment
Share on other sites

Gagua, voc poderia fazer um rar delas e me enviar?

Não estou conseguindo achar elas :s


Muito Obrigado :D

Ryzen 3400G @ 3.7Ghz | 2x8GB DDR4 3000Mhz | Gigabyte B450 Gaming X | Radeon RX 570 4GB | Samsung 750 EVO 250GB | macOS Catalina 10.15.4

Link to comment
Share on other sites

Se a GenericXHCI não está funcionando pra você, tenta baixar a PXHCD.

[attachment=0]Unlocked-Ver.1.0.11-PXHCD.kext.zip[/attachment]

 

Allan, essa também não funcionou cara :c

Sinceramente não sei o que pode ser.. Antes de instalar o chameleon tava reconhecendo pendrive 2.0 (todas as portas do meu note são 3.0) e não reconhecia 3.0, porém agora depois da instalação do bootloader não reconhece mais 2.0 e mesmo com as kexts "GenericXHCI e PXHCI" não reconhece 3.0..

Ryzen 3400G @ 3.7Ghz | 2x8GB DDR4 3000Mhz | Gigabyte B450 Gaming X | Radeon RX 570 4GB | Samsung 750 EVO 250GB | macOS Catalina 10.15.4

Link to comment
Share on other sites

  • Administrators

Reconheço que ativar as portas 3.0 é punk mesmo. Mas vamos lá.


Se for usar a GenericXHCI, as kext IOUSBFamily e IOUSBMassStorageClass devem ser as originais do OS X, sem modificações. E pra ter o funcionamento garantido, tem que aplicar o patch para USB 3.0 na DSDT.


Se for usar a PXHCD, dai as kext que vem juntas (IOUSBFamily e IOUSBMassStorageClass) elas já estão modificadas, dai faça backup das originais e instale essas. E o uso de patch é necessário.


E se estiver usando Chameleon, veja se seu boot.plist tem essas 2 opções habilitadas:

2096447267_ScreenShot2014-06-12at12_40_57AM.png.070b026b0274d1176e11f2ce6c3a5d75.png

 

Se usa Clover, tem que estar assim:

1731367035_ScreenShot2014-06-12at12_46_34AM.png.6386ca98168053bba359078ea5f7800c.png

 

Patch para DSDT: http://Olarila.com/Patches/Notebook%20Core%20i%20Ivy%20Bridge/XHCI.txt


Teste ai, e volte com os resultados.

Thanks & Regards

IdeaPad Gaming 3i  Aspire A515-52 • Clover / OpenCore
We are in a great Forum, so, let's have some fun and learn from each other!

btn_donate_SM.gif

Link to comment
Share on other sites

Reconheço que ativar as portas 3.0 é punk mesmo. Mas vamos lá.


Se for usar a GenericXHCI, as kext IOUSBFamily e IOUSBMassStorageClass devem ser as originais do OS X, sem modificações. E pra ter o funcionamento garantido, tem que aplicar o patch para USB 3.0 na DSDT.


Se for usar a PXHCD, dai as kext que vem juntas (IOUSBFamily e IOUSBMassStorageClass) elas já estão modificadas, dai faça backup das originais e instale essas. E o uso de patch é necessário.


E se estiver usando Chameleon, veja se seu boot.plist tem essas 2 opções habilitadas:

LegacyATI4800Controller.kext.zipScreen Shot 2014-06-12 at 12.46.34 AM.png[/attachment]

 

Patch para DSDT: http://Olarila.com/Patches/Notebook%20Core%20i%20Ivy%20Bridge/XHCI.txt


Teste ai, e volte com os resultados.

 

Valeu cara!!!

Fiz todos os procedimentos que voc me indicou..

- Coloquei as kexts IOUSB originais só pra garantir

- Fiz as modificações no Chameleon

- Apliquei o patch XHCI na dsdt (junto com o DTGP)

E a USB continuou não funcionando aisudhasuoda

A kext IOUSBMassStorageClass não está carregando, acho que pode ser esse o motivo..

Ela só carrega por meio de dsdt ou deveria carregar normalmente?


#Edit

Não sei se isso pode ajudar:

43lh.png

Ryzen 3400G @ 3.7Ghz | 2x8GB DDR4 3000Mhz | Gigabyte B450 Gaming X | Radeon RX 570 4GB | Samsung 750 EVO 250GB | macOS Catalina 10.15.4

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...