Jump to content
zentili

Display not waking up from sleep

Recommended Posts

Hi all!

Recently i have switched from Mountain Lion 10.8.5 to Mavericks 10.9.3 on my laptop Acer Aspire 5740g - intel core i7 620m - ATI Mobility Radeon HD 5470 512 mb. With Mountain Lion i managed to get sleep (and graphics in general) working properly by making a connectors patch and injecting that patch + my custom EDID through the Clover bootloader. Now with mavericks i use that same patch and EDID and the resolution + QE/CI are working good BUT i'm having a little problem with the sleep or to better say, the waking up from sleep. The system goes to sleep properly but when i wake it up, it wakes (i hear the fans and even the system sounds) but the display stays black, no backlight, just black, it doesn't wake up. Now i have tried various edits to the connectors patch but no changes. I even tried different values to the darkwake flag but it didn't work too. I'm considering trying a Sleepenabler kext but i don't even know if it would be a good idea because the system sleeps and wakes, it's just the display that won't wake up. I have to say i don't use a custom-edited DSDT because the patches that come with clover do (or at least used to) the job. I'm just about to try different approach to solve this thing but i don't know which would be the best. I don't understand what is the exact difference between the mountain lion and mavericks sleep thing, i think if i could point that, i could even solve my problem. That's the reason why i'm talking here, maybe someone could help me with this! Any idea, much appreciated.

Link to comment
Share on other sites

hello


i never have sytem wake in 5470m


from sleep black scren


so...


what u want a miracle.. if so u ask to pope Francisco


be glad ur graphics are working


many mac machine don't sleep well


u want a hackintosh .. sleep well .. how many mac netbooks u know works with a 5470m ?


give me 1


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

man, i don't need any pope francisco here :D


i had it working perfectly with mountain lion, going to sleep and waking up very good. Now i got it working on mavericks, it's just one little issue. I need some help with the controllers patch, not a miracle :)

Link to comment
Share on other sites

  • Administrators

Thanks & Regards

IdeaPad Gaming 3i  Aspire A515-52 • Clover / OpenCore
We are in a great Forum, so, let's have some fun and learn from each other!

btn_donate_SM.gif

Link to comment
Share on other sites

man, you saved me! That's definitely a solution. it is working with hibernatemode 21, but when it wakes, the usb mouse/keyboard are dead.. should i use some other mode? is there any place to look for which would be the best to me?

Link to comment
Share on other sites

ok, i will apply the patch and let you know.


one other thing i have noticed is that, sometimes after hibernation, when i wake it up it doesn't recognized the trackpad and the laptop keyboard behaves strangely (mismatched buttons) and i have to restart but this just happens some times, not all the times.

Link to comment
Share on other sites

  • Administrators

Use this code:

perl -e 'open(CMD, "ioreg -lw0 \| grep DSDT|") or die; while(<CMD>) { chomp; if($_ =~ /\"DSDT\.?\d?\"=<([^>]*)>/) { $buff = $1; open(PIP, "|xxd -r -p > dsdt.aml") or die; print PIP "$1"; } }'

Thanks & Regards

IdeaPad Gaming 3i  Aspire A515-52 • Clover / OpenCore
We are in a great Forum, so, let's have some fun and learn from each other!

btn_donate_SM.gif

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...