Jump to content
cw9000

After installation partition not listed

Recommended Posts

I have 2 hard drives. One with Windows and OpenSUSE Linux using grub2 ,the other was just a 3 TB drive for keeping large files. I used gparted to partition the 3TB into 2 partitions. The first one takes up 2,950 GB and the second takes up 50GB. I used Suse Studio for openSUSE to write the raw image of mountain lion. All went fine

When I booted into the install I had to boot using GraphicsEnabler=No -f

I erased the data on the 50GB partition using Disk Utility and formated it to a Mac OS Extended Journaled and named it MAC-OS-X

The first partition on that 3TB drive is called extra_space_2 and is ntfs. The 3TB drive is obviously gpt.


I then closed out of the Disk Utility and clicked on Install. All seemed to go well with the install and my computer rebooted itself.

When booting from the USB I get 4 selections.

hd(0,1) OS X Install USB

hd(1,1) OS (windows)

hd(1,8) extra_space (just extra space on the first hard drive)

hd(2,1) extra_space_2


The Mac-OS-X drive isn't showing.

I thought maybe the boot flag was the culprit so I used a gparted live cd and set the boot flag. Still doesn't show up.

If I select extra_space_2 obviously it comes up with a BOOTMGR is missing error, I need it to boot hd(2,2)


My Sata is already set for AHCI


I have an ASUS p8h61-LE/CSM mobo and i5-2500k cpu

the hard drives are both western digital.

Thank you for any, all help

Link to comment
Share on other sites

Chameleon has a size limit for the boot partition (1 TB), maybe it also fails if the partition starts after the first TB of the HD. I'm just supposing this, I haven't tested it myself.


You can try creating a partition in the beginning of the HD, or try the Clover boot loader. You can download this Mavericks image which has both Chameleon and Clover


http://Olarila.com/forum/viewtopic.php?f=9&t=4578

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Thank you Perna...

So I downloaded the Maverick image and put it on a 8GB USB flash drive.

Clover recognized my MAC-OS-X partition. I went into options and put GraphicsEnabler=No -f into the boot args.

Then I selected Mountain Lion to boot.

It stopped at USBMSC something or other and then would output "Waiting for root device" every couple of minutes.

Don't know what's up. I have a printer connected, maybe that's the culprit???

I tried with -x as a boot option, as well, to run in safe mode. Same problem.

But now I'm waiting for gparted to move my 2+TB to the right and I'm putting 100GB at the start of my 3TB drive, then I'm going to install to that first partition. Don't know what else to do. I should've tried unplugging my printer, but I had already started gparted. It takes a day to move that amount of data.


Any insight into my problem would be appreciated.

Link to comment
Share on other sites

Well I successfully booted into my hackintosh. I tried moving the intel kext files, but that didn't work. So I tried installing Maverick to my first 100GB partition I made, which took 2 days to make using gparted. But the first thing I tried to do was to erase the partition, and thus format it as journaled. It errored with a encryption disk error. WTF. anyway, I booted into Mountain Lion usb install and chose to erase from there and it had no problems. So I figured maybe Moutain Lion was more stable so I installed that to that first partition. This time it listed it after installation and I successfully booted into a graphical hackintosh via usb bootloader. I installed the chameleon boot loader via the chameleon wizard using boot0 and created the folder /Extra and saved a chameleon.Boot.plist thing there. Don't know if its actually using that or not. I edited it to have the key GraphicsEnabler and string No. I installed FakeSMC from multishit 5.5. I rebooted, booted into openSUSE and ran the script for updating grub2

grub2-mkconfig -o /boot/grub2/grub.cfg

in openSUSE. Rebooted and selected the OS X for 64-bit in the grub2 menu and it booted. But I had no audio and no wifi. I found the kext that worked with artheros AR928x from http://Olarila.com/kexts/ and installed using the recommended kext installer. In multishit I installed the Null cpu power thingy and also the ALC887 driver -Current/no dsdt. I also tried Legacy later.

So now I have wifi on my hackintosh.


What I don't have:

Audio -- System Preferences->Sound->Output says No devices. Don't Know what to do about this, searched and searched. I read my mobo manual and it specifically says ALC 887


USB- my usb seems flakey. It reads devices fine when they are plugged in b4 boot. But if plugged in after boot, it says that I didn't eject it correctly--which I'm not doing, I'm inserting it. Tried to be careful to just stick it in without any movement to make it think I was ejecting it.


non-flickering video. when I go to a new tab in Safari I get flickering on that initial screen. I'm sure I would also get it with any video, cuz the same thing happened on my virtualbox of hackintosh. I'm kinda afraid to do anything with video because once I installed FakeSMC and booted w/o usb it has given me better resolution.


I also don't know how to enter boot options such as -x for safe mode from grub2. I believe it's running the mach-kernel thing directly instead of using the boot file. I'll have to experiment with that. If I hit e, I can edit the grub2 entry and there is a list of arguments being sent, but I don't know if -x would work with that. Once you're booted how do you know if you are in safe mode? -- EDIT actually I just read that it says it at the login screen, I'll have to try -x.


EDIT

okay so I figured out that I wasn't using chameleon at all. I made my own menu entry in grub 2 and used multiboot /boot to boot into chameleon. Then I started messing with the boot options in chameleon wizard. I tried setting my SMBios thing to the two Sandy Bridge items. This works fine and I selected the SMBios in the chameleon boot plist ( if someone has trouble with the + sign not doing anything, click just below it). However neither of the two SMBios things made a difference in safari with new tab. Installed the intel kexts back from the intelhd_backup folder I made. This made a world of difference, it prevented me booting into hackintosh. Luckily I can boot into hackintosh just fine with that grub menu entry that bypasses chameleon. For some reason my wifi didn't work then, though. I moved the intelhd kexts back to the intelhd_backup folder and chameleon booted.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...