Jump to content
1h4ckOSx86

DSDT Tyan S7012 on Mountain Lion---Needs patching, thanks

Recommended Posts

Hello Community,


I have a Tyan S7012. I've extracted the DSDT and attached them and labeled them pre and post edited DSDT for the board.


The problem I am having is that when I am selecting the DSDT-free or DSDT option, I get a blank screen after the apple boot logo screen. The main reason why I want to have a DSDT is that I want to have my NIC's working in OS X.


When I've succesfully installed OS X running the installer with PCIRootUID=0 and GraphicsEnabler=Yes, it works, and even using those flags during the post boot it works fine.



After installing via *.beast choosing the DSDT option screen goes blank. I've done PCIRootUID=0 and GE=Yes along with ncpi=0x3000 which helps me run the installer, and works post-install only under the Ch****ra option NOT THE DSDT/DSDT-free option


I've done Ch****ra bootloader with the boot flags PCIRootUID=0 and GraphicsEnabler=Yes and it works and loads OS X. The main reason why I want to use the DSDT is because I want to use the on-board N.I.C.'s


Intel 82474L is what the board has and I know *****beast has the option for the E1000 Series, and I cannot load kernel flags onto c*****ra bootloader because I cannot find the plist.


My configuration: 2x E5530 Xeon's, and EVGA Nvidia GeForce 620 Dual-DVi running ML 10.8.5, as mentioned before using no DSDT works fine however; booting setup with PCIRootUID=0, and GraphicsEnabler=Yes Works, but need my DSDT to function to get my network cards to work properly and address the Blank boot-up screen after I install UserDSDT, let me know if you can fix it or if you can lead me to fix it.


Thanks.


Attached is the Send meSend me Userโ€™s Mac Pro.zip and and my prepost dsdt fixPrepost DSDT.zip, before and after. I've labeled the DSDT's. I have tried using multi**** and selecting the Ch***ra option which works but using the dsdt or dsdt-free option i get blank screen, I've tried multiple kernal flags to address the video issue after the apple boot logo screen, doesn't work.


Let me know if anyone fan fix this issue.


Thank you guys so much.

Link to comment
Share on other sites

hello


what is talking about is ur ethernet



u are talking about graphics.. the 620 should work without any problems


anyway u don't give any support to the " beast " thing


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Filesย 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...