Jump to content
luciano_frc

Ajuda Com DSDT Lenovo 62

Recommended Posts

Olá a todos.

Estou rodando o Mavericks 10.9.2 nesta maquina, usando o Clover,

porém meu áudio não funciona, e nem a a placa de vídeo que é uma Intel hd 4000

não estou usando nada de DSDT nessa maquina, mais sei que é essencial, porém me falta conhecimento em aplicar os patches para o DSDT.

estou postando o link pra download do meu DSDT que foi extraído pelo Ubuntu agradeço a ajuda de todos.

Não consegui muitas informações sobre o meu hardware, porque ele é montado, portanto creio que fique um pouco mais complexo.


Meu Hardware !

Intel Core i3 3240

VGA Intel HD 4000

Áudio (até aonde eu descobri) ALC888


Link Download DSDT-Não_Editado


Abaixo a Saída do LSPCI -nn

00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller [8086:0150] (rev 09)
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0152] (rev 09)
00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 [8086:1c2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 [8086:1c10] (rev b4)
00:1c.5 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 [8086:1c1a] (rev b4)
00:1d.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 [8086:1c26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation H61 Express Chipset Family LPC Controller [8086:1c5c] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 6 Series/C200 Series Chipset Family SATA AHCI Controller [8086:1c02] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller [8086:1c22] (rev 04)
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)

 

Atualização 23/03/2014

Tentei aplicar alguns patches para o DSDT que baixei aqui no forum

DGTP e HDEF porém ao tentar compilar no DSDT Editor estou recebendo vários erros abaixo ScreenShot

Captura_de_Tela_2014_03_23_a_s_22_25_20.png

Atualização

Apliquei os seguintes Patches

Captura_de_Tela_2014_03_23_s_23_09_33.png

e ao tentar compilar recebo o seguinte erro

  2620 Error Object does not exist (ATT3)  


Abaixo uma ScreenShot da tela

Clique para Ampliar

Captura_de_Tela_2014_03_23_s_23_11_54.jpg

Hardware OEM

Dell Vostro 270s

Especificações

justpaste.it/i3yn

dell_vostro_270s.jpg

Link to comment
Share on other sites

Olá,


troca ATT3 por BUF0.


Sinceramente acho que esses patches não vão ajudar muito usando Clover, ele já faz esses ajustes básicos, basta editar o config.plist


Para o áudio e HD 4000 você pode usar estas opções


http://clover-wiki.zetam.org/Configuration/Graphics#ig-platform-id


http://clover-wiki.zetam.org/Configuration/Devices#Audio-/-Inject


No caso do áudio você também precisa uma AppleHDA editada para o seu codec, ou usa VoodooHDA e não precisa desse ajuste.

-Donations-

PayPal HERE - Stripe HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

Link to comment
Share on other sites

Olá boa noite !!!

Desculpe a demora em responder essa semana está bem corrido..

Efetuei os teste com o Clover, sobre o audio eu ainda não consegui fazer ele funcionar, porque como meu device é 1c20 eo ventor é intel 8086 eu não faço ideia de que codec é esse, sei que é algum realteck da vida, mais não sei se é o 888 ou 888b ou mesmo se é o 888.

Mais vou continuar pesquisando.

o vídeo eu tentei todas aquelas combinações que tem no wiki do clover e nada funciona mesmo, eu percebi que meu hardware com a VGA onboard é reconhecido como um macmini 6.2, e o macmini tem essa placa de video, porém mesmo assim não vai e fora que estou tendo vários erros.

resolvi colocar uma placa offboard que eu tenho aqui sobrando uma 9500GT de 256mb, o sistema foi reconhecido como um IMAC acho que 12.1.

o video OK CI QE e Quartz.

Agora com o onboard nada mesmo...

se alguém tiver esse mesmo codec de áudio e puder me relatar qual realtek é eu agradeço..

grande abraço

e Muito Obrigado


Atualização


baixei essas Kexts

http://www.osx86.net/files/file/3667-new-final-build-13a603-109-intel-hd-3000-hd-4000-driver/

Instalei com o kext utility e deixei meu SMBIOS como imac 13.1

resultado é que tive um KP parando na appleintelcpupowermanagement o engraçado é basta colocar a 9500 que sobe de boa novamente sem KP só tenho o KP se usar a Intel hd 4000

Realmente ainda não estou tendo sucesso com essa VGA, mais vamos proceguindo e vou postando o insucesso, ou sucesso.

Hardware OEM

Dell Vostro 270s

Especificações

justpaste.it/i3yn

dell_vostro_270s.jpg

Link to comment
Share on other sites

Usa este app para identificar o codec de áudio


http://sourceforge.net/projects/dpcimanager/

-Donations-

PayPal HERE - Stripe HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

Link to comment
Share on other sites

Grato camarada pelo link, por sinal gostei bastante do aplicativo, porém o nome mesmo do codec ele não mostrou mais tem algumas coisas pra poder fazer o VooDooHDA funfar, não conhecia esse APP muito obrigado pela dica.

Fiz novas descobertas sobre meu Hardware

Primeiro é que o meu processador é esse aqui

http://ark.intel.com/pt-br/products/65690/Intel-Core-i3-3240-Processor-3M-Cache-3_40-GHz

não de onde eu tirei i3 3420

segundo a especificação minha VGA onboard é uma Intel HD 2500 e não 4000, eu disse que era HD 4000 porque o clover reconhece assim, e eu estava na fé disso.

agora na verdade tudo muda, porque eu vou atrás de fazer essa 2500 funfar, que parece ser mais fácil que a 4000.

mais vamos que vamos..

Obrigado...


Atualização


não sei porque mais não consigo aplicar nenhum patch no meu DSDT usando o DSDT Editor segue o erro que recebo

Captura_de_Tela_2014_03_27_s_21_35_22.png


Atualização

Não consigo fazer o sistema subir sem KP usando o SMBIOS do macmini 6,2

se alguém puder me dar uma dica, já tentei com as flags tipicas e nada

agora estou parado nesse KP existe um topico aqui

http://www.osx86.net/topic/19566-ivy-bridge-p-states-working-but-not-as-they-should/

sobre os ivy bridge e KP usando o SMBIOS do macmini.

Agradeço qualquer ajuda..

Obrigado

Hardware OEM

Dell Vostro 270s

Especificações

justpaste.it/i3yn

dell_vostro_270s.jpg

Link to comment
Share on other sites

Você precisa criar uma SSDT usando o script ssdtPRGen ou ativar o Generate CStates e PStates do Clover


http://Olarila.com/forum/viewtopic.php?f=2&t=34


Talvez precise também DropOem


http://clover-wiki.zetam.org/Configuration/ACPI#SSDT

-Donations-

PayPal HERE - Stripe HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

Link to comment
Share on other sites

Olá boa noite..

Eu havia gerado o SSDT.aml feito através de um vídeo que eu vi no youtube usando esse mesmo script.

resolvi fazer novamente usando o tópico que citou acima

me SSDT foi gerado sem erros e salvo no desktop com o nome ssdt.aml

Captura_de_Tela_2014_03_28_s_19_29_02.png

peguei o arquivo gerado ssdt.aml e coloquei na pasta /EFI/EFI/CLOVER/ACPI/patched

nesta pasta tenho também o meu dsdt.aml

Captura_de_Tela_2014_03_28_s_19_37_37.png

no clover estou usando as seguintes configurações

Captura_de_Tela_2014_03_28_s_19_41_58.png

dei uma olhada também no plist do clover para ver se o dropOEM estava como true

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Devices</key>
<dict>
	<key>Audio</key>
	<dict>
		<key>Inject</key>
		<string>Detect</string>
	</dict>
	<key>USB</key>
	<dict>
		<key>Inject</key>
		<true/>
		<key>FixOwnership</key>
		<true/>
		<key>AddClockID</key>
		<true/>
	</dict>
	<key>UseIntelHDMI</key>
	<false/>
</dict>
<key>Graphics</key>
<dict>
	<key>Inject</key>
	<dict>
		<key>Intel</key>
		<false/>
		<key>ATI</key>
		<false/>
		<key>NVidia</key>
		<false/>
	</dict>
</dict>
<key>Boot</key>
<dict>
	<key>Arguments</key>
	<string>-v</string>
	<key>Log</key>
	<false/>
	<key>Timeout</key>
	<integer>5</integer>
	<key>XMPDetection</key>
	<string>Yes</string>
	<key>Secure</key>
	<false/>
</dict>
<key>GUI</key>
<dict>
	<key>Language</key>
	<string>br:0</string>
	<key>ScreenResolution</key>
	<string>1024x768</string>
	<key>Theme</key>
	<string>bootcamp</string>
	<key>Mouse</key>
	<dict>
		<key>Enabled</key>
		<true/>
	</dict>
	<key>Scan</key>
	<true/>
</dict>
<key>KernelAndKextPatches</key>
<dict>
	<key>AppleRTC</key>
	<false/>
</dict>
<key>SMBIOS</key>
<dict>
	<key>Trust</key>
	<false/>
	<key>Memory</key>
	<dict>
		<key>SlotCount</key>
		<integer>2</integer>
	</dict>
</dict>
<key>ACPI</key>
<dict>
	<key>DSDT</key>
	<dict>
		<key>Debug</key>
		<false/>
		<key>ReuseFFFF</key>
		<false/>
		<key>Name</key>
		<string>DSDT.aml</string>
		<key>DropOEM_DSM</key>
		<false/>
	</dict>
	<key>HaltEnabler</key>
	<true/>
	<key>SSDT</key>
	<dict>
		<key>DropOem</key>
		<true/>
		<key>Generate</key>
		<dict>
			<key>PStates</key>
			<false/>
			<key>CStates</key>
			<false/>
		</dict>
	</dict>
</dict>
<key>SystemParameters</key>
<dict>
	<key>InjectKexts</key>
	<string>Detect</string>
	<key>NoCaches</key>
	<true/>
</dict>
</dict>
</plist>

aparentemente tá tudo certo. mesmo assim continuo tendo KP por causa exatamente do processador.

parece que o clover não está usando meu ssdt

também ativei o Generates P States e C States

Mesmo assim continuo obtendo KP..

Obrigado

Hardware OEM

Dell Vostro 270s

Especificações

justpaste.it/i3yn

dell_vostro_270s.jpg

Link to comment
Share on other sites

Anexa uma foto desse kernel panic e um preboot log (F2) do Clover.

-Donations-

PayPal HERE - Stripe HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

Link to comment
Share on other sites

Tenta outro SMBIOS, iMac13,1.


Tem algum motivo especial para usar Macmini6,2?

-Donations-

PayPal HERE - Stripe HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

Link to comment
Share on other sites

Pior que tem sim...

é por causa da placa de video onboard, que é um Intel HD 2500 ou HD 4000

só funfa se eu se eu usar o SMBIOS de um macmini 6,2.

quando eu coloco o video off sobe como imac 13.1 de boa.

porém o problema é que essa VGA é emprestada.

Mais deve ter algum segredo nisso, tem posts para o mounta lion falando de Gerenciamento nativo para os ivy Bridge.

Bom, mais vamos que vamos, estou baixando o 10.8.5, e vou tentar com ele.

Mais embora o Clover tenha exelentes recursos, estou achando que tem alguma coisa estranho no que está instalado aqui.

mais vamos tentar...

Obrigado..

Hardware OEM

Dell Vostro 270s

Especificações

justpaste.it/i3yn

dell_vostro_270s.jpg

Link to comment
Share on other sites

O vídeo desse CPU é HD 2500


http://ark.intel.com/products/65690/Intel-Core-i3-3240-Processor-3M-Cache-3_40-GHz


Ele não tem suporte oficial no OS X, é só uma forma de fazer ele ser reconhecido como HD 4000.


Pelo que diz o tópico, também pode ser Macmini6,1


http://www.insanelymac.com/forum/topic/287668-guide-intel-hd2500-full-resolution-and-qeci-1083/

-Donations-

PayPal HERE - Stripe HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill danielnmaldonado@gmail.com - BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

PicPay @danielnmaldonado - PiX @danielnmaldonado@gmail.com

Premium Users HERE - Problems with Paypal HERE

xcd5u2Y.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...