Jump to content
artur-pt

Setup UEFI Bios Legacy / UEFI mode to boot

Recommended Posts

How to setup a UEFI bios to boot in legacy mode boot (Chameleon)

 

UEFI1.png.a09eabf78a094925ff06c681d4805f2a.png

 

It's best just to reset all of your UEFI settings to their factory defaults. Once your UEFI is running on its defaults, you will have to change the following settings:


Boot Option Priorities - Change "Boot Option #1" to your USB drive. You need to do this for the pen to boot.

Mac OS X cannot boot if you set the boot option to anything that starts with "UEFI". Instead, you must select the boot option that starts with "P0", "SATA", or "Legacy" (depending on your motherboard).

 

708640698_bootorder.png.fda76349bfcbc275ce5ebaa19167e3aa.png

 

xHCI Mode - Change this to "Auto". This setting is usually set to "Smart Auto", which doesn't work.

 

1823350987_xhcimode.png.f38884ea70e564932fe4442d38bae0cc.png

 

xHCI Hand-off / EHCI Hand-off - Make sure both of these settings are enabled.

 

handoffs.png.42313a65340ec75f1cdd7a5a7905f331.png

 

Asus Setup

 

asus1.png.b5aea9b8030cc8c60d565e1498d67fd2.png

asus2.png.343e5168fb5445ae21e1f1dde696ac78.png

asus3.png.663602966220d792a65ec694c34f034f.png

asus4.png.a2d709cc821423a2a81365499560e0d9.png

asus5.png.52e022a3d081edde859586ba0f973611.png

asus6.png.5fafbb03185f8fab01b45e7c82d6a616.png

asus7.png.0d4476c05dc1c84abd2baa8714f7ab1e.png

 

How to setup a UEFI bios to boot in UEFI mode boot (Clover)

 

UEFI_SET.jpg.d53da4805d929f2357d084fa9953c71f.jpg

 

1 - "UEFI Hitachi" line allows to boot the HDD in UEFI mode,

2 - "P1: Hitachi" line allows to boot the HDD in Legacy (not-EFI) mode,

3 - "P3: DVD" line allows to boot from DVD drive in Legacy mode

4 - "UEFI: USB" line allows to boot the USB in UEFI mode.


Here is a 2nd example of BIOS, simpler, where the "Boot Mode" parameter allows one to choose the boot mode ("UEFI" or "Legacy") for all media (hard disk, CD, USB...) at the same time.

 

UEFI_set1.jpg.19b6707ef3d776c8d054426d4061255a.jpg

 

SecureBoot


"Secure Boot" is a new UEFI feature that appeared in 2012, with Windows8 preinstalled computers. So it's possible that you may encounter problems booting under Secure Boot.


Disabling SecureBoot in the BIOS


Here is an example of BIOS showing that "Secure Boot" is enabled:

 

SecureBoot.jpg.bbe48dd2ddecc62df1e6fa3a25eb3369.jpg

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...