Jump to content
nycionx

Mavericks wont boot with my ATI 7870; only with Intel HD4000

Recommended Posts

As stated in the post i cannot boot into my Mavericks OS X. only with the onboard gfx Intel HD 4000.

I installed using this: http://thepiratebay.sx/torrent/9086005/OS_X_Mavericks_10.9_bootable_USB_for_Intel_PCs_%2813A603%29

Which is great thanks! Everything works (sound, network, etc) except video kext for ATI 7870.

I used multishit - Mavericks Edition (latest) to install bootloader Chimera 2.2.1 which works fine for me. I can dual boot into my Windows 7 partition :)


here are my computer specs:


Intel Core i7 3770K CPU w/ Intel HD4000

Sapphire Radeon HD 7870 2GB

ASRock Z77 Extreme4 2.70 bios patched

4x8Gb = 32GB RAM Kingston

OCZ 256Gb SSD


So why doesnt my Sapphire Radeon HD 7870 2GB work? It just freezes while booting. I thought Mavericks included kexts for this ATI chip?? It used to boot fine with my Mountain Lion OS before!


Here is my current org.chameleon.Boot.plist:


<?xml version="1.0" encoding="UTF-8"?>




EthernetBuiltIn

Yes

GraphicsEnabler

No

IGPEnabler

Yes

Kernel

mach_kernel

Kernel Flags

-v

Legacy Logo

Yes

Instant Menu

Yes

GenerateCStates

Yes

GeneratePStates

Yes

UseKernelCache

Yes

Graphics Mode

"1920x1080x32"





Here is the org.chameleon.Boot.plist i used with Mountain Lion before (with Chameleon bootloader):


<?xml version="1.0" encoding="UTF-8"?>




AtiConfig

Chutoro

DSDT

/Extra/DSDT.aml

EthernetBuiltIn

Yes

GenerateCStates

Yes

GeneratePStates

Yes

Graphics Mode

1920x1080x32

GraphicsEnabler

Yes

IGPEnabler

Yes

Instant Menu

Yes

Kernel Flags

-v npci=0x2000 darkwake=0

PciRoot

1

SMBIOS

/Extra/smbios.plist

SystemType

1

Theme

AngelBird

UseAtiROM

Yes

UseKernelCache

Yes

device-properties

4b00000001000000010000003f0000000100000002010c00d041030a0000000001010600041c0101060000007fff0400160000006200750069006c0074002d0069006e0000000500000001





If i use this plist above with my ATI 7870 card as main gfx card in bios then booting up halts/freezes and i have to turn off computer using power button. :(


Help please! Thanks in advance!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...