Jump to content

Saga da Placa Realtek ALC861 (Audio)


Recommended Posts

Boa noite caros amigos... Este fórum é minha última tentativa de conseguir fazer minha placa de som (ALC861) funcionar no meu hackintosh.


Segue minha configuração:


Mac OS X 86 - Snow Leopard 10.6.6i by Hazard


Mobo: Uniwill M31EI Mobile Intel Calistoga-GM i945GM

Processador: Mobile Intel Celeron M 410, 1466 MHz (11 x 133) x86, MMX, SSE, SSE2, SSE3

MemÛria: Smart Modular/ DDR2-667/ 4G

HD: Samsung/ 500GB/ SATA [snow Leopard 10.6.6 + Windows 7 Dual Boot com Chamaleon 2]

DVD: TSSTcorp CDDVDW TS-L632H ATA Device

Audio: Realtek ALC861 @ Intel 82801GBM ICH7-M - High Definition Audio Controller [b-0]

Rede Lan: Marvell Yukon 88E8055 PCI-E Gigabit Ethernet Controller

Wi-Fi: Gigabyte GN-WI01GT (mini) PCI-E WLAN Card

Video: Mobile Intel® 945 Express Chipset Family (256 MB)


Já tentei diversos métodos do 1o para o último, como applehda patcher do taruga, Azalia Audio, ALCx861.kext e .pkg, diversas kexts voodooHDA... Encalhei em uma kext que identificou meu hardware e me deu mic funcionado!!! Foi uma evolução... meu output ficou identificado como Headphone, com controles de volume porém sem som nenhum... Segue link da kext que baixei:


http://www.insanelymac.com/forum/index.php?showtopic=183321



Comecei a tentar me aprofundar nisso tentando configurar PIN CONFIG, gerando arquivos hex e dec... até consegui criar os arquivos mas na hora de editar o pin fiquei um pouco confuso. Alguém já conseguiu editar por esse método?


Ainda não entendi muito bem como funciona DSDT!!


Desculpe as muitas linhas mas quis começar deixando tudo o mais claro possível!


Obrigado pelo espaço!! :|

 

1424503988_Screenshot2011-08-16at19_58_08.thumb.png.82db22aa7e9c0e02f5451138fb1f58a8.png

 

1044464857_Screenshot2011-08-17at02_54_48.png.e5df4600adac36b15983f3d12a9a4054.png

Link to post
Share on other sites
Tente uma VoodooHDA recente

http://Olarila.com/forum/viewtopic.php?f=2&t=180


Ajustar a AppleHDA é bem mais complicado

http://www.projectosx.com/forum/index.php?showtopic=465

 


Obrigado pela atenção!! já tentei com todas as kexts voodooHDA do site acima. Todas funcionam o mic porém o output aparece como uknown, com o slide de volume funcionando porém sem som...


Tem mais alguma coisa que eu possa fazer? Estou disposto a executar qualquer coisa orientado por alguém com mais experiêcia...


Valeu!! :D

codec,verbs e voodoohda codec dump.zip

Link to post
Share on other sites
  • Administrators

Fiz uma busca e parece que esse codec não é tão popular quanto os ALC88x, ao invés de esperar alguém com o mesmo hardware é melhor você fazer seus próprios testes.


Veja no link da minha primeira resposta como editar o Info.plist da VoodooHDA, você precisa incluir NodesToPatch, por exemplo

   <dict>
     <key>Codec</key>
     <integer>0</integer>
     <key>Config</key>
     <string>0x99130110</string>
     <key>Node</key>
     <integer>12</integer>
  </dict>

 

O PinDefault (Config) corresponde aos últimos 2 caracteres de cada verb, na ordem inversa

0x[color=#FF0000]41[/color][color=#008000]11[/color][color=#0000FF]11[/color][color=#8000FF]f1[/color]   00c71c[color=#8000FF]f1[/color] 00c71d[color=#0000FF]11[/color] 00c71e[color=#008000]11[/color] 00c71f[color=#FF0000]41[/color]

 

Veja que você tem vários nodes DISABLED

 Disabling pin nid 12 due to None connectivity.
Disabling pin nid 14 due to None connectivity.
Disabling pin nid 15 due to None connectivity.
Disabling pin nid 16 due to None connectivity.
Disabling pin nid 18 due to None connectivity.
Disabling pin nid 31 due to None connectivity.
Disabling pin nid 32 due to None connectivity.
nid 11 0x0121411f as  1 seq 15    Headphones  Jack jack  1 loc  1 color   Green misc 1
nid 12 0x411111f1 as 15 seq  1       Speaker  None jack  1 loc  1 color   Black misc 1 [DISABLED]
nid 13 0x01a19120 as  2 seq  0    Microphone  Jack jack  1 loc  1 color    Pink misc 1
nid 14 0x411121f1 as 15 seq  1       Speaker  None jack  1 loc  1 color    Grey misc 1 [DISABLED]
nid 15 0x411131f1 as 15 seq  1       Speaker  None jack  1 loc  1 color    Blue misc 1 [DISABLED]
nid 16 0x411151f1 as 15 seq  1       Speaker  None jack  1 loc  1 color     Red misc 1 [DISABLED]
nid 17 0x99331121 as  2 seq  1            CD Fixed jack  3 loc 25 color   Black misc 1
nid 18 0x411161f1 as 15 seq  1       Speaker  None jack  1 loc  1 color  Orange misc 1 [DISABLED]
nid 31 0x411171f1 as 15 seq  1       Speaker  None jack  1 loc  1 color  Yellow misc 1 [DISABLED]
nid 32 0x411181f1 as 15 seq  1       Speaker  None jack  1 loc  1 color  Purple misc 1 [DISABLED]

Link to post
Share on other sites
Fiz uma busca e parece que esse codec não é tão popular quanto os ALC88x, ao invés de esperar alguém com o mesmo hardware é melhor você fazer seus próprios testes.


Veja no link da minha primeira resposta como editar o Info.plist da VoodooHDA, você precisa incluir NodesToPatch, por exemplo

   <dict>
     <key>Codec</key>
     <integer>0</integer>
     <key>Config</key>
     <string>0x99130110</string>
     <key>Node</key>
     <integer>12</integer>
  </dict>

 

O PinDefault (Config) corresponde aos últimos 2 caracteres de cada verb, na ordem inversa

0x[color=#FF0000]41[/color][color=#008000]11[/color][color=#0000FF]11[/color][color=#8000FF]f1[/color]   00c71c[color=#8000FF]f1[/color] 00c71d[color=#0000FF]11[/color] 00c71e[color=#008000]11[/color] 00c71f[color=#FF0000]41[/color]

 

Veja que você tem vários nodes DISABLED

 Disabling pin nid 12 due to None connectivity.
Disabling pin nid 14 due to None connectivity.
Disabling pin nid 15 due to None connectivity.
Disabling pin nid 16 due to None connectivity.
Disabling pin nid 18 due to None connectivity.
Disabling pin nid 31 due to None connectivity.
Disabling pin nid 32 due to None connectivity.
nid 11 0x0121411f as  1 seq 15    Headphones  Jack jack  1 loc  1 color   Green misc 1
nid 12 0x411111f1 as 15 seq  1       Speaker  None jack  1 loc  1 color   Black misc 1 [DISABLED]
nid 13 0x01a19120 as  2 seq  0    Microphone  Jack jack  1 loc  1 color    Pink misc 1
nid 14 0x411121f1 as 15 seq  1       Speaker  None jack  1 loc  1 color    Grey misc 1 [DISABLED]
nid 15 0x411131f1 as 15 seq  1       Speaker  None jack  1 loc  1 color    Blue misc 1 [DISABLED]
nid 16 0x411151f1 as 15 seq  1       Speaker  None jack  1 loc  1 color     Red misc 1 [DISABLED]
nid 17 0x99331121 as  2 seq  1            CD Fixed jack  3 loc 25 color   Black misc 1
nid 18 0x411161f1 as 15 seq  1       Speaker  None jack  1 loc  1 color  Orange misc 1 [DISABLED]
nid 31 0x411171f1 as 15 seq  1       Speaker  None jack  1 loc  1 color  Yellow misc 1 [DISABLED]
nid 32 0x411181f1 as 15 seq  1       Speaker  None jack  1 loc  1 color  Purple misc 1 [DISABLED]

 

Pow obrigado Old!! To te postando meus verbs pra vc dar uma olhada se possível:


Tem os "Original Verbs" e os "Modified Verbs". Quais são os prováveis? Depois disso preciso usar DSDT ou se funcionar o som ja aparece no reboot?


Vou começar a testar e posto aqui o resultado!!



Mais uma vez obrigado! Fiquei animado mais uma vez nessa empreitada!! :D

Verbs & codec dump.zip

Link to post
Share on other sites
  • Administrators

Disabling pin nid 12 due to None connectivity.

nid 12 0x411111f1 as 15 seq 1 Speaker None jack 1 loc 1 color Black misc 1 [DISABLED]

Eu começaria tentando mudar a "port connectivity" e "location" do node 12 (71f, veja que está "01 - No External Port -or- No physical connection for Port") e também a "default association" e "sequence" (71c, botar no mesmo grupo que o node 11 pra ter auto detect quando conecta o headphone). Na verdade é bom verificar todos os verbs.


Pra VoodooHDA não precisa patch na DSDT, a menos que você queira que apareça no System Profiler (funciona mesmo sem aparecer).

Link to post
Share on other sites

Eu começaria tentando mudar a "port connectivity" e "location" do node 12 (71f, veja que está "01 - No External Port -or- No physical connection for Port") e também a "default association" e "sequence" (71c, botar no mesmo grupo que o node 11 pra ter auto detect quando conecta o headphone). Na verdade é bom verificar todos os verbs.


Pra VoodooHDA não precisa patch na DSDT, a menos que você queira que apareça no System Profiler (funciona mesmo sem aparecer).

 


Cara agora entendi claramente como isso funciona! Antes de vc postar esse "" acima eu havia conseguido fazer o siatema reconhecer os devices com os nomes certos... Vou fazer as trocas no "71f" e no "71c" pra ver e posto aqui!!


Valeuuuuu! :D

Link to post
Share on other sites

Eu começaria tentando mudar a "port connectivity" e "location" do node 12 (71f, veja que está "01 - No External Port -or- No physical connection for Port") e também a "default association" e "sequence" (71c, botar no mesmo grupo que o node 11 pra ter auto detect quando conecta o headphone). Na verdade é bom verificar todos os verbs.


Pra VoodooHDA não precisa patch na DSDT, a menos que você queira que apareça no System Profiler (funciona mesmo sem aparecer).

 

Old consegui fazer todos os "disables" funcionarem editando por pin config. Consegui 8 speak. A dúvida agora é a seguinte: Tenho somente mic interno, mic externo, Output (grenn front) e speakers stereo. O som continua sem funcionar. Da uma olhada como ficou a kext editada em patches to node!


Penso que estamos quase lá!!!


Obrigado!

404925037_Capturadetela2011-08-22as23_41_40.png.25a02a3b3d8f9a2b6c3b66cada5660c7.png

VoodooHDA - ALC861 Patches to Node.zip

Novo VoodooCodecDump.txt.zip

Link to post
Share on other sites
  • Administrators

No node 12, por exemplo, acho que no 71f em "Location Part 2 - bits 3:0" você deveria botar ATAPI (1001) e não N/A (0000). Em 71e o "Connection Type" também acho que é ATAPI (3).

Link to post
Share on other sites
No node 12, por exemplo, acho que no 71f em "Location Part 2 - bits 3:0" você deveria botar ATAPI (1001) e não N/A (0000). Em 71e o "Connection Type" também acho que é ATAPI (3).

 


Nada de som ainda... Consegui configurar todas as entradas e saídas com nomes corretos... Tem alguma chave que preciso adicionar na kext além de codec, node e config? Andei olhando em outros posts e encontrei chaves como "conns", "enable", "DAC". O que são essas chaves? A configuração pin config já entendi tranquilo.


Valeu Old tu é o cara msm!!!!


no aguardo!

Link to post
Share on other sites
  • Administrators

Mostre como ficaram os PinDefaults.


No 71c do node 11 não pode ficar 10 também, deixe 1f como estava. Tem que ser a mesma "default association" que o speaker, mas não a mesma "sequence".


As outras chaves não entendi bem para que servem, teria que procurar no tópico oficial e fazer testes, se não encontrar nada tente perguntar por lá

http://www.projectosx.com/forum/index.php?showtopic=355


Pelo que eu entendi a chave "select" define a connection padrão, a "conns" define uma connection para aquele node e a "enable" provavelmente ativa (ou desativa) o node. Sobre a "DAC" eu não achei nada (Direct Access Channel?).

Link to post
Share on other sites
Mostre como ficaram os PinDefaults.


No 71c do node 11 não pode ficar 10 também, deixe 1f como estava. Tem que ser a mesma "default association" que o speaker, mas não a mesma "sequence".


As outras chaves não entendi bem para que servem, teria que procurar no tópico oficial e fazer testes, se não encontrar nada tente perguntar por lá

http://www.projectosx.com/forum/index.php?showtopic=355


Pelo que eu entendi a chave "select" define a connection padrão, a "conns" define uma connection para aquele node e a "enable" provavelmente ativa (ou desativa) o node. Sobre a "DAC" eu não achei nada (Direct Access Channel?).

 

Segue meus pin defaults em .txt e meu info.plist com as modificações.


Old, vi nesse link http://www.projectosx.com/forum/index.php?s=99bc0f8aa0f3345fe0433237c505a064&showtopic=355 que algumas pessoas editaram a kext com as chaves "conns" e "type". Baixei o codec dump após as edições de um usuário e percebi que ele colocou essas chaves de acordo com o codec dump dele. Fiz o mesmo no meu info.plist (segue anexo). Nada de som ainda. Ouço um estálos (crackels) quando faço o reboot. Coloquei o speaker como ATAPI e não consegui som. Tentei colocar o mesmo "default association", o "X" do 71c como vc disse do node 11 (headphone) no mesmo grupo do node 12 (speaker) e o headphone não foi reconhecido. Coloquei o fone de ouvido e nada. Bom é isso Old.... Ainda estou sem som!!! Mas to lendo o guia lá...


Abraço!!!

ALC861 infoplist após pin configs.zip

ALC861 pin defaults após mods.txt.zip

ScreenShots.zip

Link to post
Share on other sites
  • Administrators

O speaker ainda não está como ATAPI, tente fazer o que eu sugeri neste post

http://Olarila.com/forum/viewtopic.php?f=6&t=333#p3143


O headphone também ainda não está como eu sugeri.


Eu tentaria antes ajustar apenas os PinDefaults (só nodes 11 e 12 pra começar), deixar para testar as outras chaves só quando os PinDefaults estiverem 100% (caso continue sem funcionar).

Link to post
Share on other sites
O speaker ainda não está como ATAPI, tente fazer o que eu sugeri neste post

http://Olarila.com/forum/viewtopic.php?f=6&t=333#p3143


O headphone também ainda não está como eu sugeri.


Eu tentaria antes ajustar apenas os PinDefaults (só nodes 11 e 12 pra começar), deixar para testar as outras chaves só quando os PinDefaults estiverem 100% (caso continue sem funcionar).

 

ok to fazendo as configs que vc sugeriu e posto aqui ja ja!


abraço

Link to post
Share on other sites

Então Old... Fiz como vc me orientou colocando o node 12 (speaker) em ATAPI no 71f "Location Part 2 - bits 3:0" e resultou em um binary "99" e em 71e o "Connection Type" em ATAPI (3). --- Segue SS do painel de preferências -----.


Coloquei também o node 11 (headphone) na mesma "default association" que o node 12 (speaker) No 71c.


Node 11 - 0x0221401f

Node 12 - 0x99130110



O headphone não é reconhecido mais... nem quando plugo o headphone. O aúdio continua sem sair.


Confere e vê se realmente está como vc me orientou!


O que significa isso?


 

+--------------------------------------+
| DUMPING PCM Playback/Record Channels |
+--------------------------------------+

Playback:

    Stream cap: 0x00000001
                PCM
       PCM cap: 0x000e0140
                16 20 24 bits, 48 96 KHz
           DAC: 3

Record:

    Stream cap: 0x00000001
                PCM
       PCM cap: 0x00020140
                16 bits, 48 96 KHz
           ADC: 8

+-------------------------------+
| DUMPING Playback/Record Paths |
+-------------------------------+

Playback:

   nid=11 [pin: Headphones (Green Front)]
     |
     + <- nid=22 [audio mixer]

Record:

   nid=8 [audio input]
     |
     + <- nid=13 [pin: Microphone (Pink Front)] [src: mic] bindSeq=00000001

     + <- nid=21 [audio mixer]

Input Mix:

   nid=20 [audio mixer]
     |
     + <- nid=13 [pin: Microphone (Pink Front)] [src: mic] bindSeq=00000001


+-------------------------+
| DUMPING Volume Controls |
+-------------------------+

Master Volume (OSS: vol)
  |
  +- control  1 (nid   3 out):    dir - out oss: vol, pcm mute
  +- control  7 (nid  22 in   0): dir - out oss: vol, pcm mute
  +- control  8 (nid  22 in   1): dir - out oss: vol, igain mute

PCM Volume (OSS: pcm)
  |
  +- control  1 (nid   3 out):    dir - out oss: vol, pcm mute
  +- control  7 (nid  22 in   0): dir - out oss: vol, pcm mute

Microphone Volume (OSS: mic)
  |
  +- control  3 (nid   8 in   0): dir - in oss: mic, rec -6/+33dB (14 steps) + mute
  +- control  4 (nid  20 in   0): dir - in oss: mic, igain mute

Speaker/Beep Volume (OSS: speaker)
  |
  +- control 11 (nid  35 out):    dir - none oss: speaker -45/+0dB (16 steps) + mute

Recording Level (OSS: rec)
  |
  +- control  3 (nid   8 in   0): dir - in oss: mic, rec -6/+33dB (14 steps) + mute

Input Mix Level (OSS: mix)
  |
  +- control  5 (nid  21 out):    dir - in oss: mix, igain -36/+0dB (13 steps) + mute

Input Monitoring Level (OSS: igain)
  |
  +- control  4 (nid  20 in   0): dir - in oss: mic, igain mute
  +- control  5 (nid  21 out):    dir - in oss: mix, igain -36/+0dB (13 steps) + mute
  +- control  8 (nid  22 in   1): dir - out oss: vol, igain mute

 



Abração Old!!!

 

2106789639_SpeakercomoATAPI.png.cc4cdec5a1288b060a7884213f2fcff7.png

Info.plist-node 11 e 12 msm grupo-node12ATAPI.zip

VoodooHDA dump e Verbs pin default atualizado.zip

Link to post
Share on other sites
  • Administrators

É, pelo que eu entendi assim deveria funcionar o auto-detect, não sei o que deu errado. Se conectar os fones e depois abrir as preferências do som, não aparece headphones no lugar de speaker? Sem essa modificação os fones funcionam?

 

If you want autodetect speaker/headphone you must place them into the same group.

 nid 13 0x99130110 as  1 seq  0	   Speaker Fixed jack  3 loc 25 color Unknown misc 1
nid 15 0x01214040 as  4 seq  0	Headphones  Jack jack  1 loc  1 color   Green misc 0

For example

nid 13 0x99130110

nid 15 0x0121401F

http://www.projectosx.com/forum/index.php?s=&showtopic=355&view=findpost&p=15331


Talvez seja melhor remover os outros NodesToPatch, adicione o mínimo possível, apenas o necessário.


As informações que você colou no post são diferentes do dump, de onde elas vêm? Pode ser que falte alguma connection.


Aqui está o dump do meu laptop (ALC269) para usar como exemplo, funciona mic interno/externo e speakers/headphones com auto-detect.

dump.txt.zip

 

Ambos têm a mesma conn

Playback:

   nid=27 [pin: Speaker (ATAPI)]
     |
     + <- nid=[color=#FF0000]12[/color] [audio mixer]

   nid=33 [pin: Headphones (Green Rear)]
     |
     + <- nid=[color=#FF0000]12[/color] [audio mixer]

 

Detalhe, o speaker usado não é o primeiro

Patched pins configuration:
nid 18 0x411111f0 as 15 seq  0       Speaker  None jack  1 loc  1 color   Black misc 1 [DISABLED]
nid 20 0x411111f0 as 15 seq  0       Speaker  None jack  1 loc  1 color   Black misc 1 [DISABLED]
nid 23 0x411111f0 as 15 seq  0       Speaker  None jack  1 loc  1 color   Black misc 1 [DISABLED]
nid 24 0x01a19830 as  3 seq  0    Microphone  Jack jack  1 loc  1 color    Pink misc 8
nid 25 0x99a3093f as  3 seq 15    Microphone Fixed jack  3 loc 25 color Unknown misc 9
nid 26 0x411111f0 as 15 seq  0       Speaker  None jack  1 loc  1 color   Black misc 1 [DISABLED]
[color=#FF0000]nid 27 0x99130110 as  1 seq  0       Speaker[/color] Fixed jack  3 loc 25 color Unknown misc 1
nid 29 0x40079a2d as  2 seq 13      Line-out  None jack  7 loc  0 color    Pink misc 10 [DISABLED]
nid 30 0x99430120 as  2 seq  0     SPDIF-out Fixed jack  3 loc 25 color Unknown misc 1
[color=#FF0000]nid 33 0x0121401f as  1 seq 15    Headphones[/color]  Jack jack  1 loc  1 color   Green misc 0

Link to post
Share on other sites

De nenhuma forma os speakers ou o headphone funcionam. Somente o mic funciona. Já testei o mic em uma gravação e executei em windows. Realmente não sei o que significa. To começando a achar que o OS X não consegue se comunicar com o esquema do circuito da minha placa. :?:


Old tem como vc me enviar sua .plist final, seu dump linux e seu voodooHDA dump para eu comparar com o meu e tentar entender isso melhor?


Tem alguma coisa aqui faltando para funcionar..



Abraço Old!!!

Link to post
Share on other sites
  • Administrators

O dump da VoodooHDA está no post anterior, eu não preciso incluir nada em NodesToPatch, funciona direto.


Segue o dump do Linux

codec.txt.zip

 

Você tentou fazer ajustes no painel de controle da VoodooHDA?


Talvez esteja faltando alguma connection para sair som.


Repare que o meu node 27 (0x1b) está conectado ao node 12 (0x0c) que por sua vez está ligado ao node 02 (Audio Output)

Node [color=#FF0000]0x1b[/color] [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
 Pin Default 0x99130110: [Fixed] [color=#FF0000]Speaker[/color] at Int ATAPI
 Connection: 2
[color=#FF0000]0x0c[/color]* 0x0d
Node [color=#FF0000]0x0c[/color] [[color=#FF0000]Audio Mixer[/color]] wcaps 0x20010b: Stereo Amp-In
 Connection: 2
[color=#FF0000]0x02[/color] 0x0b
Node [color=#FF0000]0x02[/color] [[color=#FF0000]Audio Output[/color]] wcaps 0x1d: Stereo Amp-Out

No dump da VoodooHDA a mesma coisa

nid [color=#FF0000]27[/color] 0x99130110 as  1 seq  0       [color=#FF0000]Speaker[/color] Fixed jack  3 loc 25 color Unknown misc 1
VHDevice NID=[color=#FF0000]27[/color] Config=99130110 Type=00000004 Cap=00000034 Ctrl=00000020 -- Conns: 0=[color=#FF0000]12[/color] 1=13
VHDevice NID=[color=#FF0000]12[/color] Config=00000000 Type=00000002 Cap=00000000 Ctrl=00000000 -- Conns: 0=[color=#FF0000]2[/color] 1=11

 

Coisas estranhas no seu dump após as edições

Pin [color=#FF0000]12[/color] traced to DAC [color=#FF0000]6[/color] with fake redirection
Pin [color=#FF0000]11[/color] traced to DAC [color=#FF0000]3[/color] with fake redirection
+--------------------------------------+
| DUMPING PCM Playback/Record Channels |
+--------------------------------------+
Playback:
    Stream cap: 0x00000001
                PCM
       PCM cap: 0x000e0140
                16 20 24 bits, 48 96 KHz
           DAC: [color=#FF0000]6 3[/color]

Antes tinha apenas 3 em DAC. Talvez você precise conectar tanto speaker quanto headphones ao mesmo nid, como acontece no meu.

Link to post
Share on other sites
  • 2 weeks later...

Olá Old... Depois de inúmeras tentativas não obtive êxito... No post original em que ensina sobre patches to node faltou uma última parte a ser postada e que não foi postada. O projeto é fabuloso mas acho que não tem solução mesmo por hora! Frustrante pois o hack está rodando "liso" no meu laptop que já é bem antigo... Tudo funciona perfeitamente (tudo mesmo!) menos o som... Pensei até em comprar um dongle daqueles USB com in e out para mic e fones mas só terei som com fones de ouvido... Mas valeu a força e se tiver mas alguma novidade sobre "DAC", "CONNS" e outras mais que são inseridas na plist do voodooHDA, me avise. meu email:


[email protected]



Obrigado meu amigo! Não resolvi o problema mas aprendi bastante...

Link to post
Share on other sites
  • Administrators

Você fez as últimas tentativas que eu sugeri (direcionar ambas as saídas para o mesmo DAC)?


Isso só vai ser resolvido com muitos testes, dificilmente alguém vai chegar aqui e postar a solução, até porque não tem muita gente com esse codec em hackintosh.


Tente fazer uma pergunta mais específica no tópico oficial da VoodooHDA. Se pedir "please help me to patch it for my codec, here is the dump" certamente ninguém vai responder mesmo.

Link to post
Share on other sites
  • 4 weeks later...
  • 8 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap