Jump to content
neres

P5KPL-AM + GeForce 9500GT + 10.6.8 = Problema

Recommended Posts

Olá meus caros.


Possuo um Dell XPS 1340 e com ele não tenho problemas com meu hackintosh. O meu desktop também possui OS X instalado, porém uma versão muito antiga (10.5.8) e eu queria atualizar isso para o Snow Leopard (tentei com Lion e ML, mas a seguir, vocês vão saber porque resolvi ficar no Snow).


Estou sem drive óptico e então, tentei todas as instalações via USB. Tentei unishit com ML, Lion, -f, -x, GraphicsEnabler=1/=0, PCIRootUID=0/=1, depois de começar a ler o pendrive, aparece uma tela preta e dali não sai.


Então, fiz o que eu não queria fazer, apelei para uma distro, o iAtkos S3v2. Através do GraphicsEnabler=Yes PCIRootUID=1, o sistema começa a instalar e assim o fiz, me baseando neste tutorial abaixo...


http://www.insanelymac.com/forum/topic/235809-asus-p5kpl-am-se-hackintosh-fully-working/


... pois bem. Foi um suplício o primeiro boot, quase não sai. Depois de conseguir enfim iniciar, instalei o kext de rede e atualizei para o 10.6.8. Enquanto isso, li no OSX86 Wiki que, nessa mobo, para evitar Kernel Panic, é necessário trocar o AppleACPIPlatform.kext e o IOPCFamily.kext para o da versão 10.6.7 e deletar o arquivo DSMOS.kext. Fiz o teste sem fazer estas alterações deu KP. Com estes, mesma coisa, ao trocar os dois primeiros kexts, dá a mensagem "power management may be incomplete or unsupported".


Enfim, alguma luz a respeito desta instalação que possa dar certo comigo?


Motherboard: Asus P5KPL-AM

Processador: Intel Pentium 4 3.06GHz

Ram: 1x2GB Kingston 667MHz

GPU: NVidia GeForce 9500GT 1GB

LAN: Realtek RTL8102EL 100/10 LAN

HD: Western Digital 320GB 7200RPM.

Alex da Silva Neres


Powered by: Dell XPS M1340 - Intel Core 2 Duo p8600, 4GB DDR3 1066MHz, GPU NVidia GeForce 9400M, Wireless Dell DW1510 802.11b/g/n, OS X 10.8.4 Mountain Lion &OS X 10.9 Mavericks Developer Preview 3

Link to comment
Share on other sites

Olá,


Pentium 4 não tem suporte nativo, depois de atualizar você precisa instalar o kernel legacy


http://Olarila.com/files/10.6/Kernels/10.8.0/legacy_kernel-10.6.8.v2.pkg.zip


Recomendo instalação usando DVD retail + OSX86 ModCD


http://Olarila.com/forum/viewtopic.php?f=3&t=20

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Estou a baixar o Retail para fazer o procedimento acima citado.


Duas dúvidas:


1. Esse processo eu posso fazer pelo iBoot também?

2. É possível algum método de instalação do Lion ou ML nessa máquina?


Abraço! ;)

Alex da Silva Neres


Powered by: Dell XPS M1340 - Intel Core 2 Duo p8600, 4GB DDR3 1066MHz, GPU NVidia GeForce 9400M, Wireless Dell DW1510 802.11b/g/n, OS X 10.8.4 Mountain Lion &OS X 10.9 Mavericks Developer Preview 3

Link to comment
Share on other sites

1. Nunca usei, não sei dizer.


2. Talvez, mas o kernel legacy (para CPUs não suportados nativamente) não é tão estável quanto no Snow Leopard.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Resolvi tentar usando o ModCD e o resultado é que nem sequer consigo o boot. Acontece o erro abaixo:


zb4g.jpg


O que pode ser?



CORREÇÃO:


Iniciei novamente, e agora deu certo, iniciou a instalação. Acho que agora vai.


Quando eu for atualizar, eu instalo o Kernel Legacy antes de reiniciar, seria isso?

Alex da Silva Neres


Powered by: Dell XPS M1340 - Intel Core 2 Duo p8600, 4GB DDR3 1066MHz, GPU NVidia GeForce 9400M, Wireless Dell DW1510 802.11b/g/n, OS X 10.8.4 Mountain Lion &OS X 10.9 Mavericks Developer Preview 3

Link to comment
Share on other sites

Enfim, não foi... :/


Instalei, tudo bonitinho, fui instalar o 10.6.8. Tentei o Combo e deu falha, sendo que eu já havia instalado o Kernel. Deu pau, pra variar. Então, refiz a instalação e tentei instalar a atualização pela Atualização de Software do próprio Mac OS. Instalou, pediu pra reiniciar. Aí, instalei o Legacy Kernel, beleza. Quando reiniciei, na hora de concluir a instalação do 10.6.8, deu falha. Novamente, como o Kernel não era compatível, deu erro. A tela que aparece é essa:


zniv.jpg


Terei que instalar o sistema novamente? E existe alguma restrição de se atualizar direto do 10.6.0 para o 10.6.8, para toda vez estar dando falha? Simplesmente aparece "ocorreu uma falha durante a atualização", mais nada.

Alex da Silva Neres


Powered by: Dell XPS M1340 - Intel Core 2 Duo p8600, 4GB DDR3 1066MHz, GPU NVidia GeForce 9400M, Wireless Dell DW1510 802.11b/g/n, OS X 10.8.4 Mountain Lion &OS X 10.9 Mavericks Developer Preview 3

Link to comment
Share on other sites

E o update para o 10.6.8 insiste em não instalar. Estou pensando seriamente em testar com outro processador. :/

Alex da Silva Neres


Powered by: Dell XPS M1340 - Intel Core 2 Duo p8600, 4GB DDR3 1066MHz, GPU NVidia GeForce 9400M, Wireless Dell DW1510 802.11b/g/n, OS X 10.8.4 Mountain Lion &OS X 10.9 Mavericks Developer Preview 3

Link to comment
Share on other sites

Olha se tem o arquivo mach_kernel na raiz da partição, o update deve verificar se ele existe. Se não tiver, copia o legacy_kernel para mach_kernel.

Donation with Paypal | Mercado Livre | Premium and Donators Users | Installation GUIDE

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Desculpe-me a ignorância, mas no caso como é feito esse processo?


Na pasta raiz da partição não há nenhum arquivo avulso, apenas os diretórios padrão.Tenho aqui o tanto o instalador do Kernel 10.8.0 em formato .pkg e o arquivo Mach_Kernel 10.8.0. Simplesmente ponho este último na pasta raíz e tento atualizar? =)

Alex da Silva Neres


Powered by: Dell XPS M1340 - Intel Core 2 Duo p8600, 4GB DDR3 1066MHz, GPU NVidia GeForce 9400M, Wireless Dell DW1510 802.11b/g/n, OS X 10.8.4 Mountain Lion &OS X 10.9 Mavericks Developer Preview 3

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...