Jump to content
rtlarson3

No trackpad/usb after installation

Recommended Posts

Hi everyone. First thank you to everyone who helps make all of this possible. I have been working for months (off and on) to get OS X on my laptop HP DV7-6b75nr and could get it to install fine but never boot! I've finally gotten it to boot after installing using iATKOS ML2 and the right set of options. And i did buy mountain lion so please dont ban me.


So now here's my biggest problem. The trackpad and usb worked during installation but not after.


I can get it to work if i boot in to safe mode but thats it.. USBBusFix and EHCIhard do not fix it. Neither does -f, -F, pciroot=1


I got to this point this morning, then totally hosed everything when I tried to fix it using chameleon wizard (i think, i dont remember honestly, I'm doing this on my desktop also at the same time), and had to spend all day just to get back to this point again, so now that its working, i dont want to go further alone.


Specs on the laptop

HP DV7-6B75NR

i7-2670QM (only showing 1 core)

HD3000 (working)

RADEON 6770M (detected but not working, later issue)

16GB RAM

USB 3.0

Fingerprint scanner

WIFI intel centrino N 1030 + bluetooth & WiDi (none of it working obviously)

card reader

VGA+HDMI

DVD-RW/Blu-Ray player (CD-RW portion works at least, i successfully burnt a disc)

installed to a dedicated drive (tri booting off ssd & hdd my goal)


..I know most of that will never work

other issues that might help figure this out:


Laptop display does not show anything after boot.. It works during install and boot but not once you get to the desktop. HDMI works. It can sense the display because at first, it'll be in extended mode till I close the laptop and it switches the desktop to HDMI only.


It crashes after about 10 mins of running.. The fan is working. When you go to shutdown the laptop actually powers off (unlike my desktop)


no sound



The attached ZIP has the bootloader log file and an exported dsdt. the screenshots are of devices and their IDs


I'm guessing i need some kext's or to edit them.. I know where they're at on the system and how to edit them, if someone can tell me exactly what to change.


Please help me out. Thanks immensely in advance.

-Robbie

bootlog.zip

101_2470.thumb.JPG.6c6ccea6e6a6c53e5c79bb5b49b43979.JPG

101_2471.thumb.JPG.7fc3c9d3a888768a120c96a3f9455204.JPG

Link to comment
Share on other sites

I solved most of my issues using the appropriate kext's and installing them using the utility under Tools. I also used DSDT editor to pull my dsdt and patched it using a file that was closest to my laptop. I now have working


Trackpad/keyboard

usb 2.0

internal screen

battery


I ordered TP-LINK TL-WN725N Nano Wireless N150 Adapter to solve wifi issues, intel centrino will never work.


Now to fix sleep, sound and only showing 1 cpu

I've been trying the voodoo installer but it fails every time..


ADMIN:THREAD CAN BE CLOSED

thank you

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×
  • Create New...
The popup will be closed in 15 seconds...