Jump to content
ralpho

ASUS X501A I3 2350m

Recommended Posts

ASUS x501a i3 2350m

I got it all working except track pad and QE/CI HD3000.


Voodoo sound


Atheros ar9485 no kext, used tp-link TL-WDN3200 it is a ralink rt5572 used the only M/L USB at the top of this page it


worked. http://www.mediatek.com/_en/07_downloads/01_windows.php?sn=502


realtec pcie gbe I think I used RealtekRTL81xx-0_0_90.pkg


I used http://Olarila.com/forum/viewtopic.php?f=27&t=1627


I had to do this remove trick.

If boot stops right before reaching the installer, or graphics aren't working right, remove video kexts and boot with


GraphicsEnabler=No -f

ATI = ATI* Intel = AppleIntelHD* AppleIntelSNB* nVidia = GeForce* NVDA*


Now getting video to work right look a long way off. I tried osx86.net drivers tricks none worked for me.


On a pny 8 gig stick to boot and install. Installed to a 100 gig usb drive.

SUSE Studio Image Writer

ftp://ftp.berlios.de/pub/kiwi/ImageWriter.exe


Preboot in extra seems to load a voodoo track pad preventing the right one from loading. I dont know how to undo that.

Best thing about using the Olarila mountain lion usb installer was no need for a real mac. As I had none handy.


I used the updcombo to get from 8 to 8.3

As far as I can tell I am the first person to get this working. used tp-link TL-WDN3200 it is a ralink rt5572 used the


only M/L USB at the top of this page it worked. http://www.mediatek.com/_en/07_downloads/01_windows.php?sn=502

Link to comment
Share on other sites

your trackpad is possibly a v3 elantech, here in the forum there are links to the kexts, and the video you solve with a smbios of macbook pro 8.1 and GraphicsEnabler=Yes

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

you have only the hd3000?


it should work with the smbios and the GE=Yes.


what is your chameleon version?

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

look, if this is the only graphic card and you are booting from the hdd, it has to work with the mbp 8.1 smbios in the extra folder and the GraphicsEnabler=Yes in the bootloader.

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

Well this aint my first rodeo I have been doing this a long time.

And it dont fly on this laptop.


And on tonycrapx86 is whole threads of this problem even on hd4000.

Some people have edited the AppleIntelSNB and framebuffercapri with some having success but even that did not work.

I have checked everything in the bios a hundred times.


Even the fresh usb drive wont boot with out pulling AppleIntelSNB no matter what switches you try.


I even made SMBios and used SMBIOS= to make sure.

I have tried mini 5.2 or1 also because some people have had luck. But i have seen no one else on any of these boards trying this laptop. I have a install on a t4500 and a t6500 no problems, this one that looks like it should just work nope. The ones that look hard with legacy kernels no problems.

lol thanks for the help though I really appreciate you taking the time.


I will keep reading and perhaps in due time something will come along.


EDIT: Fellow Sabayon user.

Link to comment
Share on other sites

One last thing to anyone.


Preboot.dmg contents:

Extensions.mkext

org.chameleon.Boot.plist


Extensions.mkext contents:

AHCIPortInjector.kext

AppleACPIPS2Nub.kext

FakeSMC.kext

IOAHCIBlockStorageInjector.kext

NullCPUPowerManagement.kext

PXHCD.kext

VoodooPS2Controller.kext

VoodooPS2Keyboard.kext

VoodooPS2Mouse.kext

VoodooPS2Trackpad.kext


How can I remove VoodooPS2Mouse.kext VoodooPS2Trackpad.kext from extensions.mkext.


I never used preboot before.

Link to comment
Share on other sites

hello


delete the file..


and install the new ones


mandatory fakesmc.kext and nullcpupowermanagement.kext


intall this in system/library/extensions


boot


-f -v


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...