Jump to content
proatwork

[TRYING TO...] OSX 10.8.2 Mountain Lion on HP DV7 6135DX

Recommended Posts

Hello everyone.


First of all thank you for this great community. It has helped me in installing 10.8.3 on my old Core2Duo desktop PC - Now I'd love to have it on my HP dv7 6135dx laptop

screenshot of aida64 spec summary here :

3xkC5rz.jpg

What I've tried using Mountain Lion bootable USB for Intel PCs

- removed 1 of the 4GB ram sticks

- In BIOS i have tried with Virtualisation on & off and also graphics mode in "Fixed" & "Dynamic"

- removing ATI kexts , nvidia kexts and appleIntelHD kexts from /S/L/E (on stick)


I tried with no flags = Kernel panic

with cpus=1 and GraphicsEnabler=No, it freezes before displaying the OSX installer (freezes at [iOBluetoothHCIController] -- success)

I have tried a lot of kernel boot flag combinations but to no avail... sometimes is gets stuck at "DSMOS has arrived", but it's still stuck


I've read about my laptop and OSX and people say they've managed to install just fine but without ATI card -- that's fine for me


So if you could give me any hints on how to get over the graphics cards issue, that would be greatly appreciated


-Many thanks

Alex

Edited by Guest
Link to comment
Share on other sites

as far as i know, you just need to use GE=No and -f for the vídeo issue.

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

hello


the kp about cpu is well know... is a HP problem


must use with chameleon in


/Extra/module/kernelpatcher.lyb


or use a mod kernel lapic_kernel (google it)


have u remove all appleintelhd*.* ?


if so boot


-f GraphicsEnabler=No


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Hello again and thank you for the replies

I've been away and could not check the forums.


I am giving it one more try, as artur-pt said, with the lapic_kernel for 10.8.2 (I am using OS X 10.8.2 Install USB). I guess what I have to do is:

- replace the mach_kernel on USB with the mach_kernel (lapic fix) I donwloaded

- remove AppleIntelHD* kexts from /System/Library/Extensions/

- boot with "-f GraphicsEnabler=No"


Will come back with result


Many thanks!

-Alex

Link to comment
Share on other sites

Hi again guys!


I went ahead and followed the advice given here


I've used the "OS X 10.8.2 Install USB for Intel PCs" which I've written to a USB drive using the SUSE image writer provided


- Removed 4GB of RAM out of 8GB

- On the USB drive, I replaced the mach_kernel from the root folder with one I downloaded from http://www.osx86.net/view/3263-ml_10.8.2_mach_kernel_lapic_fix.zip.html

- Moved AppleIntelHDGraphics.kext, AppleIntelHDGraphicsFB.kext, AppleIntelHDGraphicsGA.plugin, AppleIntelHDGraphicsVADriver.bundle to /System/Library/ExtOLD (folder which I created)

- Installed Chameleon2.2 (I have /Extra/modules/KernelPatcher.dylib)

- Booted with "-f GraphicsEnabler=No"

- Booted with a bunch of other flags such as -x -v but no result


All I get is :

IFe06iSs.jpg

http://i.imgur.com/IFe06iS.jpg



Many thanks

-Alex

Link to comment
Share on other sites

hello


remove all appleintelhd*.*


u have intel hd 3000 so must remove all, u write only some kext


and boot again


-f -v GraphicsEnabler=No


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Hei artur-pt


Those 4 files I wrote above were the only "AppleIntelHD*" files inside /S/L/E/


For "Graphics" I also have inside /S/L/E:


AppleIntelSNBGraphicsFB.kext

IOGraphicsFamily.kext

AppleGraphicsControl.kext

AppleGraphicsPowerManagement.kext


Also I have ATI* & NVDA* kexts inside the /S/L/E/ folder.


What else should I remove ? :?


Many Thanks!

-Alex

Link to comment
Share on other sites

OS X Mountain Lion 10.8.2 is installed on my machine

Booted into installed OS with only "GraphicsEnabler=No" flag.


Out of the box :

1024x768 resolution

Touchpad works, but only buttons (no tap to click, touchpad disabler button doesn't work)

Keyboard works


Other stuff doesn't work (sound, ethernet, usb3 (left side ports), ati card, etc)


Will post here when I make a break-through

Link to comment
Share on other sites

hello


take a good read in guides and tutorials, is all there to post instalation ,

and how to make the other things work.. but remember, incompatible hardware not work ... mac os x is for mac ... not generic OS.


the ati card don't work.. so see how to make intel hd 3000 work..


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

use a macbook pro 8.1 smbios in the extra folder and GraphicsEnabler=Yes to enable the video.


the ati card will not work.

Se quando viaja faz o que quer, quando viajar, não leve a mulher

.

Core I5 750 12gb 500gb GTX 760(macOS 10.12, macOS 10.12.Xb, Win10)

Pentium 4 3.06 2gb 80gb fx5200 (10.5.8)

iMac G3 400Mhz 512mb Rage 8Mb (10.4.11)


Save OSX86... Don't Let Tony win!

Link to comment
Share on other sites

So all I managed to do by now (besides having sleep) is struggle on installing a bootloader to my harddrive.


I think I f**cked up..

I installed Easybeast and now I get a KP when booting from Chimera - I can still boot into OSX HDD from usb drive but after it boots, usb no longer works :-(



Edit1: Okay I fixed it I think - USB Works again


I copied

"boot" from usb to "/"

"Extra" from usb to "/Extra" on hdd


Unpacked "org.chameleon.Boot.plist" from Preboot.dmg to my /Extra folder and removed Preboot.dmg


Edited org.chameleon.Boot.plist with

GraphicsEnabler=No

kernel=/Extra/mach_kernel (lapic 10.8.2)


My org.chameleon.boot.plist:

Instant Menu

Yes

GraphicsEnabler

No

kernel

/Extra/mach_kernel

 

My Extra folder has:

Extensions.mkext

mach_kernel

org.chameleon.Boot.plist

Themes/

 


Edit2: Installed FakeSMC.kext and NullCPUPowerManagement as here http://Olarila.com/forum/viewtopic.php?f=28&t=1716

Also Repaired Permissions & Rebuilt Cache with Kext Wizard - after repairs finished I rebooted from Apple icon - Restart and booted with no flags - Boot takes about 2 minutes (any clue on that? - i'm on a SSD too)



Edit3: Using Chameleon Wizard, I have set smbios to be MacBook8,1

added SMBios.plist to /Extra folder

set GraphicsEnabler=Yes in org.chameleon.Boot.plist

& Restart laptop


About this Mac now shows "MacBook Pro" & Graphics: Intel HD Graphics 3000 Mobile 64MB

My maximum resolution is still 1024x768.. shouldn't it be 1366x768?


Edit4 With other PC, I downloaded Java to usb drive in order to run DSDT Editor

I extract DSDT and then IASL > Compile but I get 2 errors , 4 warnings 8 remarks & 60 optimizations. If I click "Fix Errors" errors remain

I can't save AML with errors...

Any tips?



I have dsdt.dsl for my laptop generated in Windows 7 x64 before Installing OSX -> Does this help me ? - Still generates same errors

Errors:

Line 19 : Name already exists in scope (\TNOT)
Line 7093 : _HID suffix must be all hex digits (GH) 

- On line 7093 I have :

Name (_HID, "ABCDEFGH")

Edit5 Went ahead and commented the lines that had errors (commented with "//")


Edit6 Got full resolution (1600x900) but freezes sometimes for ~2 seconds

- Patched the dsdt like said here (with files provided) : http://Olarila.com/forum/viewtopic.php?f=18&t=2193

- Removed all AppleIntelHD* kexts from /S/L/E and installed ones here (https://dl.dropboxusercontent.com/u/27721057/HD3000.zip - can't remember where I found initially) with Kext Wizard + rebuild permissions and cache

- My screen brightness went down to ~50% and also freezes for ~1,2 seconds when opening apps eg: Terminal (Any help with this?)


Also, external monitor works (I think at 1920x1080)


Edit7 Realtek LAN card works with pkg here: https://dl.dropboxusercontent.com/u/27721057/RTGNICv2.0.6For10.7.zip

Edited by Guest
Link to comment
Share on other sites

hello


where u read to use extensions.mkext ????


man try to go slow obvioulis u don't know nothing about the system..


try to read step by step and apply, but if u gonna apply something must understand what are u doing...


if u think the mac os x is easy to install.. and a have a proper setup.. u are wrong...


mac os x is for mac and developed exclusively for mac.. u have a mac ? no..


hack mac os x is 99% of reading, googling, persistency and 1 % of luck u hardware be compatible..similar to a mac.. when u use a smbios like macbookpro8,1 is saying to the system u have the hardware of this mac...


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Hei artur-pt


You are right, I didn't read that anywhere, I just copied.


I am not trying to make a tutorial, I am just marking my steps so if I manage to make it work (with your help) other people will know how.

Any criticism is needed and is well taken


I removed extensions.mkext from /Extra folder


Also, is it okay when testing kexts to copy /S/L/E folder to /S/L/Extensions_bak and in case of fail replace folder?


Many thanks!

-Alex

Link to comment
Share on other sites

Unfortunately I have to use the laptop for work and had to restore Windows to it :(


Here's a Copy-Paste of my conversation with artur-pt which helped me more than I could of expected - I hope he doesn't mind me posting this as it might help some people.


I will surely give this a second try when I get some spare time.


Many thanks

-Alex

artur.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...