Jump to content
Prabakar

Bootloader and Audio Issues

Recommended Posts

Hello All,


I've installed Hackintosh 4 times today and every time i've corrupted the boot somehow, forcing myself to go over the installation again and again.


This time, I've kept it in a running state and am looking for help before messing it up again.


Current Setup:

  • Made 2 partitions in HDD

    1. Identifier: disk0s1 Format:FAT 32 Name: Untitled Blank

    2. Identifier: disk0s2 Format: HFS+ Name: OS X

    Installed OS X in disk0s2

    Installed RealtekRTL81xx-0_0_90.pkg for Ethernet and it works

 

Current Status:

  • USB Mouse works - I don't have a PS2 mouse so, can't tell if it will work or not

    PS2 Keyboard works - I didn't install any kext for it to work

    Ethernet works - After installing the driver mentioned above.

    Display - Graphics Card's HDMI out, VGA out works again didn't have to install anything additionally

    Sound - Doesn't work

    Boot without Live USB assistance - Doesn't work

 

Previous Attempts:

In all my previously failed attempts I had done the exact same stuff as what I mentioned above and did the following


Attempt 1:

  • Followed http://Olarila.com/forum/viewtopic.php?f=27&t=1627#p13583

    Installed Chameleon Wizard from the link given

    Created a directory in root folder Extras and created 2 plist files from the software

    Didn't understand what DSDT is so I skipped it.

    The previous steps didn't work so I followed this link: http://Olarila.com/forum/viewtopic.php?f=27&t=1676, added boot1h

    Again it didn't work so I installed the latest Chameleon, it said installation finished so I restarted the system, and it showed 3 menus for boot option. I thought it finally worked, but after that every time I try to boot with OS X partition either through USB or directly from HDD it would show some verbose message and greys out with a OS X popup asking me to restart the system

    I don't remember what I did in Attempt 2, but that was a failed attempt too.

Attempt 3:

  • My friend Suggested to use Multi-beast So I downloaded the latest version here for 10.8 and did the easy install and restarted and nothing changed

    Then I decided to live with the USB boot as long as I can manage to install and boot windows and OS X from the USB boot somehow.

    So I installed all the Realtex Sound drivers in Multi-beast drivers and after restart it threw some Sound Assertion error message in verbose launched the OS X but keyboard and mouse stopped working. Unable to interact with the OS, I again reinstalled.

 

What I need:

 

  • I want to be able to dual boot the machine with OS X and windows.

    I would like the sound to work

    If possible get a fix for booting issues. But I can live with booting windows or mac from the live USB.

 

System Configuration:

 

  • Processor: Intel Core i5-3470 CPU @ 3.2 GHz

    Motherboard: Asus Motherboard P8H61-M LX3

    Graphics Card: GeForce 210 1 GB

    No CD/DVD reader

 

Please help,

Prabakar.

Link to comment
Share on other sites

You need to install basic kexts, not only the bootloader, read http://Olarila.com/forum/viewtopic.php?f=27&t=1716


For sound you can try http://Olarila.com/forum/viewtopic.php?f=18&t=454

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Thanks for the quick reply. I tried following the links and have come up with the below


For Audio I downloaded the System Info Application

Found that I have 2 sound cards:


Ven ID | Vendor | Dev ID | Device | Class Subclass

8086 | Intel Corp | 1c20 | 6 Series/C200 Series Chipset Family HD Audio Controller | Multimedia Controller Audio Device

10de | NVIDIA Corp | 0be3 | HD Audio Controller | Multimedia Controller Audio Device


Followed problem 2 kext doesn't work

I first took a backup of AppleHDA and then Opened the plist file inside VoodooHDA.kext and made the modifications, then Installed VoodooHDA.kext


I still didn't get audio. So I've left it at that.



For Boot, I don't understand what I should do


I installed Chameleon first from Built-In

Created org.chameleon.Boot in Extras folder with following configurations

Boot Flags: Verbose mode, Ignore Boot Cache and Quite Boot Default Partition hd(0,2) Legacy Logo

Miscellaneous: Force 64bit, System Type 1-Desktop Restart Fix


And saved it in Extras folder


SMBios selected iMac(12,2) it automatically Filled in the rest so saved that to extra's folder


Downloaded a compiled aml for my motherboard P8H61-M LX3 from tonycrapx86 and dropped it in Extras folder

And it still didn't work

So again I tried copying the boot1h directly from terminal (USB boot) after un mounting disk0s2 and this time it started showing lots of console message just like the USB boot and during the time the USB boot usually changes font (smaller and brighter) the harddisk boot restarts again, creating a loop.

Hope I have given enough info to get help.



Please Help,

Prabakar

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...