Jump to content
madeira31

Dúvidas sobre conexão HDMI na geforce 9800 GT

Recommended Posts

Olá a todos, tenho uma nvdia gforce 9800 gt com saida dvid e hdmi, eu tinha um monitor em que eu usava uma conexão dvid onde eu plugava na placa de video e o meu mountain lion (hack) funcionava numa boa. mas esse monitor queimou e comprei um full hd mas só com conexão hdmi e o mountain lion não reconheceu, ficando uma tela preta sem imagem. Isso é um problema oriundo de placa grafica, ou qualquer placa grafica ao usar a conexão hdmi não irá funcionar no mountain lion?

o dvi funcionava legal no outro monitor que queimou

O novo monitor veio com uma cabo conversor de hdmi / dvi

Mas mesmo assim não funcionou

uso esse cabo que sai do monitor com a conexão numa ponta em hdmi e na outra dvi, que é onde eu plugo na placa de video

quando passa da tela do boot, tudo fica preto, sem imagem

mas ja ouvi falr que essa serie gforce 9xxx tem esse problema nos custom mac

mas a minha duvida é a seguinte: tem como contornar esse problema com essa placa grafica? ou existe alguma outra placa grafica em que funcione sem problemas a conexão hdmi em um custom mac?


Obrigado e aguardo informações.

Link to comment
Share on other sites

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Mesma coisa, não muda nada.


1. baixe o MacPro8800GT.ROM

2. renomeie MacPro8800GT.ROM para 10de_0614.rom (ou qualquer que seja seu device ID) e coloque na pasta /Extra

3. adicione estas linhas no org.chameleon.Boot.plist (em /Extra)

<key>GraphicsEnabler</key>
<string>Yes</string>
<key>UseNvidiaROM</key>
<string>yes</string>
<key>VBIOS</key>
<string>yes</string>

MacPro8800GT.ROM.zip

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Quero agradecer a ajuda, muito mesmo. Mas infelizmente não funcionou, fiz exatamente como descrito, mas ao sair da tela de boot , uma tela branca fica travada e nada acontece.

Renomeei a rom para 10de_0614.rom e coloquei na pasta extra e editei o org.chameleon.Boot.plist como descrito, só que nada!!

Será que fiz algo errado, mesmo vendo que processo é bem fácil de fazer?


Obs.

Ao editar o org.chameleon.Boot.plist , devo adicionar essas linhas descritas a partir da ultima linha ou a partir logo abaixo do GraphicsEnabler que ja tem no org.chameleon.Boot.plist ?

Ficou assim depois que editei


<?xml version="1.0" encoding="UTF-8"?>



EthernetBuiltIn

Yes

GenerateCStates

Yes

GeneratePStates

Yes

GraphicsEnabler

Yes

VBIOS

yes

Kernel

mach_kernel

Kernel Flags

-f darkwake=0

Legacy Logo

Yes

PciRoot

1

Timeout

2

UseKernelCache

Yes

Graphics Mode

"1600x900x32"


Link to comment
Share on other sites

Sobrou a parte destacada em vermelho e faltou

<key>UseNvidiaROM</key>
<string>yes</string>

Use "Wait=yes -v" no boot e veja se a ROM foi carregada.

<?xml version="1.0" encoding="UTF-8"?>



EthernetBuiltIn

Yes

GenerateCStates

Yes

GeneratePStates

Yes

GraphicsEnabler

Yes

VBIOS

yes

Kernel

mach_kernel

Kernel Flags

-f darkwake=0

Legacy Logo

Yes

PciRoot

1

Timeout

2

UseKernelCache

Yes

Graphics Mode

"1600x900x32"


ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Me perdoe, a parte que faltou estava lá sim e a parte sobrando também foi engano ao especificar.

É que na verdade estou usando o MAC drive 8 para acessar a partição do MAC OS pelo windows e ao abrir com o bloco de notas o que está escrito sai sem formatação.

Não consegui enviar o anexo, mas logo depois da tela do multishit aparece essa mensagem:


Filesize of /Extra/10de_0614.rom is bigger than expected! Truncating to 0x10000 Bytes!


Não sei o que isso quer dizer.

Link to comment
Share on other sites

Quer dizer que o arquivo tem 128 kb quando o esperado é 64 kb (não foi carregado por completo)

#define NVIDIA_ROM_SIZE 0x10000
...
size = file_size(fd);
if (size > bufsize) {
	printf("Filesize of %s is bigger than expected! Truncating to 0x%x Bytes!\n", filename, bufsize);
	size = bufsize;
}

http://forge.voodooprojects.org/svn/chameleon/trunk/i386/libsaio/nvidia.c


Esse é o único "truque" que conheço pra HDMI nessas placas.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Não é um procedimento, é o motivo de aparecer a mensagem. Não conheço outra solução.


Poderia tentar mudar o NVIDIA_ROM_SIZE para 0x20000 mas acho que não vai adiantar, se fosse pra funcionar, teria sido assim mesmo.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Se quiser testar, substitua o arquivo boot na raiz do HD pelo anexado, ele deve carregar a ROM de 128 kb, apesar de que todos que reportaram sucesso, foi carregando apenas os primeiros 64 kb mesmo.

boot.zip

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Se a resposta for sim,sumiu aquela mensagem de erro, mas não resolveu. Mas estou pensando em duas possibilidades:

1- Tenho uma imagem com a instalação limpa do Mountain Lion, posso restaura-la e tentar fazer seu tutorial do zero.

2- Meu monitor tem entrada de vídeo componente, será que se eu comprar um adaptador/ conversor DVI / Vídeo componente e liga-lo ao monitor será que o Mountain Lion irá reconhecer esta conexão e voltar a funcionar o vídeo?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...