Jump to content
mdma

Can only boot in safe mode, no obvious errors -logs attached

Recommended Posts

Hi,


After days of trial and error, I finally have found workarounds for most issues, including binpatched AICPM and patched kernel for lapic errors.


My machine is an HP Spectre XT ultrabook, running an Ivy Bridge i5-3317U and Intel HD 4000.

So far my install is based on unishit and 10.8.2 app from App store, and have tried Chameleon r2064 as well as Chimera 1.11.1 as bootloaders.


I am unable to boot unless I use safe mode (-x), but there are no apparent errors or KP messages.


When not in safe mode, I stay stuck at the verbose output screen, the GUI does not start and I get no login screen.


I don't think this purely a HD 4000 graphics issue, as even when injecting incorrect device properties for the HD 4000, consequences are only felt when in safe mode.


I've attached two sets of system.logs: a failed boot in normal mode (nogui) and a successful boot in safe mode (safemode).


Any insight would be much appreciated.


Cheers,


Max

Archive.zip

Link to comment
Share on other sites

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Thanks Artur,


I followed your guide for HD 4000 and at least I have a graphics now, only problem is that Chimera 1.11.1 seems to overwrite my ig-platform-id, I am trying to inject 0003 but it seems that 0009 is the result, even though I am using a custom hex string in my boot.plist.


Edit: I am using GraphicsEnabler=No to try to stop Chimera doing its default injection.


Consequently, I have a slightly garbled display and I don't see my cursor. But acceleration seems ok.


Any ideas on how to get the right id injected?


I tried reverting to Chameleon r2064 but with the same config I am not getting any graphics.


Thanks!

Link to comment
Share on other sites

Update:


Now that I am home I was able to do a clean re-install and try again.

Now as long as I keep GE=No I get to the login window.


Interestingly, looking at system.log tells me that the WindowServer process takes up to 26 seconds to display any graphics after macx_swapon success, but when I inject ig-platform-id 0003 I get graphics almost instantly after swapon.


I'm still suffering from some 'garbled' graphics, cursor invisible etc. probably due to wrong memory settings. But my HP Insyde BIOS is locked and I can't change the pre-allocated memory (can't even see what it is set to). I think 0003 is the correct ID for my hardware in terms of pipes/ports, but not the memory. Sadly, there is no other ID with the same pipes/ports values.


Manually hex-editing the BIOS image and flashing it is risky, so I'm looking at editing kexts to match my hardware/BIOS configuration, hope I can find a solution that way. Probably something to take to another thread.


I have one open question though:


The Portuguese HD4000 guide on this forum mentions what to put in device-properties.plist to generate a hex string with gfxutil. But some other websites add another key called 'hda-gfx' to the plist, thereby resulting in a different set of hex strings:

 

<dict>
   <key>AAPL,ig-platform-id</key>
   <string>0x01620003</string>
   <key>hda-gfx</key>
   <string>onboard-1</string>
</dict>

Does this make any difference?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...