Jump to content
cjwescott

Patch request for ASRock Z77 Extreme 4-M

Recommended Posts

O.K. Since posting this I did try running multishit with the no-DSDT option along with installing my Lan and Audio drivers, but upon rebooting the OS doesn't run. See attached for a similar image to what I receive upon rebooting.

Additional reading on this topic appears to indicate that I need to do something with kext or other in order to get the system to boot up. This is where I am lost. Any explanation that I have read so far is not descriptive enough to assist a newbie like myself.

Screenshot-Mac.thumb.png.3794ca9abaea87145adbc4d7643de412.png

Link to comment
Share on other sites

cjwescott, I have made a patch for this motherboard. Even though Z77 boards needs no DSDT, to get the HDMI A/V working you need one.


Extract the DSDT and apply the patch. Hit compile and you should see 1 error to fix it just hit "Fix Error" button.

Save it as DSDT.aml onto desktop.


This patch includes:

HDMI A/V edits for HD4000.

Unknow SATA fix.

ASRock Motherboard sleep fix.


Remove AppleHDA and HDAEnabler from S/L/E and install the attached AppleHDA.kext.


Note - If you are using a graphics card using this DSDT both HD4000 and Graphics card should show in system information.




Credits - Olarila for generic patch which i have modified and toleda from tonycrap for audio edits and AppleHDA.



Update : 06/12/2012


As i have clearly written above some of the files were not mine and that is why i have taken them down. Sorry please google go to the rite place and get them.

Edited by Guest
Link to comment
Share on other sites

I receive two errors and one warning when I try and compile the dsdt with the patch. When I hit "fix errors", the same message comes up, 2 errors and 1 warning.


Errors are:

6906 Error Name already exists in scope (BUS0)

6909 Error Name already exists in scope (_ADR)

9654 Warning Statement is unreachable


Tried extracting my own dsdt file and running the patch and I get three errors of which the fix errors does not fix them. Problem with brackets is one message.

Link to comment
Share on other sites

The RAW file that you have attached above has already got all the edits in it. That is why when you are patching the DSDT you get errors.


You have extracted the DSDT on a system which has booted up using a DSDT file. Just use the DSDT file i have given in comment No 6, it will be fine.



Please refer to the below link for more info.


http://Olarila.com/forum/viewtopic.php?f=19&t=634


Important: Don't use "extract DSDT" if you booted using a patched dsdt.aml.

Edited by Guest
Link to comment
Share on other sites

I can't get the system to boot. I wanted to start over and reinstall the OS of the usb but I can't even get that to work. When I select USB on boot up it too doesn't get me to the install screen. It seems to be looking to the drive on boot up and I want it to only look at the USB stick. I don't know what is going on. Please don't tell me another corrupted usb stick. I didn't copy or move anything from it.

Link to comment
Share on other sites

O.K. some followup on my journey:


With the awesome assistance of Pmdsp I was able to get OSX up and running.


Ended up having one bad memory stick (1 of 4 gb). Removed all but one, hoping to not use the offending one and the install went pretty smooth with pmdsp's help.


When I updated to 10.8.2 lost audio. Again with pmdsp's suggestion, reinstalled applehda.kext and all was well with both my external speakers and youtube videos not playing.


Last night I was running Mem86+ to find the offending stick. I found it and only placed the 3 good ones in the motherboard.


Now unfortunately I lost audio again and youtube videos are not playing. Most say unavailable and the ones that are available play for 11 seconds and stop. Audio settings say no output device available. I removed one stick just to keep it even but that doesn't make a difference. Thought I would give it a shot though. Ran kextbeast with the applehda and appleacpiplatform on my desktop but this doesn't fix the problem this time.

Link to comment
Share on other sites

hello all. having quite a few issues getting this to boot without my USB installer. no combination of multishit seems to work. i made a DSDT file using the MoBo patch posted (this was the closest i got to success), tried with Easybeast. initially getting a "Kernel Panic" from what it seems (not familiar with UNIX commands and such so im blurry on details, here to learn), but i seem to get past that. the most successful attempt so far resulted in an everlasting apple loading screen


my next idea is to attempt to apply each driver through multishit before the separately to see what might be causing an issue. anything else i may have looked over?


my specs


AsRock Z77 Extreme 4

Intel i5 3570k

1TB caviar black HDD

EVGA nVIDIA GTX 660ti

ill get back you on the type of RAM, at school so don't know brand off the top of my head

Link to comment
Share on other sites

I am an amateur on this as well. I had a lot of assistance getting my machine running.

That said, I would make sure you do the following if you haven't already:

1. Set your internal graphics memory to 64mb in your bios

2. Do not install your graphics card until you are able to boot off your hard drive into OSX.


With the assistance I received from PMDSP I had a DSDT modified for my system. If you would like I could export mine out and post it here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...