Jump to content
seventy

suffering from ATI5650m lion driver

Recommended Posts

http://www.youtube.com/watch?v=O3CFvM5qIGE&feature=player_embedded


i have the same laptop as this one in video


i tried many times to derive my ati 5650 on lion GM 10.7 and on iAtkos L2 with this tutorial http://www.osx86.net/view/1502-qe-ci_with_..._lion!.html but nothing done

each time i end with the apple boot logo and the loading image under it freezed stopped rotating after some time around 2 minutes


the GM master i tried it with clean install and with different boot files the one on the tutorial files and the one on this video comments

and tried non clean install after sound and usb fix and other kexts


but the same thing happend freezing boot screen or panic error

and tried the tutorial after DSDT patching and nothing again the freezing boot logo

when i booting -v its sometimes acpi error and sometimes SMC cannt located driver error

i tried to use the extra this guy provided in the video and his boot file too but the same cant boot with chameleon only rboot with no graphics at all


this is my full configuration

AppleBootScreen.png


and this is my edid


 

0000FFFFFFFFFFFF0030E4B602000000001000140103802012780A1F659E5F589C27201B50540000000101010101010101010130010101010101121B567850000E30202040240041B51000001900000000000000005000000000000000000000000000FE004C604720446973706C61790A2020000000FE70004C503134355748312D544C42310062



and this is the Gold master i used


506999021.png



and this is my Graphics Card


5v6.png



any ideas about what is going wrong ???

or what can i do to get the full QE/CI

note am very new to mac

Link to comment
Share on other sites

hi


use system info and post u hardware


is in hardware


i use the forced edid and works good


and boot always until is all working


-v


what is the apple screen error ?



good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

after i did what u said i get this after the first reboot

No bootable device -- insert boot disk and press any key

 



now i cant enter even my windows 7 desktop without rboot CD :(


i was able to enter windows 7 without any boot cd or any boot loaders what i can do now ?

Link to comment
Share on other sites

ok i fixed it no problems at this i did something stupid with the new chameleon wizard


but now here is the story of what happend after i did what u told me in wrong way and lost boot i entered lion again with rboot LE and everything went ok


after i accessed the lion desktop i installed the Chameleon-2.0-RC5-r875 again and the problem resolved

i replaced the boot file and select boot0m option and and select the preinstalled tab or something like that tab above beside dropbox and folder on disk i think

when i restarted i got this


http://imageshack.us/photo/my-images/13/57454141.jpg/



http://imageshack.us/photo/my-images/607/81759437.jpg/


and i booted with verbose mod -v and i got this to

with the boot file provided on the tutorial on kext.com and i got this

http://imageshack.us/f/138/bvvbv.jpg/

and the boot file from the guy in the video with his extra folder replaced in my mac drive and i got this


http://imageshack.us/f/28/extravc.jpg/


is this can help u to state the problem ??

important note

i noticed in the 2 times the one with the boot file in the tutorial and the boot file provided in the youtube video from that guy

when i in the -v mode

it reads the card all its all details !!!!!!!!!!!

like its id

and its actual 1GB speed ???? and so on ????

i hope this can help u to state the problem well

Link to comment
Share on other sites

hi


man let we talk about something


now i do not know what are u doing and follow...


so if u follow something , must read all about and do the right way the tuto u are follow


and pay atention in something i gonna tell u


u must have a clone in another partition to do test..


if something go wrong u can recover u original install


one of the images u don't have fakesmc installed


and the chameleon to use must boot ML


if boot ML it boot too Lion, but some chameleon boot lion and do not boot ML like that 875


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

hi


man u card must work with forced edid


after u have u forced edid working well, it works on any mac os x

 

My DisplayProductID-717.zip

 

that is my forced edid


see in ati post where he goes


set AtiConfig=


Eulemur or Langur


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

finaly i got y card working :D:o


screenshot20120907at857.png


:lol::lol::lol::lol::lol::lol::lol: am very happy


but here is the story


i installed Chameleon-2.1svn-r2003.pkg


i replaced my boot file with this boot file in attachments


and created /extra folder and put in the extension folder the fakesmc.kext from the guy on the youtube video has the same my laptop with its all configuration exactly the same


after restart i cant be able to go to my desktop in any frame buffer i tried


ATiConfig=HooLock and ATiconfig=Knull aticonfig=KEulemor and Eulemur and Langur


some of them return with system uptime in nano seconds xxxxx :(

and others return with black screen and the light is on and the device still working


i tried to boot in verbose mode with no frame buffer and only my flags

cpus=1 busratio=20 -v

+ GraphicsEnabler=yes


and get scrembled screen before the login form


and i noticed three things :


1-the display properties in system configuration didnt have the

refresh rate drop list

here is the screen


screenshot20120907at506.png


2- i think the font it isnt smooth


3 - after first restart my menu system report reports my graphics card like this :?


screenshot20120907at858.png


very important note


i restarted the laptop more than 10 times with no aticonfig at all only graphicsenabler=yes and cpus,busratio to see what will happend

one time i can reache my desktop and the other one i got system uptime in nanosecond

in other word its mutual one successful start and the other failed


and with each restart before the laptop shutdown i have this text printed in my screen

MACH Reboot
No interval found for using 8000000
Restart still waiting on appleUSBEHCI

rc5_v1331_5650m___same subsystem as mine.zip

Link to comment
Share on other sites

what i can do for the smbios ???

and what about the graphics problem ? is this smbios will correct it !!!

i had other things to ask you for pls :(

can you batch the dsdt for me i tried it more than one time and every time i return with failed os :(

or show me a complete example of how i can do this ?

some times the lion logging me out without i doing anything wrong and i had to enter the pass again to login what is the reason of this problem ??? :(


please help me with the dsdt :(

Link to comment
Share on other sites

Many Many thanks artur-pt

:):):)

after the dsdt.aml file now

[*]i can shutdown and restart in very nice speed :o:o

[*]the camera is now working with flash light and faceTime :twisted::twisted:

[*]the fuckin right usb sata3 port is now working :mrgreen::mrgreen:

[*]very quiet 2 fans sound the cpu and the Gpu ;););)


but the is few problems :roll:

[*]the keyboard is going crazy the alt is used instead of the command [windows button] and no fn support no backlight and so on :(

[*]my voice output i dont know where it is now no voice at all :?:

[*]and i lost the touchpad too the didnt recognize it :!::!:


but i need you to give a look at this photos here


afterxl.jpg

is it normal to have the ids of the processors looks like this ???!!!!!!!!!!!!1 :!::!::!::!::!::!:



and at last many many many thanks specially for the fuckin right usb port u are the man :D


and i still have a problem in my graphics card if u wanna help :oops::oops:

Link to comment
Share on other sites

hi


man the dsdt is not a salvation


must work with the right kext to the hardware


dsdt is u bios optimize to mac os x, and to use native powermanagement


about the fn keys some note don't work but the patch is there


the cpu is right, if is not it give kp


about the graphics i have tell u how to try to work


good hack

PB Easy Note TM 86 - i5 430 M - H55M - Ram - 6 GB - Alc272 - Radeon HD 5470 512 QE/CI

Lenovo G500 - i5 3230m - HM77 - Ram - 8 GB - Conexant audio - HD 4000

My OS X Files 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...