Jump to content
wagedu

Bluetooth (e prefpane) some após sleep ou restart

Recommended Posts

Olá,


eu estou rodando um 10.7.2 "bastante estável" num ASUS N55SF, principalmente graças à ajuda do Artur, que editou minha DSDT http://Olarila.com/forum/viewtopic.php?f=7&t=646&start=30

Além disso, só instalei o SleepEnabler e VooDooHDA2.7.3. Sleep e Sound perfeitos, só o ajuste ocasional de som após cada wake, para eliminar plops e hisses.


Porém, minhas portas USB3 não funcionam (posso viver sem isso) e o meu Bluetooth exige apagar o kernelcache toda vez após wake ou restart. Tenho que ir pra partição Windows, deletar o arquivo kernelcache (que sempre é regenerado com a mesma data) e restartar o Lion.

Já eliminei meu SleepEnabler (ou perco BT a cada sleep) e já tentei

UseKernelCache

No

no meu Chameleon Boot, mas segue na mesma. Preciso apagar manualmente o kernelcache desde Windows, ou o meu OSX inicializa sem Bluetooth prefpane. E no System Info aparece como "No information found".


Apagando o kernelcache e reinicializando, tudo funciona perfeitamente.


Existe algum jeito mais simples e lógico de conservar o Bluetooth funcionando do que essa volta toda que estou dando?

E, if possible, alguma dica pro USB3?


Obrigado de coração :) Abs,

ASUS N55SF - Intel Core i7 2670QM - Ram 8Gb - Intel HD Graphics 3000 1920*1080 - GeForce not working

Link to comment
Share on other sites

SleepEnabler só serve para quem usa NullCPUPowerManagement. Se você tem DSDT ajustada e AICPM patcheada, não precisa delas.


Use Wait=yes UseKernelCache=No -v e confira se o kernelcache é lido.


Pro USB3 precisa instalar a kext http://Olarila.com/forum/viewtopic.php?f=2&t=1404

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Oi Cassio e obrigado pela orientação.


Segui a tua dica e iniciei com Wait=yes UseKernelCache=No -v e aparentemente o kernelcache não foi lido, ou seja meu Bluetooth funciona...

Não entendo pq as outras vezes ele é lido, se eu já tenho essa instrução no meu Extra/org.chameleon.Boot.plist

1. Como faço para resolver, sem ter que fazer manualmente toda vez?

[EDIT] No seguinte restart com os mesmos comandos, OSX sem Bluetooth. Unico jeito é apagar por Windows...


Após aplicar o AICPM Patch... sim, meu computador entra em sleep, mas aí o Bluetooth some. Agora estou com um Sleep que não posso "desligar" (o kext eu podia apagar) e que me elimina o Bluetooth quando acorda :(

2. Como faço para não perder Bluetooth toda vez q acordo do sleep?


Menos importante: Enquanto ao USB3, eu já tinha procurado no System Info mas não sei qual dos devices ele é.

devices.jpg

3. Como identificar qual device é o USB3, para depois poder baixar as kexts?

[EDIT] Procurando tanto pelo Vendor ID quanto pelo Device ID do "Unknown Device" fico sem resultados no Search de kexts...


Basicamente, sigo atrás de um jeito de não perder Bluetooth a cada wake e a cada restart.


Desculpe a pilha de texto mas estou tentando ser detalhado :)


Muito obrigado, abs

ASUS N55SF - Intel Core i7 2670QM - Ram 8Gb - Intel HD Graphics 3000 1920*1080 - GeForce not working

Link to comment
Share on other sites

Tente isto pro USB

http://www.osx86.net/view/2810-asmedia_usb_3.0_package.html


Se funcionar, use a opção File - Transmit data do System Info, assim outros com o mesmo hardware saberão qual kext usar.


Sobre o bluetooth realmente não tenho idéia, não faz sentido ter que remover o kernelcache pra funcionar se ele nem é carregado pelo Chameleon.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

O USB3 começou dando KP e depois boot disc not found. Apos apagar Extensions.mkext, voltou a funcionar.

System info postada, tomara que ajude alguém :)

(os "Unknown devices" seguem os mesmos...)


Enquanto ao Bluetooth e o kernelcache... não é só isso, mas é que o BT tb "morre" após cada sleep&wake. Mesmo q eu apague o kernelcache a cada restart, se o compu entra em sleep, BT some das prefs...


Alguma idéia? thx!

ASUS N55SF - Intel Core i7 2670QM - Ram 8Gb - Intel HD Graphics 3000 1920*1080 - GeForce not working

Link to comment
Share on other sites

Ok, agora é ainda mais esquisito: NADA A VER COM KERNELCACHE.

Na verdade, o que faz o BT "voltar" é reiniciar a maquina em Windows e depois em OSX.

Ou seja, assim que entro em "sleep", o BT some das preferências. Aí a única solução é desligar. Ligar em Windows. Desligar de novo. Ligar em OSX e BT tá lá de novo.


Parece como se o BT fosse literalmente desligado e só Windows conseguisse ligar ele de novo.


Alguma sugestão, please?


Muito obrigado

ASUS N55SF - Intel Core i7 2670QM - Ram 8Gb - Intel HD Graphics 3000 1920*1080 - GeForce not working

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...