Jump to content
eff7

Atualiza e nao funciona

Recommended Posts

Boa noite pessoal,


Ja faz uma semana que tento instalar o mac os x no meu notebook.

Consigo instalar o Lion 10.7, e atualizar ate o 10.7.2 sem problemas, so que quando tento atualizar para versao 10.7.3 ou 10.7.4, nao consigo mais usar o lion. Ja tentei instalar diretamente pelo 10.7.4, so que o sistema nao inicia.

Esse e um dos erros que a inicializacao apresenta quando atualizo meu sistema:

 

USBMSC Identifier (non-unique): 0x5e3 0x723 0x9454
SNB Framebuffer did not show up, unload
mbinit: done [64 MB total pool size, (42/21) split]
Pthread support ABORTS when sync kernel primitives misused
From path: "uuid",
Waiting for boot volume with UUID 4D2971C5-186A-325B-9E12-9C48AFFASF2
Waiting for <dict ID='0"><key>IOProviderClass</key<><string ID-="1">IOResources</string><key>IOResourceMatch</key><string ID="2"><boot-uuid-media</string></dict>
Still waiting for root device
Still waiting for root device

 

Tanto a instalacao, quanto a inicializacao do sistema operacional so funcionam com os seguintes comandos: "cpus=1 arch=i386 GraphicsEnabler=No -f". Nao sei mais o que fazer.


Tentei criar um dsdt seguindo divercos tutoriais, so que na hora de compilar da varios erros e nem compila nada. Gostaria de criar o meu para ter o lion mac funcionando bem no meu notebook.


Ja estou achando que nao e possivel usar o mac no meu notebook. Se alguem puder me da uma ideia do que fazer, me ajudar com isso ficaria muito grato.



Obrigado pela atencao.

A configuracao do meu notebook esta na minha assinatura.

E malz pelos acentos pessoal.

Edited by Guest

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Tente botar todas as kexts em /S/L/E e usar kernelcache http://Olarila.com/forum/viewtopic.php?f=10&t=456


Pro vídeo http://Olarila.com/forum/viewtopic.php?f=10&t=1339


Qual o notebook? Se for HP precisa do "lapic kernel" pra dispensar o cpus=1 http://Olarila.com/forum/viewtopic.php?f=10&t=1303

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Tente botar todas as kexts em /S/L/E e usar kernelcache http://Olarila.com/forum/viewtopic.php?f=10&t=456

Ja usei "KernelCache=No/Yes", "USBBusFix=No/Yes", mais nada de iniciar depois da atualizacao.

 

Preciso atualizar? Estou na versao 10.7.2, provavelmente se atualizar nem iniciar meu mac vai mais.

 

Qual o notebook? Se for HP precisa do "lapic kernel" pra dispensar o cpus=1 http://Olarila.com/forum/viewtopic.php?f=10&t=1303

Nao sei se pode postar links, entao: http://dl.dropbox.com/u/79284848/lga530spec.jpg


Tambem esqueci de falar que o 10.7.2 so inicia com a pasta Extensions do 10.7. Triste.

Obrigado desde ja pela atencao.

Edited by Guest

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Tem que estar usando kernelcache já antes de atualizar, com todas as kexts em /S/L/E. O parâmetro é UseKernelCache=Yes, configure no Boot.plist e faça boot com Wait=yes -v (sem -f) pra conferir se não tá lendo todas as kexts mas sim o kernelcache.


O vídeo só vai ter aceleração após o update 10.7.3.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Usando o comando que voce falou no topico:

eff7-MacBook-Pro:~ patchbot$ sudo kextcache -prelinked-kernel

Password:

JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

JMicronATA.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

 

Isso, uso "UseKernelCache=Yes/No", e que confudi agora na hora.

Ou seja, nao posso atualizar ainda ne? Como resolvo o problema acima? So deletar da pasta extensions?

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Isso não é problema, são apenas avisos, o kernelcache é atualizado mesmo assim.


Confirme que o kernelcache tá sendo usado e atualize.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

O UseKernelCache parece está funcionando corretamente, não apresenta nenhuma mensagem de erro e aquele carregador de kexts ficou menor e mais rápido.


Depois disso fiz a atualização para versão 10.7.4, quando ia inicia apareceu uma tela azul rapida seguida por uma tela preta, que acho que trava o notebook, porque so consegui desligar da maneira forçada.


Fiz backup e deletei aqueles arquivos da AppleIntel que você citou e reiniciei.

Só que agora aparece os erros:

Essa são as três ultimas linhas das coisas que aparecem:
ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
DSMOS has arrived
nspace-handler-set-snapshot-time: 1339116982

 

E mais uma vez não sei o que fazer.

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Você fez todos os procedimentos indicados no tópico sobre a Intel HD 3000?


Depois de remover as kexts no single user você tem que rodar o comando pra atualizar o kernelcache. Mas a idéia não é essa, depois do update o vídeo deveria funcionar acelerado (se feitos todos os ajustes).

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Você fez todos os procedimentos indicados no tópico sobre a Intel HD 3000?

Sim, deletei aqueles arquivos AppleIntel, configurei o smbios para macbookpro 8,1. Fiz isso tanto antes de atualizar, como depois de instalar o combo update 10.7.4. So nao tenho dsdt para aplicar nada.

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Para resoluções superiores a 1366x768 normalmente é necessário injetar a propriedade DualLink no dispositivo de vídeo

É o seu caso?


Todo BIOS tem DSDT, você só precisa fazer alguns ajustes.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

É o seu caso?


Todo BIOS tem DSDT, você só precisa fazer alguns ajustes.

 

Segui os procedimentos para extrair o dsdt com o dsdt editor, so que quando chego na parte de compilar não consigo porque aparece varios erros.


Aconteceu algo diferente agora, dei boot com a opção "Graphics Mode"="1024x768x32", no lugar de terminar naqueles 3 erros lá em cima, terminou com o erro:

DSMOS has arrived

nspace-handler-set-snapshot-time: 1339116982

NTFS volume name, version 3.1.

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Eu usei "-f "Graphics Mode"="1024x768x32" -v" e voltou a apresentar o erro abaixo:

Waiting for <dict ID='0"><key>IOProviderClass</key<><string ID-="1">IOResources</string><key>IOResourceMatch</key><string ID="2"><boot-uuid-media</string></dict>
Still waiting for root device
Still waiting for root device

 

Vou demorar um pouco para pegar o dsdt novamente, porque vou instalar denovo o lion 10.7, depois pegar a partir do dsdt editor.



Obrigado novamente pelas respostas e atenção.

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Que versão do Chameleon você tá usando?


Esse "Still waiting for root device" relacionado ao não uso do kernelcache pode ser problema no Chameleon.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Tinha esquecido, mais meu dsdt editor nem compila, ele nao gera o AML. Na hora de compilar aparece varios erros.

A versao do meu chameleon e a v5.0.132 - Enoch by ErmaC r1986, mais tambem ja tentei com o chimera.



Esses sao errors que aparecem quando tento compilar, lembrando que ja cliquei em "fix errors", mais nada funciona. Nao posso gerar o AML.

http://dl.dropbox.com/u/79284848/Screen%20Shot%20Compile%20Errors.png

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Consegui gerar, segue abaixo o link. Fiquei em duvida se poderia remover alguma coisa.

http://dl.dropbox.com/u/79284848/notedsdt.aml


A proposito Cassio, vi que sua placa de video e uma GeForce GT 425M, proxima da minha, sera que um dia a minha vai funciona no lion?

E a versao do meu chameleon e boa? Voce recomenda alguma outra?

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Você precisa aplicar os patches, não adianta só compilar o original.


A diferença do seu vídeo é que funciona em conjunto com a Intel HD, não sei se vai funcionar em hackintosh.


O Chameleon não estou acompanhando, uso a 1820.

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Você precisa aplicar os patches, não adianta só compilar o original.


A diferença do seu vídeo é que funciona em conjunto com a Intel HD, não sei se vai funcionar em hackintosh.


O Chameleon não estou acompanhando, uso a 1820.

 

Quais patches? So o da intel que voce citou la em cima?


De qualquer forma mesmo se so a intel funcionar, fica bom pra mim, sera que fica instavel? Devo desistir de tentar instalar o lion 10.7.4?

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Obrigado Cassio, resolvemos alguns problemas, mais outros continuam aparecendo, entao vou verificar algumas coisas denovo.

CPU: i7-2670QM, RAM: 6 GB, HDD: 750 GB, Video: Intel HD Graphics 3000 e nvidia GT 555M 2GB

Audio: Realtek ALC269 e Intel, Network: Atheros AR8151 e Ralink RT3090

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...