Jump to content
Bauer

CRIANDO UM HACKINTOSH SERVER USANDO UM SERVIDOR HP INTEL!

Recommended Posts

E ae galera, estou com um servidor HP proliant ML110 G5 e bateu a idéia de instalar o OS X lion nele.


http://h18000.www1.hp.com/products/quickspecs/12867_na/12867_na.HTML


Ele usa um processador Intel Xeon 3065 775 + 2gb de memória DDr2 800mhz com ECC.


Instalei um drive gravador de DVD sony e não usei o HD SAS que vem no servidor e sua controladora para instalar o OS X...apesar de suportados no OS X (testei em outra maquina com o OS X já instalado) preferi usar um HD separado usando o chipset serial ata nativo da Intel. Para tal usei um HD de 1tb WD sata II.


O video onboard desse servidor não ajuda nada..nem para windows...é um video apenas para visualizar as atividades do servidor.


O hardware suplementar que pretendo usar é.:


Placa de video NVS440 (quadro) Asus (256mb de memória) DVI + VGA. Essa placa é compativel com o Snow...já usei em outra maquina para teste a um tempo atras.

Como o servidor só tem slots pci-e de 8X, para usar uma placa 16X no slot de 8X eu precisei fazer um "hack"na placa NVS440, fazendo um pequeno corte no barramento PCI-E correspondente ao encaixe para 8X, senão ela não caberia...mesmo assim ela funciona normalmente em outros slots PCI-E (8X/16X)

+

controladora SAS Lsi logic

HD SAS Seagate 72gb, esse com windows, ou Linux.


para instalar, usei o metodo tonycrap com o unishit... a instalação rola normalmente...porem depois que o sistema reinicia, a tela trava com um kernel panic depois do boot pelo proprio unishit...

 

DSCN0980.thumb.JPG.546f6104fc00ec9ffd952a2e84067d9f.JPG

 

e usando -V depois, aparece assim.:

 

DSCN0984.thumb.JPG.07f3014d820b71d4ec1dac76201b2572.JPG

 

alguma dica para esse problema?

Edited by Guest

ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE

X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA

Link to comment
Share on other sites

Boas novas... o problema foi parcialmente resolvido...era a placa de video!


Servidor rodando o OS X lion 10.7.3! Reinstalei o sistema dessa vez usando o HD SAS e usando o HD de itb sata como backup.


Coloquei uma 8500GT 256mb e funcionou normalmente.


Vou fazer uma upgrade de video em breve por uma Nvidia Quadro NVS-300 PCI-E 1X 512mb DDR3 que arrematei baratinha no ebay! E tambem arrematei uma placa de som asus PCI-E 1x que usa o codec ALC888s... acho que vai ficar legal.


Um detalhe interessante, é que o servidor funciona razoavelmente bem sem dsdt... fazendo o metodo de instalação mais comum by tonycrap , ligar e desligar fuciona normalmente com a opção without DSDT. O unico erro que detectei até o momento é que as vezes após ligar, o sistema para na tela de inicialização pós seleção de boot no Chameleon...


Optei por esta opção por enquanto porque não consigo compilar a DSDT. Quando é feita a extração da mesma e é complilada, são resolvidos varios problemas, porem, SOMETE UM dos erros não é resolvido, então não é possivel gerar / salvar a DSDT.aml. Isso precisa ser feito manualmente?


E como faço para identificar corretamente o processador? no caso ele identifica como Core2Duo, e o modelo seria a sua versão Xeon.


obrigado

ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE

X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA

Link to comment
Share on other sites

Isso precisa ser feito manualmente?

Sim.

 

E como faço para identificar corretamente o processador?

Configure no SMBIOS.plist


SMcputype=1281

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Ola Cassio, obrigado pela dica, funcionou muito bem a respeito do processador!

 

27527792_CapturadeTela2012-05-17s03_30_16.png.f5ec36653d510dacb56d470295f548d1.png

 

Mas em relaçao a DSDT, como posso altera-la?


dei um print lá no erro e salvei a dsdt.dsl em anexo!

 

1140925997_CapturadeTela2012-05-17s03_39_33.png.364151bb3b7bfae09cf8b4ce77b82588.png

 

Se puder dar um help, agradeço!


A placa de som que eu havia citado nao vai funcionar eu acho porque ela usa uma interface que so tem nas placas da asus, (MIO) achei que era pci-e 1x!


Alguma dica de placa de som relativamente barata que nao seja USB e que eu possa usar? Essa asus MIO ia ser excelente...uma pena. Nao se acha placas com codec da realtek tipo azalaia! só VIA ou Creative na grande maioria.


obrigado

dsdt.dsl.zip

ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE

X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA

Link to comment
Share on other sites

Mude o length para 0x00000001.


Sobre o áudio, faça uma busca no Google tipo "mac compatible usb audio", encontrei esta, por exemplo

http://www.turtlebeach.com/products/sound-cards/audio-advantage-amigo-ii.aspx

ASUS N53Jq • CPU: Intel Core i7-740QM 1.73GHz • RAM: 6,0GB • HD: 500GB • GPU: GeForce GT 425M 1GB 1920x1080 • OS: OS X 10.8.4 • Linux Mint 15 • Windows 8

Link to comment
Share on other sites

Muito obrigado Cassio...novamente sua dica funcionou!

 

542168320_CapturadeTela2012-05-17s15_02_08.png.83096601b9fceceb4ae7aca944b26c0f.png

 

depois eu vou refazer o processo do chamaleon com DSDT para testar.


Sobre o som, realmente já havia achado muitas opções USB! mas queria ver alguma PCI-E 1x ou PCI... mas de qualquer forma, até para economizar slot que são poucos, a melhor opção vai acabar sendo optar por uma usb mesmo!


Por hora, mais uma vez, obrigado.

ASUS P6X58D-E/12GB/i7-960 8MB 3.20GHz/NVIDIA GTX 650/WINDOWS 10/YOSEMITE

X87-DELL-16GB-DDR3-1600MHZ/XEON E3-1220v3 8MB/NVIDIA GTX1050/WINDOWS 10/XUBUNTU/OSX-SIERRA

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...