Jump to content

Olarila HackBook Lenovo IdeaPad S145 10th Gen / Catalina / Big Sur / Monterey Full DSDT Patches / Clover and OpenCore


Recommended Posts

  • Replies 442
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal https://tinyurl.com/r7fchn9 Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 Donation with ETH 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05 Donation with LTC MTmk

Alternativa para quem está sofrendo com os Kernel Panics de áudio em Ice Lake + Big Sur + AppleALC: -- Testado no Lenovo S145 82DJ0000BR (i7 1065G7 com ALC230) -- - Substituir a kext AppleAL

--update- Full Efi folder https://easyupload.io/gvkgeu

  • Administrators
1 hour ago, Ruki Studios said:

Thanks for your job and very noob and dumb question. Will this EFI folder work with an Ideapad 3 14IIL05 using a ci3 1005G1? It's almost the same laptop but with a smaller screen.

this folder work for u but acpi no

Link to post
Share on other sites
25 minutes ago, MaLd0n said:

this folder work for u but acpi no

I generated my own DSDT.dsl using the SSDTTime tool. Will that suffice or there is there another guide I need to follow? Thanks by the way

Edited by Ruki Studios
Link to post
Share on other sites
On 9/10/2021 at 12:02 PM, MaLd0n said:

0.7.3

Finalmente consegui que a bateria apareça. No entanto não aparece sempre. Uma vezes ligo e esta la o símbolo mas outras vezes ligo e já não aparece sem alterar nada.

Descobri apos vários testes que para o símbolo da bateria aparecer tenho de ir ao propertree ou ao OC configurator e desabilitar e voltar a habilitar os patch  EC0_EC e o RTC-STA que são os 2 que la estão.

Se por acaso eu trocar as KEXT mesmo que seja substituir pelas mesmas ( que estão atualizadas para o 073) e fizer Um OCsnapshot e reeinicializar o PC a bateria também aparece mas não posso fechar o OCconj ou o propertree quando desligo

Mas é muito chato ter de estar sempre a fazer isso antes de desligar o PC.

Será que alguém me pode dar uma ajuda? pois eu penso que será uma coisa simples que me esta a escapar. Séra algum Boot arg?

Link to post
Share on other sites
On 9/15/2021 at 6:49 PM, MaLd0n said:

então não tem pq vc usar a nossa pasta

isso é específico para o hardware s145

Mas foi com a vossa pasta que eu consegui montar o meu hackintosh quase na perfeição, e da qual te agradeço muito mesmo.

O sucesso do meu projecto foi porque todas as especificações deste PC são as mesmas do s145 i3  incluindo o processador intel 10005G1 a ram a placa gráfica a placa de rede etc etc so o baptizaram com outro nome.

Claro que tive de fazer as minha tabelas de ACPI especificas.

Dai que eu considero que este também é um post meu. e toda a ajuda que eu possa dar também é valida.

Graças a todos vós tenho um excelente hackintosh muito estável e 95% funcional.

A cereja no topo do bolo seria conseguir que o símbolo da bateria aparecesse sempre e não só as vezes. e ate penso que será´um ajuste simples mas que a mim me está a escapar. é muito estranho o porque de ser intermitente umas vezes ao ligar aparece outras não. Já perdi imensas horas a mudar parâmetros e o resultado e sempre o mesmo, a ultima desconfiança é que poderá ser uma configuração de  SMBIOS mas não sei. Quando a bateria aparece tudo funciona a 100% incluído o britness e o painel de trackpad nas definições. Quando  a bateria não aparece o painel de trackpad também não abre.

Não sei se já aconteceu a alguém e como resolveu

 

 

Edited by enduromen
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap