Jump to content
MaLd0n

Hackintosh Lenovo IdeaPad S145 10th Gen Full DSDT Patches / Clover and OpenCore

Recommended Posts

  • Administrators

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

 

-OpenCore Vanilla Guide - https://tinyurl.com/ycvcnp8h

-Clover Vanilla Guide - https://tinyurl.com/ydhgntcz

-How to create a personal Vanilla MacOs Bootable - https://tinyurl.com/ycq2co9b

 

dqdMwSg.jpg

-Wifi card has been replaced with Broadcom!

-I'm using a S145 Model with Intel Core i5-1035G1 IceLake / Intel HD Graphics ICL

-Update bios/uefi to last version 

 

--Bios/UEFI config--

Go to Security tab and disable Secure boot

 

-IceLake Premade installation Folder (easy way installation)

https://www.olarila.com/topic/5676-hackintosh-efi-folders-for-all-chipsets-clover-and-opencore/

 

--Clover and OpenCore Folders--

If you share this folder elsewhere, don't forget the credits.

Just paste EFI folder inside EFI partition

EFI Lenovo S145 IceLake.zip -Update to last Bios/UEFI version DKCN55WW (Just use this EFI folder with this version)

--Enable Trackpad Dragging Option--

Go to System Preferences/Accessibility/PointerControl/Trackpad Options and "Enable dragging"

45AXPIX.png

 

-ScreenShots

9PlPgeH.png

 

aQtD1kd.png

Y4VVTLw.png

8lF1F5r.png

uBgCbw5.png

rW20hTZ.png

AlUaXia.png

I1LaCaW.png

Vhy2gYz.png

xADwPRt.png

5YtpalZ.png

zDttQOr.png

2dPIDLo.png

Tb3s6vV.png

qqOLprw.png

oM27y1a.png

OPGd5yF.png

3juf9Tl.png

crEwu6I.png

ceNizCj.png

3e5APwf.png

zSE7Orn.png

rJVj6iW.png

nCDSJ44.png

pSMCAdT.png

pCYUJeD.png

0Dhk3MT.png

-Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
 
Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Acidanthera Team, Olarila Facebook Community, Hackintosh Facebook Community and many others!
 
 
We're all here to have fun and learn from each other!
  • Like 4

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

Hello... I have a Ideapad S145-15IIL with Core i7 Ice Lake and iris plus graphics.

I manager to get Opencore installed in a USB drive and boot with all your EFI but i got stuck in a logo with the mouse and keyboard, seems that the Keyboard and mouse are not detected.

Edited by Salaberrip
Link to comment
Share on other sites

  • Administrators
2 hours ago, Salaberrip said:

I manager to get Opencore installed in a USB drive and boot with all your EFI but i got stuck in a logo with the mouse and keyboard, seems that the Keyboard and mouse are not detected.

after verbose?

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

  • Administrators
8 minutes ago, Salaberrip said:

- Trackpad not working

my trackpad is syna, if u have other need change i2c kext

9 minutes ago, Salaberrip said:

- Cursor corrupted image.

common for now

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

On 9/2/2020 at 5:38 PM, Salaberrip said:

Last update for now...i fix the trackpad (was the ELAN model) and Wifi using the itlwmx_v1.0.0_stable.kext and Heliport as workaround.

Real pity that the cursor is so Broken, its very difficult to be used as daily driver as it.

is this issues appearing in Big Sur too?

I have this same problem on the trackpad is all confused, the rest is working normally.

Link to comment
Share on other sites

  • Administrators
16 minutes ago, Max Alex said:

I have this same problem on the trackpad is all confused, the rest is working normally.

Need some updates in voodooi2c project

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Link to comment
Share on other sites

On 8/31/2020 at 6:01 PM, MaLd0n said:

-OpenCore Vanilla Guide - https://tinyurl.com/ycvcnp8h

Atualizei pro Public Beta usando a sua EFI do OpenCore e toda vez ele demora pra bootar até que para e reinicia o notebook, se eu tentar de novo, mesma coisa. 

Depois de atualizar (e depois de tentar no mínimo 15 vezes reiniciando o computador e esperando ele bootar no macOS) eu consegui bootar ele uma vez, mas precisei reiniciar e agora não consigo mais.

Sou leigo no assunto hackintosh, talvez eu precise fazer alguma mudança na config.plist ou algo do tipo mas eu só copiei a sua EFI e colei no lugar da minha antiga, que era do Clover, não sei mais o que fazer.

Obs: As parti√ß√Ķes que aparecem pra bootar s√£o Backup, Preboot e Recovery 11.0.

Agradeço desde já.

Link to comment
Share on other sites

Boa noite pessoal conseguir fazer o boot com o opencore utlizando a efi do MaLd0n, e está funcionando tudo mouse e tudo mais, adicionei a Voodooi2Elan apra funcionar o mouse, minha efi que estou utilizando é a https://drive.google.com/file/d/1XiHhB0X-zHcLyLHU4rktlaTMSUbduGpi/view?usp=sharing

Realizei 2 testes na mesma verifiquei que o problema do bug no mouse é por causa da VoodooI2CELAN.kext sendo que com ela ele funciona o mouse normalmente com todos os gesto mais o mouse fica um pouco borrado e sem ela o mouse aparece normalmente mais não funciona o mouse, estou realizando uns teste com a versão compilada do codigo e trago mais resposta e noticias a vocês.

Link to comment
Share on other sites

1 hour ago, MaLd0n said:

Inside this folder have syna i2c kext not elan, remove this kext and add elan. dont need use system folder. u can use all in bootloader kexts folder

It worked :)

I think we already have a nice daily driver now :)

I will try to get a Broadcom WiFi Card to avoid the use of Heliport...or we will wait for the Black80211 project be more stable to put the Intel card natively into MacOS

https://github.com/usr-sse2/Black80211-Catalina

But for now, its totally up and running, Thanks!

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
  • Create New...
The popup will be closed in 15 seconds...