Jump to content
Shinji3rd

[Solved] ASUS Zenbook UX310, can't boot using OpenCore

Recommended Posts

Posted (edited)

Hi!

I'm a long time Hackintosh user. I started with Chameleon, then I had to learn a lot to use Clover, and now I'm trying to learn and use OpenCore.

My laptop currently works perfect with Clover, on Catalina, but now that we have a public beta of Big Sur and that I'm about to get a new laptop with an Intel 10th gen processor, I wanna try OpenCore.

There are too many guides and even some contradicting info on the net, but after some hours, I think I have an EFI folder in compliance to what OpenCore needs for this system. However, I'm putting that EFI folder on a usb stick, boot from it to see if I can boot to my current Catalina installation, and all I get is a panic. I don't know why, or how to solve it.

Things I tried:

  • Removing all the kexts except for the mandatory ones (Lilu, Whatevergreen & VirtualSMC) -and of course, removed the entries from config.plist-
  • Go to hieplpvip Github for the Zenbook, take a look at his Opencore branch and do some modifications to adapt my EFI to his. No result, same panic at the same spot.
  • Tried with and without DSDT. No change.
  • Cleared NVRAM, tried again after that. Same error.
  • Different combinations for SyncRuntimePermissions and RebuildAppleMemoryMap as per some posts on Reddit and other sites, but nothing changed.


I'm not seeing what's wrong, but I can't boot using OpenCore. If I then boot directly from my SSD where Clover is installed, everything is smooth. Can someone with more knowledge than me in OpenCore give me a hand?

Find attached the EFI I'm using to try (removed uuid on purpose, and removed kexts folder so it fits here, because I can't upload a file larger than 2.93mb here). I'm attaching my current ACPI folder, that I use with Clover, if anyone can use it to compare it with what I'm using in OpenCore  and see what's wrong.

This is what I'm getting:

00:000 00:000 AAPL: [EB|#LOG:INIT] 2020-08-10T06:45:10
00:129 00:129 AAPL: [EB|#VERSION] boot.efi 422.140.3~11 (Official), built 2020-07-05T01:34:33-0700
00:243 00:114 AAPL: [EB|#BUILD] BUILD-INFO[300]:{"DisplayName":"boot.efi","DisplayVersion":"422.140.3~11","RecordUuid":"hiding this on purpose","BuildTime":"2020-07-05T01:34:33-0700","ProjectName":"efiboot","ProductName":"boot.efi","SourceVersion":"422.140.3","BuildVersion":"11","BuildConfiguration":"Release","BuildType":"Official"}
00:357 00:113 AAPL: [EB|#H:IS] 0
00:471 00:114 AAPL: [EB|#WL:MODE] 0
00:585 00:113 AAPL: [EB|#CONFIG:SRC] <default>
00:741 00:155 AAPL: [EB|#CONFIG| 0] boot-save-log : 0x0000000000000002 (0x0000000000000002 < 0xFFFFFFFFFFFFFFFF) <default>
00:855 00:114 AAPL: [EB|#CONFIG| 1] wake-save-log : 0x0000000000000002 (0x0000000000000002 < 0x0000000000000002) <default>
00:969 00:114 AAPL: [EB|#CONFIG| 2] console       : 0x0000000000000001 (0x0000000000000001 < 0x0000000000000001) <default>
01:083 00:114 AAPL: [EB|#CONFIG| 3] serial        : 0x0000000000000000 (0x0000000000000000 < 0x0000000000000000) <default>
01:197 00:114 AAPL: [EB|#CONFIG| 4] embed-log-dt  : 0x0000000000000000 (0x0000000000000000 < 0x0000000000000000) <default>
01:311 00:114 AAPL: [EB|#CONFIG| 5] timestamps    : 0x0000000000000000 (0x0000000000000000 < 0xFFFFFFFFFFFFFFFF) <default>
01:425 00:114 AAPL: [EB|#CONFIG| 6] log-level     : 0x0000000000000001 (0x0000000000000001 & 0x0000000000000001) <default>
01:539 00:114 AAPL: [EB|#CONFIG| 7] breakpoint    : 0x0000000000000000 (0x0000000000000000 & 0x0000000000000000) <default>
01:653 00:114 AAPL: [EB|#CONFIG| 8] kc-read-size  : 0x0000000000100000 (0x0000000000100000 < 0xFFFFFFFFFFFFFFFF) <default>
01:767 00:114 AAPL: [EB|#H:IS] 0
01:882 00:114 AAPL: [EB|#WL|0] 0x01 0x01   0 0x00
02:037 00:155 AAPL: [EB|#BRD:NV] Mac-hiding this on purpose
02:151 00:114 AAPL: [EB|#WL|1] 0x01 0x01   2 0x00
02:266 00:114 AAPL: [EB|`BST:IDT] {
02:382 00:115 AAPL: [EB|`BST:IDT] }
02:496 00:114 AAPL: [EB|#WL|2] 0x01 0x01   3 0x00
02:610 00:114 AAPL: [EB|#WL|3] 0x01 0x01   4 0x00
02:724 00:114 AAPL: [EB|#BRD:NV] Mac-hiding this on purpose
02:838 00:114 AAPL: [EB|#WL|4] 0x01 0x01   5 0x00
02:952 00:114 AAPL: [EB|`H:CHK] BM: 0x0000000000000000
03:067 00:114 AAPL: [EB|`H:CHK] Err(0xE) @ GV boot-signature
03:181 00:114 AAPL: [EB|#WL|5] 0x01 0x01  23 0x0E
03:332 00:151 AAPL: [EB|`H:CPM] Err(0xE), (24, 24) @ GV Persistent-memory-note
03:450 00:117 AAPL: [EB|`SB:EN] Err(0xE) @ LocP hiding this on purpose
03:564 00:114 AAPL: [EB|#LIMG:DP] Acpi(PNP0A03,0)/Pci(1D|0)/Pci(0|0)/?[ 0x83 0x17 0x10 0x0 0x1 0x0 0x0 0x0 0x0 0x25 0x38 0x5C 0x81 0xB2 0x26 0x6B ]/HD(Part2,SigBDC79661-0951-4EE1-8A1A-0C4C4BA16E8A)/VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842)
03:679 00:114 AAPL: [EB|#LIMG:FP] \6D991DAE-A7B8-41AF-A1A3-D6AA44A1060F\System\Library\CoreServices\boot.efi
03:793 00:114 AAPL: [EB|#LIMG:OPT] ()
03:908 00:115 AAPL: [EB|`OPT:LXF] 'LF (\\6D991DAE-A7B8-41AF-A1A3-D6AA44A1060F\\System\\Library\\CoreServices\\com.apple.Boot.plist)
04:022 00:114 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: \\6D991DAE-A7B8-41AF-A1A3-D6AA44A1060F\\System\\Library\\CoreServices\\com.apple.Boot.plist, DP: 0
04:136 00:114 AAPL: [EB|`LD:OFS] Err(0xE) @ OPEN (\\6D991DAE-A7B8-41AF-A1A3-D6AA44A1060F\\System\\Library\\CoreServices\\com.apple.Boot.plist)
04:250 00:114 AAPL: [EB|`OPT:LXF] Err(0xE) @ 'LF
04:364 00:114 AAPL: [EB|`OPT:LXF] 'LF (Library\\Preferences\\SystemConfiguration\\com.apple.Boot.plist)
04:478 00:114 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: Library\\Preferences\\SystemConfiguration\\com.apple.Boot.plist, DP: 0
04:593 00:114 AAPL: [EB:#KF] ()
04:726 00:133 AAPL: [EB|#MBA:CL] ()
04:840 00:114 AAPL: [EB|#MBA:NV] (-v debug=0x100 keepsyms=1 alcid=3 lilucpu=8)
04:954 00:114 AAPL: [EB|#MBA:KF] ()
05:068 00:114 AAPL: [EB|#MBA:OUT] (-v debug=0x100 keepsyms=1 alcid=3 lilucpu=8)
05:183 00:114 AAPL: [EB|#LOG:VERBOSE] 2020-08-10T06:45:15
05:297 00:114 AAPL: [EB|#OPT:BM] 0x84182
05:411 00:114 AAPL: [EB|`OPT:LXF] 'LF (\\6D991DAE-A7B8-41AF-A1A3-D6AA44A1060F\\System\\Library\\CoreServices\\PlatformSupport.plist)
05:525 00:114 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: \\6D991DAE-A7B8-41AF-A1A3-D6AA44A1060F\\System\\Library\\CoreServices\\PlatformSupport.plist, DP: 0
05:640 00:114 AAPL: [EB|#B:VAw]
05:754 00:114 AAPL: [EB|#P:CPR] N
05:869 00:114 AAPL: [EB|#P:MPI] N
06:022 00:153 AAPL: [EB|#P:BPI] N
06:136 00:114 AAPL: [EB|`CS:CSKSD] {
06:250 00:114 AAPL: [EB|`CS:CSKSD] Err(0xE) @ GV hiding this on purpose:boot-info-payload
06:364 00:114 AAPL: [EB|#WL|6] 0x01 0x01   6 0x0E
06:479 00:114 AAPL: [EB|`CS:LFC] {
06:593 00:114 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: System\\Library\\Caches\\com.apple.corestorage\\EncryptedRoot.plist.wipekey, DP: 0
06:709 00:116 AAPL: [EB|`FS:AGSVH] Err(0xE) @ LocHB hiding this on purpose
06:823 00:114 AAPL: [EB|`G:CS] } Ok(0)
06:937 00:114 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: <null string>, DP: 1
07:053 00:115 AAPL: [EB|`B:SBS] SZ: 621112
07:172 00:118 AAPL: [EB|#B:SHA] ddd967ac3c18abcbba6f6169c748e9ad4ecc21a3
07:326 00:154 AAPL: [EB|`WL:PWLFNV] Err(0xE) @ GV wake-failure
07:440 00:114 AAPL: [EB|`WL:DT] Err(0xE) @ WL:PWLFNV
07:555 00:114 AAPL: [EB|`WL:PWLFRTC] ! @ RTC:R
07:669 00:114 AAPL: [EB|`WL:DT] Err(0xE) @ WL:PWLFRTC
07:783 00:114 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.0
07:897 00:114 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.1
08:011 00:114 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.2
08:126 00:114 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.3
08:240 00:114 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.4
08:354 00:114 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.5
08:468 00:114 AAPL: [EB|`LD:LKC] BPDK -> (System\Library\PrelinkedKernels\prelinkedkernel.development)
08:624 00:155 AAPL: [EB|`LD:OFS] Err(0xE) @ OPEN (System\\Library\\PrelinkedKernels\\prelinkedkernel.development)
08:738 00:114 AAPL: [EB|`LD:LKC] BPDK,!R -> (System\Library\PrelinkedKernels\prelinkedkernel)
11:387 02:649 AAPL: [EB|`LD:LKFS] } Ok(0)
11:510 00:122 AAPL: [EB|`LD:LKC] } Ok(0)
11:625 00:115 AAPL: [EB|#FWFM] 0xFF1FFF7F
11:739 00:114 AAPL: [EB|#FWFT] 0xFF0FF57E
11:854 00:114 AAPL: [EB|#CSR:IN] 0x00000040
11:968 00:114 AAPL: [EB|#CSR:OUT] 0x00000040
12:082 00:114 AAPL: [EB|`BST:FBS] {
12:197 00:114 AAPL: [EB|`BST:FBS] BA.ADSZ: 0
12:311 00:114 AAPL: [EB|`BST:FBS] BA.KSDSZ: 0
12:463 00:152 AAPL: [EB|`B:WFDW] Err(0xE), 0 @ LocHB hiding this on purpose
12:580 00:116 AAPL: [EB|#LOG:DT] 2020-08-10T06:45:22
12:695 00:114 AAPL: [EB|#LOG:EXITBS:START] 2020-08-10T06:45:22



Thank you in advance!

EFI.zip

ACPI.zip

Edited by Shinji3rd

Share this post


Link to post
Share on other sites

what processor this notebook have?

Share this post


Link to post
Share on other sites

i7-7500U (Kabylake). But I use lilucpu=8 in bootargs and inject properties to emulate Skylake graphics, because there is a known issue with Kabylake graphics showing weird color gradients on the internal screen, solved by emulating Skylake graphics.

Share this post


Link to post
Share on other sites
1 hour ago, MaLd0n said:

u check ur config with OpenCore Sanity Checker?

https://opencore.slowgeek.com/

Yes, and it's all fine: https://opencore.slowgeek.com/?file=laptopkabylake060hV8TVR&rs=laptopkabylake060

PickerMode = External is ok because I'm using OpenCore's graphic interface. Only thing that changes using builtin is that you select the boot units using a text-only ugly-looking gui on screen.

AAPL,ig-platform-id = 00001619 is correct too because I'm spoofing Skylake graphics on purpose.

SMCBatteryManager.kext is ok, the battery is already patched. But I tried removing that kext and line from config.plist and it's the same, I can't boot and get the same error.

Share this post


Link to post
Share on other sites

I FINALLY DID IT! Had to try way too many things, but finally I am able to boot with OpenCore. Not only that, I also fixed Wi-Fi and Battery after booting with OC. So now I have the same fully functional Hackintosh, but booting with OC instead of Clover. This is now solved!

  • Like 1

Share this post


Link to post
Share on other sites
On 8/11/2020 at 9:01 PM, Shinji3rd said:

I FINALLY DID IT! Had to try way too many things, but finally I am able to boot with OpenCore. Not only that, I also fixed Wi-Fi and Battery after booting with OC. So now I have the same fully functional Hackintosh, but booting with OC instead of Clover. This is now solved!

Can you add your final EFI folder working, please?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...