Jump to content
thorasgard1

(Success) Acer Aspire 5 (A515-54g) i5-10210u

Recommended Posts

On 11/19/2020 at 1:49 PM, thorasgard1 said:

If you dont using touchpad, unlock touchpad flexi from MB and KB will be working every time 😀 I using usb mouse.

[Solved keyboard] Finally! A515-54G-53GP 100% operational! (Except Wifi).

OSX 10.15.7 Catalina - OpenCore 0.6.3

I was able to solve the keyboard problem. Just use Hackintool.

1-Mount your EFI partition.

2-Run Hackintool.

3- Go to the "Utilities" tab.

4 Select "Install Kexts" and install all VoodooPs2.kext that are inside your EFI.

5-Done this, you can delete all voodoops2.kexts from your EFI and update the config.plist.

I highly recommend using a ProperTree tool and the command (cmd, shift, R) to update and organize everything.

                 Note:  1 - Open Config.plist with "cmd + o"

                             2 - Select your "OC" folder in EFI with "cmd + sft + r"

That done, just restart. Infallible. I tested it several times.

Be happy ... 😎

My EFI and VooDooPs2Control.kext with the internal plug-ins:

https://drive.google.com/file/d/1GpxM0F8lnLlp0BV-nZbsHWvCgtCxuXaU/view?usp=sharing

 

Edited by Master System
Link to comment
Share on other sites

17 hours ago, Master System said:

[Solved keyboard] Finally! A515-54G-53GP 100% operational! (Except Wifi).

OSX 10.15.7 Catalina - OpenCore 0.6.3

I was able to solve the keyboard problem. Just use Hackintool.

1-Mount your EFI partition.

2-Run Hackintool.

3- Go to the "Utilities" tab.

4 Select "Install Kexts" and install all VoodooPs2.kext that are inside your EFI.

5-Done this, you can delete all voodoops2.kexts from your EFI and update the config.plist.

I highly recommend using a ProperTree tool and the command (cmd, shift, R) to update and organize everything.

                 Note:  1 - Open Config.plist with "cmd + o"

                             2 - Select your "OC" folder in EFI with "cmd + sft + r"

That done, just restart. Infallible. I tested it several times.

Be happy ... 😎

My EFI and VooDooPs2Control.kext with the internal plug-ins:

https://drive.google.com/file/d/1GpxM0F8lnLlp0BV-nZbsHWvCgtCxuXaU/view?usp=sharing

 

On Big Sur does not work😖

Link to comment
Share on other sites

2 hours ago, thorasgard1 said:

On Big Sur does not work😖

 

Try using VooDoops2controler.kext that I posted above.
Remember to delete ps2.kexts from your EFI folder and update your config.plist.
I'll try with BigSur, too.
ProperTree is important because it loads the Drivers,
Kexts in the exact order and makes everything perfect.
I have already experienced errors with
OpenCoreConfigurator (I use it only to generate SmBios).
I will make a video of everything working and
how to do it as soon as I have time.
I hope it works for you too ...😎
Edited by Master System
Link to comment
Share on other sites

3 hours ago, Master System said:

 

Try using VooDoops2controler.kext that I posted above.
Remember to delete ps2.kexts from your EFI folder and update your config.plist.
I'll try with BigSur, too.
ProperTree is important because it loads the Drivers,
Kexts in the exact order and makes everything perfect.
I have already experienced errors with
OpenCoreConfigurator (I use it only to generate SmBios).
I will make a video of everything working and
how to do it as soon as I have time.
I hope it works for you too ...😎

KB lighting but no working. I stay on unplug flexi on TP from MB.

Link to comment
Share on other sites

10 minutes ago, thorasgard1 said:

KB lighting but no working. I stay on unplug flexi on TP from MB.

My notebook does not have this feature.(KB lighting)
You must insert the kext to make it work.
There is just one more thing that is bothering me and I wanted to solve:
The system will not turn on if you have a headset connected to the p2 output.
I know it is AppleALC that causes this, because if it is not in config.plist the notebook will turn on normally.
If anyone can help me, I would appreciate it!😎
Link to comment
Share on other sites

  • Administrators

try patch by Rodion

Quote

<dict>
                <key>Base</key>
                <string>_isSingleUser</string>
                <key>Count</key>
                <integer>1</integer>
                <key>Enabled</key>
                <true/>
                <key>Find</key>
                <data></data>
                <key>Identifier</key>
                <string>com.apple.iokit.IOHIDFamily</string>
                <key>Limit</key>
                <integer>0</integer>
                <key>Mask</key>
                <data></data>
                <key>MaxKernel</key>
                <string></string>
                <key>MinKernel</key>
                <string>20.0.0</string>
                <key>Replace</key>
                <data>uAEAAADD</data>
                <key>ReplaceMask</key>
                <data></data>
                <key>Skip</key>
                <integer>0</integer>
            </dict>

 

Donation with Paypal https://www.paypal.com/donate/?hosted_button_id=RYQ6CGUGK5D6S

Donation with Stripe https://tinyurl.com/2ssnydn6

Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

On 11/16/2020 at 8:31 AM, thorasgard1 said:

Clover has same security problem, cant instal apps as tuxera, which need install some kernel and check in security, this no options in security tab, oc work fine.

Clover custom icons does not work, i cant create recovery partition icon and others

Big problem with mounting EFI for work

Wirless kext its not good compatibile in Clover

FULLY WORKING CLOVER 👍

ABOVE MENTIONED PROBLEMS SOLVED

FOR OTHERS EFI http://s000.tinyupload.com/?file_id=11409594416974638249

  • Like 2
Link to comment
Share on other sites

20 minutes ago, bimantoro said:

Hi mate, can you share your efi folder for opencore?

mine is asus k413fq i5-10210u and i can't boot to installation setup even i try efi that maldon's share.

thanks

When i back from work to home i will posting OC/Clover latest EFI.

Long time i using OC but problem with dual boot to Win, i change to Clover no problem.

Link to comment
Share on other sites

54 minutes ago, thorasgard1 said:

When i back from work to home i will posting OC/Clover latest EFI.

Long time i using OC but problem with dual boot to Win, i change to Clover no problem.

i need for opencore,please :). oh btw do you dual boot on same disk or separate?

edit: catalina version if you have it, thanks

Edited by bimantoro
Link to comment
Share on other sites

On 11/30/2020 at 11:09 AM, thorasgard1 said:

This Clover EFI is working on Catalina, but there are some issues. I'm facing unexpectedly shutdowns, either using the battery or with charger plugged in. Also, as mentioned before, keyboard isn't working, but something weird happened: i closed the laptop, and after few minutes, opened again, and the keyboard suddenly worked. I tried to install XCode, and the laptop became so sloww, and then turned off. I think that was something related with temperature, because the power button doesn't worked until the laptop was cold enough. Should I upgrade to Big Sur in order to use this EFI?

Link to comment
Share on other sites

41 minutes ago, Pedro Lemos said:

This Clover EFI is working on Catalina, but there are some issues. I'm facing unexpectedly shutdowns, either using the battery or with charger plugged in. Also, as mentioned before, keyboard isn't working, but something weird happened: i closed the laptop, and after few minutes, opened again, and the keyboard suddenly worked. I tried to install XCode, and the laptop became so sloww, and then turned off. I think that was something related with temperature, because the power button doesn't worked until the laptop was cold enough. Should I upgrade to Big Sur in order to use this EFI?

KB is problem, i unclip touchpad flexi from MB, it is only way to solve this problem. see discussion above.

Link to comment
Share on other sites

my notebook is acer s50-51 10210u ,it has the same problems with yours in hackintosh,but I used the applesmarttouchpad.kext on Catalina,Keyboard worked fine.but when I used it on bigsur ,it dont work.Is there any difference between the two Kext (Applesmarttouchpad and voodoops2controller)? this is my old clover(ver5120)https://vincent3139.lanzous.com/ikIRqj3kifa

Link to comment
Share on other sites

On 12/6/2020 at 1:17 AM, Vincent S said:

my notebook is acer s50-51 10210u ,it has the same problems with yours in hackintosh,but I used the applesmarttouchpad.kext on Catalina,Keyboard worked fine.but when I used it on bigsur ,it dont work.Is there any difference between the two Kext (Applesmarttouchpad and voodoops2controller)? this is my old clover(ver5120)https://vincent3139.lanzous.com/ikIRqj3kifa

I tried your Clover folder on Aspire 5 A515 running Catalina 10.15.7, and surprisingly, keyboard works, but touchpad don't. For me, better to use an external USB mouse than a keyboard. Also, the laptop don't heat too much with your files (seems a lot stable). Audio is weird and with a low volume, but works either with a headphone and the speaker itself. I don't know nothing about patching and all this stuff, but I think that @thorasgard1 can use your files to improve his own EFI folders. Oh, forget to mention: i'm running Catalina with an external HDD via USB-C port (it's an old laptop HDD inside a case). Maybe there are issues with NVMe, but I cant tell anything

Edited by Pedro Lemos
Link to comment
Share on other sites

18 hours ago, Master System said:

Where should I insert this code?

Simply, use text editor as ProperTree. Below is example how.

6- Let's check OpenCore config

Go to NVRAM tab, 7C436110-AB2A-4BBB-A880-FE41995C9F82

add -lilubetaall, booter-fileset-kernel and booter-fileset-basesystem

<key>booter-fileset-kernel</key>
<data>AA==</data>
<key>booter-fileset-basesystem</key>
<data>AA==</data>

 

GNV3kSl.png

Link to comment
Share on other sites

On 12/7/2020 at 12:08 PM, Pedro Lemos said:

I tried your Clover folder on Aspire 5 A515 running Catalina 10.15.7, and surprisingly, keyboard works, but touchpad don't. For me, better to use an external USB mouse than a keyboard. Also, the laptop don't heat too much with your files (seems a lot stable). Audio is weird and with a low volume, but works either with a headphone and the speaker itself. I don't know nothing about patching and all this stuff, but I think that @thorasgard1 can use your files to improve his own EFI folders. Oh, forget to mention: i'm running Catalina with an external HDD via USB-C port (it's an old laptop HDD inside a case). Maybe there are issues with NVMe, but I cant tell anything

haha,the audio powered by voodoohda,so you can try to use apple alc and use id 77 to make it perfect ,but I give up Catalina and clover,I like oc and bigsur   .......     ꉂ ೭(˵¯̴͒ꇴ¯̴͒˵)౨”

Link to comment
Share on other sites

18 hours ago, Baio77 said:

if you confirm I correct the EFI on Github, I wanted to implement the patch in SSDT Hack, but if it works as you say better, can you pass me ioreg?

I added simply to your EFI this kext https://github.com/acidanthera/BrightnessKeys

I tested this EFI in fresh install BS 11.1 and etc. Everythig working well no problem. Previous problem with KB malfunction is out.

It is first 100% working EFI without any problems.

I transfer your OC to my Clover and working too without any problems. In ACPI folder in clover must be DSDT and your SSDT hack, but i using OC.

Ioreg will be later.

THOR - MacBook Pro.zip

Edited by thorasgard1
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap

The popup will be closed in 30 seconds...