Jump to content
oldnapalm

DSDT patch requests

Recommended Posts

On 11/10/2019 at 8:15 PM, ssprod said:

Greetings, Maldon.. System is running ok, but no trackpad control or brightness control and HD620 showing as 7meg. Any assistance in DSDT patching would be most appreciated. Thank you, sir!

Lenovo ThinkPad T480S

Intel i5 8350U

HD620 GPU

MacOS 10.15

Send me Catalinas-MacBook-Pro.zip 3.84 MB · 9 downloads

Hi Maldon, can the patches provided by you for t480s and Catalina also be used for Mojave? Or do I need to start from scratch with DSDT patching?

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, i am attaching my Send me file, pls fix these problem - wifi, bluetooth, sound, trackpad, brightness control and etc are not working in my laptop.

OS installed Catalina 10.15.6, i am using HP15-bs164tu notebook, 8 gb ram, kaby lake i5 processor with integrated intel HD graphics 620. pls help me to fix these problem

Send me file:- http://s000.tinyupload.com/index.php?file_id=03614857426813644493

Send me Bikashs-MacBook-Pro.zip

Edited by Bikash Paul

Share this post


Link to post
Share on other sites

So i have built a Catalina 10.15.6 Ryzen hackintosh and everything works as expected except for:

  • When there's a USB 2.0 device connected to XHC0 ports, sleep will not let me wake the system up and a hard reboot (pressing the reset button) is required.

I have under 15 ports per Controller (XHC0 has 4 USB 3 Ports and PTXH Controllers has 4 USB2.0 and 3 USB 3 ports)
If anyone can assist with this issue I'd really appreciate it as its the only thing keeping me from having a perfect hackintosh. :(


Runme.app files

Share this post


Link to post
Share on other sites
Posted (edited)

Hi

I'm new member of hackintosh world😃

I have an Asus G551vw:

-  i7 6700hq - HD530

-  Gtx960m 4gb

-  24gb ram 2400 ddr4

-  128gb ssd + 1tb hdd

-  Alc668 audio

-  Intel dual band wireless

-  4k 15.6" ips display

 

I did install olarila catalina 10.15.6 and im running it whitout usb disk. But i dont have any drivers yet😅

Please help me🙏🏻

This is my Run_me file: https://filebin.net/6kekx09tzrkcz4dp/Send_me_Pooryas-MacBook-Pro.zip?t=bosomily

Send me Pooryas-MacBook-Pro.zip

Edited by Poorya

Share this post


Link to post
Share on other sites
Posted (edited)

Olá, como vc está?

Poderia me ajudar com o audio ALC887 e a LAN RTL8111H, já tentei de tudo, todas as combinações possíveis (cerca de 10 horas combinando, comecei 12h desisti agora :( ) mas não consigo fazer o som funcionar no meu Hack.

Segue link:  http://s000.tinyupload.com/?file_id=29826549188249841648 anexo ainda

Já procurei em vários locais, inclusive na índia, mas nada de conseguir.

Follows my specifications (although it is in the bio):
CPU: i5 4690
MB: Asrock H81m-hga r4.0
GPU: hd graphics 4600
RAM: 10GB DDR3 (8+2 1600)
HDD: 500gb (se funcionar migro para o SSD)

 

Abraço, vc faz a diferença no mundo!

 

Edit: Consegui resolver o problema com o áudio, muito obrigado mesmo assim! Não sei como apagar o post

Edited by Winston Bruno
Consegui resolver o problema, não se faz mais necessário

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @MaLd0n need help for my Hack I'm running High Sierra

Specs: 
CPU : Intel Pentium G3260
Mobo : Gigabyte H81-HD2 Bios Ver. F6

RAM : 8GB DDR3 1600Mhz

SSD : 240GB

HDD : 500GB
GPU : Asus GTX 750 Ti OC 2GB

RunMe.app File

though my hacks won't boot without USB if I remove my USB and theres no bootargs appear, do I need to put a bootargs in bootmenu? I already put some NullCPUPowerManagement, FAKECIID still doesn't work.

Thanks

Edited by kyle10

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @MaLd0n

Can you work your magic please.

New bios.

Lid sleep does not work, brightness hotkeys do not work but they are Q11 & Q12 i think. I attached my old DSDT that just had hotkeys patched.

Using latest OC 0.6.1 and Big Sur beta 4  

Laptop specs in signature.

http://s000.tinyupload.com/index.php?file_id=93429335224393740542

Edited by savage001

Share this post


Link to post
Share on other sites

Hi, I hope you can help to patch my DSDT, I have a laptop lenovo ideapad 500-14ISK, intel i7 6500u, 8gm ram, I have Problems with the battery icon, It is visible now but It gets stuck when I plug or unplug the charger it's like a visual bug and I also have problems with my trackpad(no gestures)
Here is the link to the send me file: http://s000.tinyupload.com/?file_id=18877527862926468955

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, need your helP:

I am not able to build own and perfect DSDT aml etc. 

My Maschine: 

Asus ZenBook UX303LA:
 

  • Intel Core i5 Broadwell 5200U
  • Intel Graphics HD5500 (no dedicated graphics card, if you want that check out the UX303LN)
  • Audio Codec: Conexant CX20751/2
  • 1080p matte screen
  • 3x USB3.0 (Intel)
  • 1x SD Card reader
  • WebCam
  • Automatic Light Sensor (ALS)
  • 1x Full-size HDMI 2.0
  • 1x Mini DisplayPort
  • Backlit Keyboard
  • 3.5mm jack
  • FocalTech Trackpad
  • Intel 9 Chipset (Wildcat Point-LP SATA Controller etc)
  • Extra mSATA port for a half-size mSATA SSD inside
  • Comes with 8GB of RAM, and is upgradable.
  • Comes with two accessories: A miniDP to VGA converter, and a USB Ethernet dongle.

No Audio and other will not work. I tried  but without success. I hope you can help (with some Donate).Load file up "send me".

Hope you can help me on my birthday :-)

please for OpenCore

 Thank you

ghostbottle0815

 

https://filebin.net/vk5skxuufsiss5jl

 

 

CodecDump.zip Results SSDTTTime.zip origin DSDT_ Clover.zip

Edited by ghostbottle0815
missing link, added files

Share this post


Link to post
Share on other sites
Posted (edited)

 

On 6/12/2020 at 12:39 PM, MaLd0n said:

[Solved]

I'm sorry Sir, false alarm. Your DSDT.aml file still do the magic. The problem is wrong EFI folder. I download the notebook version efi folder (because mine is laptop) but thats the problem, so i donwload the non notebook efi folder then waalllaaahhh, i saw the magic.

🤣🤣🤣

 

Sir, this is a DSDT file you sent me before and it worked like magic. Recently i try to install HS on a same Laptop but in a different Drive. But I got a prohibited or stop logo on boot. But as usual, i'm able to boot using the usb installer. My Question is do i need another DSDT.aml file on this case or i miss something here?

Thanks in advance sir.

Here is my runme generated file

Send me Ades-MacBook-Pro.7z

Edited by adoqnukman
Solved

Share this post


Link to post
Share on other sites
On 7/28/2020 at 4:57 AM, danupermana said:

Hi Mald0n,

DSDT.01.zip

 

On 7/28/2020 at 9:16 AM, guwe said:

Thanks Maldon

DSDT.02.zip

 

On 7/28/2020 at 12:11 PM, Sanket Suman Rath said:

Hi Bro,

DSDT.03.zip

 

On 7/28/2020 at 1:49 PM, jackdevils said:

spec mainboard huanan x99-tdd. /  dual cpu e5-2687v3  / VGA RTX-580 8Gb

DSDT.04.zip

 

On 7/28/2020 at 4:58 PM, Fabio Ortolan said:

Opa segue a Dsdt

primeiro vc tem de usar a pasta pro seu hardware, reiniciar e extrair. com essa pasta atual a gente começa errado

 

On 7/28/2020 at 10:06 PM, mikeelhanze said:

Hi Maldon,

DSDT.05.zip

On 7/28/2020 at 10:30 PM, João Vitor Viegas Rêgo said:

Hi there, im looking for the DSDT of my motherboard, is an Asus TUF B360M-Plus Gaming, please.

DSDT.06.zip

 

On 7/29/2020 at 10:42 AM, iphone4438 said:

my spec laptop HP 1126TU I3 3110M RAM 4GB SSD 120GB

DSDT.07.zip

 

On 7/29/2020 at 12:06 PM, 나수환 said:

Audios don't work

https://www.olarila.com/topic/6074-guide-easy-audio-solution-with-applealc-clover-and-opencore/

  • Thanks 1

Share this post


Link to post
Share on other sites

Good day Maldon. Pls help. Main issue is I cannot play Netflix in Safari. Thank you.

 

https://filebin.net/cbpao1syun80b9za/Send_me_NavonaHckintosh.zip?t=0kbnicpi

Share this post


Link to post
Share on other sites
On 7/29/2020 at 12:52 PM, ramadhinolfski said:

Hi mald0n, would you like to help me with the patch?

with this folder is impossible. use olarila folder, reboot and extract

 

On 7/29/2020 at 4:18 PM, Muhammad Fhauzan said:

Hi Maldon,

DSDT.08.zip

 

On 7/30/2020 at 12:20 AM, grabbi99 said:

Hi,

DSDT.09.zip

 

On 7/30/2020 at 7:06 AM, pararayos said:

hi! here is my file. thanks!

DSDT.10.zip

 

On 7/30/2020 at 8:17 AM, Wei chuan Chu said:

Really appreciate for the help, thanks.

DSDT.11.zip

 

On 7/31/2020 at 12:17 PM, uncletonn said:

hello i has a new laptop

first u need a good efi folder. check Olarila folders

 

On 7/31/2020 at 1:32 PM, izfernando said:

Olá Maldon,

DSDT muito bugado. vou tentar olhar com calma pra esse caso

 

On 7/31/2020 at 2:19 PM, MarcusVR said:

Hello !

i need one dump from ssd

 

On 7/31/2020 at 11:11 PM, Emulators For Laptops said:

hey man this my file

DSDT.12.zip

 

On 8/1/2020 at 4:43 AM, jackie233 said:

Hi,

DSDT.13.zip dont use fakepciid

 

 

On 8/1/2020 at 6:59 AM, nayga73 said:

HI Maldon,

DSDT.14.zip

 

On 8/1/2020 at 7:08 AM, steezy said:

Hi @MaLd0n here it is...thanks in advance...

DSDT.15.zip

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Mald0n,

 

Not sure what you did, but sadly it stopped my laptop from booting, stuck at the Apple logo screen with a full bar underneath it, takes about 20 mins to get to that stage and then freezes :( Thanks for trying though :)

 

nayga73

 

**Update** Finally got Battery Stats working :)

Edited by nayga73

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...