Jump to content
oldnapalm

DSDT patch requests

Recommended Posts

Can't figure out HDMI to work. System boot log has many framebuffer errors.

My sendme:

https://drive.google.com/file/d/1YyogHdkuqA0B1r25eB6FNUKXNVE_QRI5/view?usp=sharing

WhatEverGreen manual says I have to remove IGPU & IMEI renames & FakePCIID kexts, but system does not boot then. removing fakepciid_intelhdmiaudio.kext I have audio problems.

As I understand, whatevergreen.kext does not work.

Most of all is working good: sleep/wake, wifi, bluetooth, shutdown/reboot, SD card reader, audio(bit too quiet), battery life.

Except for HDMI. everytime I connect HDMI, mouse keeps freezing and nothing more.

Share this post


Link to post
Share on other sites
On 7/20/2020 at 1:06 PM, BlueScion said:

hi, here's my runapp output

DSDT.aml.zip

On 7/20/2020 at 2:52 PM, Ika Musume said:

Hi, I want to request a Battery Hotpatch for opencore, brightness key and other hotpatches that works only on mac os.

no pseudo solution here

On 7/20/2020 at 4:15 PM, Tomas ҆aduikis said:

Can't figure out HDMI to work. System boot log has many framebuffer errors.

bIxfs1Y.png

On 7/20/2020 at 11:21 PM, LuteDane said:

Boa noite Mald0n fiz uma nova instalação

O problema não é a instalação, são acpi renames etc

yXQAchr.png

13 hours ago, kar2wlan said:

hi i have hp revolve 810 G3

same case above, many acpi renames etc. don't need it

8 hours ago, koerindeharxeniex said:

Hi! Hope someone can do the trick for me

DSDT.aml.zip

Share this post


Link to post
Share on other sites
Posted (edited)

I have problems with the hdmi audio (gtx 960) and the audio from the motherboard

I am using highsierra I have 2 GPU

Nvidea GTX 960

RADEON HD 5400 (but this one I can't get it to work)

 

PD: i Send Donation Paypal

 

Mainboard B450 Gaming Pro Carbon AC

Rayzen 5 2600x

GPU NVidea 960

GPU Radeon HD 5450

Send me iMac-Pro.zip

Edited by Luis M. Gaming

Share this post


Link to post
Share on other sites
On 7/20/2020 at 9:15 PM, Tomas ҆aduikis said:

Can't figure out HDMI to work. System boot log has many framebuffer errors.

My sendme:

https://drive.google.com/file/d/1YyogHdkuqA0B1r25eB6FNUKXNVE_QRI5/view?usp=sharing

WhatEverGreen manual says I have to remove IGPU & IMEI renames & FakePCIID kexts, but system does not boot then. removing fakepciid_intelhdmiaudio.kext I have audio problems.

As I understand, whatevergreen.kext does not work.

Most of all is working good: sleep/wake, wifi, bluetooth, shutdown/reboot, SD card reader, audio(bit too quiet), battery life.

Except for HDMI. everytime I connect HDMI, mouse keeps freezing and nothing more.

Sorry, for the link. This one should work:

https://drive.google.com/file/d/1YyogHdkuqA0B1r25eB6FNUKXNVE_QRI5/view?usp=sharing

Share this post


Link to post
Share on other sites

I some how corrupted the system and reinstalled Catalina with a windows dual boot.

So I thought I need a new DSDT patch.

http://s000.tinyupload.com/index.php?file_id=70098187041148252158

Btw, I noticed my intel hd graphic memory as '7'MB. Is there a fix for that ?

(HP 15-ay081tx, I7-6500u(Intel HD graphics 520) | 8gb ram | 256gb ssd with Mac and Windows | AMD Radeon R7 M340(well i don't know if this even works, dedicated gpu)

thanks!

Share this post


Link to post
Share on other sites
On 6/25/2020 at 5:01 PM, erasor2010 said:

Hi Guys,

most of my System is working. I just have Problems with Shutdown (it reboots) and Sleep

Gigabyte H370 HD3

Onboard UHD 360

i5-8500

8GB Ram

SendMe.zip

 

Hi MaLd0n,

is there any way to get a Patch that fixes my Shutdown Problems?

Share this post


Link to post
Share on other sites

Dell Inspiron 14 

no Graphics no wi-fi no lan no sound

 

sorry file size is too large so i uploaded in google drive here is the link

Send me

Share this post


Link to post
Share on other sites

Hello Maldon,

Recently I have installed Catalina 15.5.6  with opencore 0.5.9. Its working fine with few problems:

  1. Sleep/Wake not working.
  2. Battery indicator not working
  3. HDMI needs to unplug and then plug again after every reboot as its not detected automatically.
  4. Audio volume is too low.

I have attached my EFI and Sendme.zip files here. Thanks for ur kind co-operation.

 

EFI : https://drive.google.com/file/d/1hMl3R9lM0CuqWY01FCqLTLBuJcUfiQb0/view?usp=sharing

Sendme.zip : https://drive.google.com/file/d/1Po9HDDL1ve9EXHgxzioHGTvyf5drR23c/view?usp=sharing

 

Share this post


Link to post
Share on other sites

Hello! Here's my Send me file

https://we.tl/t-oItWDQtn74

I managed to use intel hd graphic using the patch. But with the hardware encode/decode patch it always crashed by kernel_task or kextd would there be a solution? my cpu is i7-6500u

Share this post


Link to post
Share on other sites
Posted (edited)

hi i have dell latitude i5 6th gen 480 ssd 16 gb ram..

my hackintosh is catalina 10.15.6. when i use the efi folder of usb stick from where i install catalina it show 

Intel HD Graphics 520 2048 MB and i succeed in patching battery and audio but i face problem when i unplugged the charger my mac os is stucked and i have to press power to shutdown. i have tried the efi folder of chipsets notebook skylake everything is good on that folder except that folder show Intel HD Graphics 520 1536 MB and also the same porblem when i unpluged the charger... help me.

 

this my result zip file from run me app.

https://drive.google.com/file/d/1_crY6JTtZEsw9RhnlZreOaqFqzdLK6Mn/view?usp=sharing

kindly help me

 

 

Edited by umairmaher44
because i solved one of the mentioned problems.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @MaLd0n,

Hope you're well,

Got 3 favours to ask you:

1. My onboard intel UHD630 is not being recognised as it should be (only shows 7mb) Not sure what to do?

2. My GPU AMD Radeon Vega Frontier Edition is on it's way, once it arrives do I need to do anything else to get it recognised by the system? 

3.Could you please send me a DSDT patch?

 

Thanks in advance for your help mate.

 

Please find attached my Send me on the link .

http://s000.tinyupload.com/index.php?file_id=36535520322202058059 

Edited by ROBERTO P
link +edit

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...