Jump to content
MaLd0n

[Guide] Wifi Atheros AR9565, AR9462, AR9463, AR9485 on Mojave and Catalina

Recommended Posts

  • Administrators

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with Stripe https://tinyurl.com/2ssnydn6

Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

 

1- Download KextUtility.

https://tinyurl.com/y256m57y

 

2- Download pack for your Wifi card.

*Lilu.kext is mandatory, if you don't have this kext, download and put in bootloader kexts folder*

-AR 9462

AR9462.zip

-AR9463

AR9463.zip

-AR9485

AR9485.zip

-AR9565

AR9565.zip

 

3- Drag ATH9KInjector.kext and IO80211Family_ATH.kext into KextUtility.app, put your Password and wait.

 

4- Reboot.

 

Atheros Bluetooth Kext

IOath3kfrmwr.kext.zip

 

Enjoy!

 

New way, check link bellow

https://tinyurl.com/yxgyatn9

 

Créditos: Apple, chunnann, Acidanthera Team, Pike R. Alpha, Bruno Souza

  • Thanks 1

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

  • Administrators
2 hours ago, fortoszone said:

it works. but i got really slow even unusable connection

ofc

the best is change this card

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

I've found a solution from the guy that contributed to building the  Intel WiFi kext (zxystd). Here is the link to his blog for fixing AR9565 bluetooth: https://www.longzc.cn/index.php/archives/308 (it's in Chinese but google translate figures it out). You have to download the 2 kexts there and just put them in OC/kexts . It's a bit buggy but it works on cold boot. Here is the source code on GitHub: https://github.com/zxystd/AthBluetoothFirmware

Link to comment
Share on other sites

On 9/9/2020 at 3:24 PM, Iona Hrap»ôa said:

I've found a solution from the guy that contributed to building the  Intel WiFi kext (zxystd). Here is the link to his blog for fixing AR9565 bluetooth: https://www.longzc.cn/index.php/archives/308 (it's in Chinese but google translate figures it out). You have to download the 2 kexts there and just put them in OC/kexts . It's a bit buggy but it works on cold boot. Here is the source code on GitHub: https://github.com/zxystd/AthBluetoothFirmware

you can write what you do to run bluetooth the way in this tutorial because not everyone translates this page.

Link to comment
Share on other sites

@MaLd0n

Thanks very much for taking the time to do this! Doing it this way didn't work for me (on Mojave). BUT I was able to make it work by putting ATH9KInjector.kext, IO80211Family_ATH.kext, and AR9462 in /EFI/CLOVER/kexts/Other/ and rebooting.

Just thought I'd mention it in case others ran into a problem.

  • Like 1

ThinkPad E531, L530, Inspiron 9400: Core 2 duo @2.16GHz , 4GB, G70 Geforce 7800 (10.7/Lion)

E531: i5-3230M, L530: i3-3110M, Optiplex 780: Core i5 @3.1GHz, 8GB, Geforce 8400 GS (10.9/Mavericks)

HD4000, A68HM-E33 V2 (MS-7721): Athlon X4 860K, 8GB, GeForce GT 730 (10.9/Mavericks)

Link to comment
Share on other sites

On 9/9/2020 at 6:24 PM, Iona Hrap»ôa said:

I've found a solution from the guy that contributed to building the  Intel WiFi kext (zxystd). Here is the link to his blog for fixing AR9565 bluetooth: https://www.longzc.cn/index.php/archives/308 (it's in Chinese but google translate figures it out). You have to download the 2 kexts there and just put them in OC/kexts . It's a bit buggy but it works on cold boot. Here is the source code on GitHub: https://github.com/zxystd/AthBluetoothFirmware

Can you send me the files? 
Bluetooth kext

this link is not working 

Link to comment
Share on other sites

  • Administrators
2 hours ago, pecunha97 said:

Hi, this isn't work for my laptop wifi card AR9485WB-EC. I'm using OpenCore. Do u know any solution ?

https://www.insanelymac.com/forum/files/file/1008-io80211family-modif/

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

  • Administrators
1 hour ago, gianni.dmg said:

hi i have a card Atheros AR9485 and my system is big sur booted with OpenCore, is it possible to make it work?

https://www.insanelymac.com/forum/files/file/1008-io80211family-modif/

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...

Hey! Welcome to Olarila.com  Please Disable Your ADBlocker!

3vHSCmh.png

The popup will be closed in 15 seconds...