Jump to content

Olarila HackBeast MSI B460M-A PRO - Full DSDT patches


Recommended Posts

  • Administrators

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with ETH 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05

Donation with LTC MTmkEY9xiLkuzf4vHtRYHLoapBcmmoApFc

Donation with DAI 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05

Donation with USDC 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05

Donation with PicPay @danielnmaldonado

Donation with PiX¬†@[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

 

-TUTORIAL-

https://tinyurl.com/ycvcnp8h

 

-EFI OpenCore Folder

https://tinyurl.com/y7puzwv9

-EFI Clover Folder

https://tinyurl.com/ycr9g9ye

 

--Hardware--

MSI B460M-A PRO

nx67NzZ.png

Intel(R) Core(TM) i5-10400

feF1dcd.jpg

 

--Screenshots--

nJzxSQ1.png

9PECYSM.png

Kcm6DG8.png

KzTm10w.png

9vrsIOP.png

JDKvAcR.png

HsoffBR.png

sjc7XTb.png

7BIDxDu.png

9hjQi4E.png

UfVKcwV.png

5c8OUE1.png

PBWdu3V.png

Ozjnc8X.png

fMvUvgg.png

8FVENaQ.png

NDUNeQp.png

htc93JC.png

yepMwLY.png

bzPlLwi.jpg

 

 

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • 1 month later...
  • Replies 57
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal https://tinyurl.com/r7fchn9 Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 Donation with ETH 0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05 Donation with LTC MTmk

Hey. I managed to install by using your EFI folder. Screen was pinkish colour but I fixed it by forcing rgb. Only problem is installing xcode. It stucks saying installing. I tried other apps, they ins

just need add device properties video patch example  

  • Administrators
1 hour ago, endrohat said:

Thank you! Do you happen to have the EFI for this? I would need to edit the PCIROOT entries I guess

just need add device properties video patch

example

Quote

            <key>PciRoot(0x0)/Pci(0x2,0x0)</key>
            <dict>
                <key>AAPL,ig-platform-id</key>
                <data>BwCbPg==</data>
                <key>device-id</key>
                <data>mz4AAA==</data>
                <key>enable-hdmi20</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con0-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con0-type</key>
                <data>EAAAAA==</data>
                <key>framebuffer-con1-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con1-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-con2-pipe</key>
                <data>EgAAAA==</data>
                <key>framebuffer-con2-type</key>
                <data>AAgAAA==</data>
                <key>framebuffer-patch-enable</key>
                <data>AQAAAA==</data>
                <key>framebuffer-unifiedmem</key>
                <data>AAAAgA==</data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
            </dict>

 

  • Like 1
Link to post
Share on other sites
  • Administrators
4 hours ago, Josele said:

Why do you use the i5 10400 instead of the i5 10500?
I think it will be more compatible right?
I was thinking of using this same configuration, but with a Gygabite H410M

all is compatible now

Link to post
Share on other sites
  • Administrators
19 minutes ago, endrohat said:

ok so how do i use the dsdt and ssdt provied? I was checking the OC dortania guide and it seems I have to run them through IASL command?

with dsdt u dont need any ssdt just if u have a thunderbolt for hotplug

Link to post
Share on other sites

I used the EFI from the post to boot into USB installer. it loads everything up but just after 2 seconds of showing apple logo the screen goes blank. I have used DVI nad HDMI both but same problem. In the config.plist I added entries for my iGPU

 

<key>DeviceProperties</key>
	<dict>
		<key>Add</key>
		<dict>
			<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
			<dict>
				<key>AAPL,ig-platform-id</key>
				<data>BwCbPg==</data>
				<key>framebuffer-patch-enable</key>
				<string>01000000</string>
			</dict>
			<key>PciRoot(0x0)/Pci(0x1b,0x0)</key>
			<dict>
				<key>layout-id</key>
				<data>AQAAAA==</data>
			</dict>
		</dict>
		<key>Delete</key>
		<dict/>
	</dict>

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap