Jump to content

Olarila HackBeast Asus PRIME X299-DELUXE II - Intel Core i9-10920X - Thunderbolt - Full DSDT patches


Recommended Posts

  • Replies 59
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Donation with Paypal聽https://tinyurl.com/r7fchn9 Donation with聽BTC聽33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3 Donation with ETH聽0x255EdE75081D2731FcD6F7BE171dfC7f5ce9DF05 Donation with LTC聽MTmk

Amazing Job MaLd0n!! Lets bring some love to X299 :) 馃憦馃憦馃憦馃憦

to be able to install I had to use Clover, your folder for X299 has old kexts and I had to activate EC0 to EC to be able to boot.

Now the system DOES NOT RESTART and DO NOT SHUT DOWN, it behaves strangely when it makes copies of folders, copies them but does not copy the contents ...

I would like to understand:

1. Why can't I use OperCore

2. I believe the DSDT needs to be redone on my configuration

3. I need Thunderbolt, but your guide is not talking about BIOS settings to enable Thunderbolt

4. I'm not sure if the config.plist is correct and it is correct to use iMacPro1,1

Please tell me how to do it

Thank you

Send me Simones-iMac-Pro.zip

Link to post
Share on other sites
  • Administrators
25 minutes ago, R-88 said:

can U share your OC Config for this build? I'm so curious to see the settings.

dont have any difference about performance and i need dual boot. clover now

Link to post
Share on other sites

well, but on the Z390 you have to make some changes to the bios to have thunderbolt + SSDT, now I ask you if I have to make some changes also to the asus bios or if everything works in default .... Sorry if I insist but your answers are always partial

Link to post
Share on other sites
On 8/17/2020 at 5:32 PM, MaLd0n said:

dont work

Everything seemed ok but today you no longer see the graphics card ...
it only works if I use it in screen sharing

Now I can boot only without your DSDT

In the meantime I have updated the BIOS to the latest 3105
I have these problems:


1. Firewire port does not shows up in SysProf/Firewire but show only as PCI @slot [email protected],0,0

2. Thunderbolt port does not shows up in SysProf/Thunderbolt but show only as PCI @[email protected],0,0

3. Thunderbolt/Usb C hotplug doesn't always work

4. Please check if I need any kind of ACPI patch

http://gofile.me/6EH67/UTGkZPaPZ

THANX!

P.S. I've donated today for your hard work

Edited by R-88
Link to post
Share on other sites
2 hours ago, R-88 said:


Seems to be perfect! These strange things remain:

1. Firewire does not appear in System Report

2. USB-C only works if inserted with the pc off (no hotplug?)

Send me Simones-iHack-Pro.zip 5 MB 路 0 downloads 1.zip 82.09 kB 路 0 downloads 2.zip 153.89 kB 路 0 downloads

hi what audio interface u use?聽

do you use the complete x299 olarila folder and add maldon dsdt?

Link to post
Share on other sites

Grab the oc folder from send me files. You need your own dsdt to boot. Or use the dortania guide (if you don鈥檛 have dsdt use the dortania鈥檚聽ssdt to boot the system with usb, next use runme.app from Olarila and request your dsdt)

Link to post
Share on other sites
On 8/20/2020 at 11:13 PM, MaLd0n said:

1- firewire is not full load. if u dont use it, remove

SSDT-X299-TB3HP.aml.zip 1.57 kB 路 2 downloads

I need firewire, how to fix?

P.S. I've found this, is possible solution??

Note that any devices in respective PCIe slots on the ASUS WS X299 Sage 10G sharing the same PCI device at different PCI bridges, like PC02.BR2A.SL05 in case of the ANS1 NVME controller in Slot-1 (PCI bridge @10) and in case of the ARPT OSXWIFI Broadcom BCM94360CD BT/WIFI PCIe Adapter in Slot-3 (PCI bridge @08), need to be implemented in the same system SSDT, like in case ofSSDT-X299-Slot1-Slot3-PC02-BR2A-SL05-ANS-ARPT.aml.

Hi Maldon, I solved it by myself by changing the slot to the Firewire card. Now works.
I ask you to redo the DSDT because I changed the order of the cards and now it no longer sees anything in System Profiler / PCI Cards

Thank you!

http://gofile.me/6EH67/g2YardKjd

Edited by R-88
SOLVED!!!
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap