Jump to content
MaLd0n

[Guide] Install/Restore BigSur with OpenCore on AMD Ryzen

Recommended Posts

  • Administrators

--Video Tutorial OpenCore Vanilla--

https://tinyurl.com/yyfa7mfa 

--Full OpenCore Vanilla Guide--

https://tinyurl.com/ycvcnp8h

 

--AMD Patches and Credits--

https://github.com/AMD-OSX/AMD_Vanilla

 

--Full Solution with good fine tune you need post your files, check video and run this app bellow--

Download RunMe.app - https://tinyurl.com/y9562hz7

 

Let's start

System password is 1234

 

Work in internal or external HDD/SSD / Don't restore to your Mojave/Catalina macOs SSD

 

1- Download this .dmg and put in your desktop

Link 1- https://tinyurl.com/ybttsz94

Link 2 - https://tinyurl.com/ydxme7jl

All Credits to vit9696 and Vandroiy

 

2- Open terminal and mount .dmg

-Run in terminal-

hdid -nomount "/Users/olarila.com/Desktop/macOS_11.dmg"

*change user*

x0drVkg.png


3- Check disks with diskutil list in terminal 

***Pay attention, you need restore partition that has EFI partition and 120gb, check image below***

-Run in terminal-

diskutil list

In my case .dmg mounted is disk5 and my NVME is disk1

*mounted .dmg have 120 gb*

85my8xB.png

4- Unmount Disk

*Make changes according to the result in the terminal*

-Run in terminal-

diskutil unmountDisk /dev/disk1

DaBYgwZ.png

5- Restore

*Make changes according to the result in the terminal*

Restore from disk5 to disk1

-Run in terminal-

sudo dd if=/dev/disk5 of=/dev/disk1 bs=32m

1fjhbhB.png

with ctrl + t you can check progress

Restore is done.

6xkKKdq.png

GNV3kSl.png

c- Go to Kernel tab, Patch and add these patches

https://github.com/AMD-OSX/AMD_Vanilla

g2UPlQ9.png

Download last release OpenCore and Kexts

 

--OC vanilla Application--

https://www.olarila.com/topic/10371-oc-vanilla/

 

Premade EFI Folder AMD RYZEN

https://tinyurl.com/ybr968w3

 

Boot into system and enjoy!

 

Resize Disk After restore Thanks to Pavo

To resize the physical disk of BigSur when using this method

*Identify the physical disk

diskutil list

*repair the physical disk partition

sudo diskutil repairDisk diskX

*Resize the physical disk container volume

sudo diskutil apfs resizeContainer diskXs2 0

4jWxCkO.jpg

Eh1uva1.jpg

Credits/Thanks: Acidanthera Team, AlGrey, XLNC, Apple

  • Thanks 1

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

dd: /dev/disk6 of=/dev/disk5 bs=32m: No such file or directory

Main ASUS ROG Trix B360-G Gaming + CPU Intel i5 9400F + DDRAM4 Trident Z 8gb bus 3000 + VGA Gigabyte RX 580 8Gb+ Wifi TP Link WN823N

Main ASUS X570 CSM Pro + CPU Ryzen 5 3600 + DDRAM4 Corsair 16Gb bus 3000Mhz + VGA Gigabyte RX 5700 XT 8Gb + Wifi Intel 7265AC + USB TPlink Nano T2U V3 + USB TPlink W725N + USB TPlink W823N V3

Link to comment
Share on other sites

  • Administrators
On 7/5/2020 at 12:29 PM, ccphuc2019 said:

dd: /dev/disk6 of=/dev/disk5 bs=32m: No such file or directory

check ur procedure

1 hour ago, longcoming said:

what is SIGABRT error and how to solve it?

-Boot from USB / Disable booter-fileset-kernel and booter-fileset-basesystem

-Boot from SSD / Enable these options if need

  • Like 1

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Ola amigo, antes de tudo muito obrigado por tudo!

Eu instalei aqui e deu certo, so o mouse que esta bem estranho, fica travando toda hora.

Voce teria alguma dica? ja procurei em varios lugares e nada. estou atualizando para o beta 2 agora para ver se resolve.

Muito obrigado ūüėÉ

Link to comment
Share on other sites

  • Administrators
1 hour ago, low_sperm said:

Eu instalei aqui e deu certo, so o mouse que esta bem estranho, fica travando toda hora.

o sistema é beta e esses patches tb. sempre vários bugs

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Hi MaLd0n

 

My System:

msi 990fxa-gd65. | AMD FX 8150 | 12GB RAM | Gigabyte RX 560 4Gb

I successfully Installed Big Sur using VMware. Booted with these EfI ( tried with both FAKEsmc and VirtualSMC)

 

I want to try USB Installer (olarilla iso Big sur dp3).

But its not booting at all. I can use this efi to boot both Usb Installer catalina and Installed catalina disk.

Getting this error

https://photos.app.goo.gl/fAo5ez83t41tLP31A

 

Edited by iamprabhuantony
Link to comment
Share on other sites

  • Administrators
38 minutes ago, iamprabhuantony said:

msi 990fxa-gd65. | AMD FX 8150 | 12GB RAM | Gigabyte RX 560 4Gb

u need check if patch for FX is done

theses guys have a amazing work for amd in github

  • Like 1

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

Hi, @MaLd0n I installed beta 3 successfully on my computer but black screen for a while after boot, I had to press ESC for a while (30s) to go to the login screen (MSI RX 5500 XT)

My EFI: https://drive.google.com/file/d/1Ls62lTinMCi9Hd84D0FlJh9rsgXBeo7O/view?usp=sharing

PC: Msi B450 Tomahawk Max, Ryzen 5 3600, Msi Rx 5500 XT 8G Gaming X, RAM 16G, Ethernet Realtek RTL 8111, Audio Realtek ALC892, MacOS 10.16 Beta 3, Opencore 0.6.0 (method USB Installer)

MSI B450 TOMAHAWK MAX, RYZEN R5 3600, MSI RX 5500 XT, WIFI BCM94360cs2 , MacOS 10.16 Beta 9, Opencore 0.6.2

Link to comment
Share on other sites

On 7/30/2020 at 2:29 AM, MaLd0n said:

try with no weg.kext

Hi, @MaLd0n

I have the same issue, I don't know if this is the way to show my login screen, but I have to type my password 2 times with enters several times even my screen is blank,
then usually there is artefac glitch on my screen after. Then after this, my login screen showed up

I have:
AsRock B450Pro4 with 4.20 BIOS Update
Ryzen 3600
RX 5600XT
latest official opencore 0.6.0

EFI.zip

Link to comment
Share on other sites

  • Administrators
15 hours ago, othsout said:

but I have to type my password 2 times with enters several times even my screen is blank

idk what happens

Support Olarila Vanilla Hackintosh by making a donation HERE

About Premium Users you can check HERE

Problems with Paypal HERE

Link to comment
Share on other sites

On 7/23/2020 at 7:46 PM, iamprabhuantony said:

Hi MaLd0n

 

My System:

msi 990fxa-gd65. | AMD FX 8150 | 12GB RAM | Gigabyte RX 560 4Gb

I successfully Installed Big Sur using VMware. Booted with these EfI ( tried with both FAKEsmc and VirtualSMC)

 

I want to try USB Installer (olarilla iso Big sur dp3).

But its not booting at all. I can use this efi to boot both Usb Installer catalina and Installed catalina disk.

Getting this error

https://photos.app.goo.gl/fAo5ez83t41tLP31A

 

Hello iamprabhuantony,

how did you install BigSur in VMware?

Do you have a Description or instructions, maybe a Link?

My System:

AMD FX 6300, MSI GT 710, ASRock 980DE3/U3s3, 16 GB RAM

Greetings from Germany, maclinux

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...

Hey! Welcome to Olarila.com  Please Disable Your ADBlocker!

3vHSCmh.png

The popup will be closed in 15 seconds...