Jump to content
megamac2020

Laptop Black Screen after apple logo when HDMI is connected

Recommended Posts

Posted (edited)

Hi....this is the problem....

1-) Boot with HDMI connected:

- After Apple logo, laptop display goes black / HDMI monitor as secondary display normal;

2-) Boot with HDMI disconnected:

- Laptop display normal, then after Login screen I connect the HDMI display and get the two displays with image;

 

ps: MacOS Catalina is installed...

This is driving me crazy😃😃😃😃....any help???

 

Lenovo Yoga 710-15ISK

Intel HD520

Thank you!

config.plist.zip

Edited by megamac2020

Share this post


Link to post
Share on other sites

i have the same problem, lenovo ideapad 300 14lsk. My display was broken so i use only hdmi, when boot and black screen, only disconnect and connect the hdmi and work. previous i have a problem with intel hd 520 4mb, now its appear like hd 530 but 1536mb

Share this post


Link to post
Share on other sites

igfxonln=1

Share this post


Link to post
Share on other sites

u can. try with agdpmod=vit9696

if have a 4k display add -cdfon

Share this post


Link to post
Share on other sites

I tried all, pikera too.... Very strange....I saw something in the logs about not sufficient energy to that port (DVI and HDMI same connector)  right before "Login Screen"

 

 

Share this post


Link to post
Share on other sites

try generate new patch with hackintool

 

Share this post


Link to post
Share on other sites
On 7/1/2020 at 7:21 PM, megamac2020 said:

I tried all, pikera too.... Very strange....I saw something in the logs about not sufficient energy to that port (DVI and HDMI same connector)  right before "Login Screen"

 

 

 

My problem was solved, something was causing me conflict, I backed up the progress and reinstalled again without adding anything extra except solution for hd 520, that solved me, it work for me in Catalina and Mojave, I stayed with mojave for 32b support.

 

my config is a mess, but it works for me, while I learn to perfect it

 

config.zip

Share this post


Link to post
Share on other sites
1 hour ago, megamac2020 said:

(Catalina still crazy)

🤣

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...