Jump to content
MaLd0n

[Guide] Install/Restore BigSur with OpenCore

Recommended Posts

Could you tell me how to manage to make Wifi work? Or I’d better wait for an update of AirportBrcmFixup.kext

Wifi card is bcm94352z. (Bluetooth works well)

Edited by Alden
Link to comment
Share on other sites

Fiquei com uma d√ļvida.

J√° com o Big Sur instalado, Instalei o Command Line Developer Tools e rodei os comandos baixados daqui:

OpenCorePKG.command & OlarilaOC.command

O primeiro eu vi que criou no ~/usuário/OpenCorePKG dentro de binaries eu acho o OC mais recente porque baixou do repositório. Ok. Entendido. Mas...

Ao rodar o OlarilaOC, são criadas duas pastas no desktop. A OlarilaOC e a OlariaOC Release. A primeira tem além do OC os kexts e tudo mais, porém eu vi que são os "códigos" dos KEXTS não eles em sí. A outra pasta está vazia. Então fiquei perdido.
Era para ter os KEXTs e com isso ter uma vers√£o mais 'atualizada' de tudo, claro que copiando o novo OC e os kexts iguais aos que tenho sobrepondo. Mas acho que algo ficou perdido no meio do caminho.

O que eu deveria fazer?

Hacks:
Main: 
Gigabyte Z390 Gaming X  - Intel i5 9400F - 16 GB DDR4 2666 - Radeon RX 570 4GB - Big Sur 11.4 / Monterrey 12 Beta 1
Backup: Gigabyte EP-45-UD3R - Intel Core2Quad 9550 @4.0Ghz - 8 GB DDR2 - GeForce 9800GT - Sierra

Link to comment
Share on other sites

I wish to send you a Big Thank you, MaLd0n!

I got it working easily with the help of your files and guide :) Basically I took my working OC folder for Catalina, updated OC and Kexts with your scripts, copied the updated files to my "old" Catalina OC folder, and finally changed the config.plist with the two NVRAM entries.

I have Big Sur on an old external SSD connected by USB, and I will probably test to clone it to an internal SSD later today.

I haven't tested if all hardware works, as I just got it installed a couple of minutes ago, but audio works, Eehernet works, and it finds my Intel 530 graphics as well as my Radeon VII card. I will test USB 3.0 later.

Again, many thank's for all your help!

Edited by Thegn
Link to comment
Share on other sites

Awesome guide @MaLd0n

I managed to dd to a separate SSD but when booting, I get a black screen before what I assume would be the login window.

I have Vega 64 and can boot using the same config into Catalina with no problem (Although I've been using Clover up until now, I manged to build an OC EFI, in preparation for Big Sur). I've tried with and without agpmod=pikera. My Kexts are up to date.

My MB is ASUS Maximus Hero X WIFI AC

I've attached my EFI folder

EFI.zip

Edited by DrDrumm
Link to comment
Share on other sites

I managed to install MacOS Big Sur following the guide from 1 st page, but after some time I lost sound, my bluetooth was touch and go, so  I decided to start again, following the guide and it all appeared to go well...

But when I rebooted the machine I only have one entry in OpenCore boot menu macOS Catalina, for some reason I go to disk utility and found that the disk0 was not initialized, I tried to erase it, but no dice it gives error...

How do i solve this?

Captura de ecrã 2020-06-28, às 12.28.03.zip

PS: Solved erased it with terminal...

Edited by MorenoAv
  • Like 1
Link to comment
Share on other sites

  • Administrators
17 hours ago, Alden said:

Wifi card is bcm94352z.

inject 43a0

16 hours ago, asapreta said:

OpenCorePKG.command & OlarilaOC.command

deve ser o xcode. ainda n√£o testei no BS

15 hours ago, Soman said:

Gigabyte H77-DS3H, Core i5, 16GB RAM, ATI Radeon Rx560. 

work good

15 hours ago, johnnybravo said:

Thanks MaLd0n! Works great!

Enjoy, Johnny!

12 hours ago, Thegn said:

I wish to send you a Big Thank you, MaLd0n!

Enjoy, Thegn!

10 hours ago, SergejSD said:

Thanks MaLd0n! Super!!!

Enjoy, SergejSD!

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with Stripe https://tinyurl.com/2ssnydn6

Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX¬†@[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

2 minutes ago, MaLd0n said:

deve ser o xcode. ainda n√£o testei no BS

Era para ter acontecido o que?

Hacks:
Main: 
Gigabyte Z390 Gaming X  - Intel i5 9400F - 16 GB DDR4 2666 - Radeon RX 570 4GB - Big Sur 11.4 / Monterrey 12 Beta 1
Backup: Gigabyte EP-45-UD3R - Intel Core2Quad 9550 @4.0Ghz - 8 GB DDR2 - GeForce 9800GT - Sierra

Link to comment
Share on other sites

  • Administrators
9 hours ago, DrDrumm said:

Awesome guide

csm disabled?

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with Stripe https://tinyurl.com/2ssnydn6

Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX¬†@[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

  • Administrators
5 hours ago, mathewgx said:

@MaLd0n, is it possible to install image on a partiton (e.g. disk1s1) instead of a disk?

restore to entire and clean disk, not partition

4 hours ago, kevin0007 said:

Hi, @MaLd0n thanks for your tutorial...I did same as you mentioned in your post..I used your provided efi without any modification but at first boot I got kernel panic

what ur hardware?

1 hour ago, Marck00 said:

Disk1s5s1: device is not readable.

restore to entire disk not partition

9 minutes ago, asapreta said:

Era para ter acontecido o que?

n√£o sei se precisa do xcode full ou somente o command line

9 minutes ago, Alden said:

 

inject via devices properties, ssdt or dsdt

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with Stripe https://tinyurl.com/2ssnydn6

Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX¬†@[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

15 minutes ago, MaLd0n said:

inject via devices properties, ssdt or dsdt

I’m a novice. I’m sorry to bother you but could you instruct me to inject this. I’m still skeptical of it.

Link to comment
Share on other sites

23 minutes ago, MaLd0n said:

restore to entire and clean disk, not partition

what ur hardware?

restore to entire disk not partition

n√£o sei se precisa do xcode full ou somente o command line

inject via devices properties, ssdt or dsdt

I already restored the entire disk, the system works perfectly, but before starting it appears many times that message, I have the doubt if it is normal or not

Edited by Marck00
Link to comment
Share on other sites

  • Administrators
2 minutes ago, Alden said:

I’m a novice. I’m sorry to bother you but could you instruct me to inject this. I’m still skeptical of it.

https://www.olarila.com/files/Utils/RunMe.app.zip
https://www.youtube.com/watch?v=k9wmIfGLe3A

3 minutes ago, Marck00 said:

The operating system works and everything, I only have the doubt if it is normal that when booting, that message appears repeatedly

post one photo

  • Like 1

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with Stripe https://tinyurl.com/2ssnydn6

Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX¬†@[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

4 minutes ago, Marck00 said:

I already restored the entire disk, the system works perfectly, but before starting it appears many times that message, I have the doubt if it is normal or not

Same happens here but as far as I know everything is working.

25 minutes ago, MaLd0n said:

n√£o sei se precisa do xcode full ou somente o command line

Instalei ambos no Big Sur antes de rodar os comandos.

Uma pasta ficou vazia e a outra como eu disse.

Hacks:
Main: 
Gigabyte Z390 Gaming X  - Intel i5 9400F - 16 GB DDR4 2666 - Radeon RX 570 4GB - Big Sur 11.4 / Monterrey 12 Beta 1
Backup: Gigabyte EP-45-UD3R - Intel Core2Quad 9550 @4.0Ghz - 8 GB DDR2 - GeForce 9800GT - Sierra

Link to comment
Share on other sites

  • Administrators
40 minutes ago, Marck00 said:

 

restore to entire disk

37 minutes ago, Alden said:

Here you go.  Thanks

Archive.zip

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with Stripe https://tinyurl.com/2ssnydn6

Donation with BuyMeaCoffee https://tinyurl.com/bvsbpf6e

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX¬†@[email protected]

Donation with Mercado Livre https://tinyurl.com/y9evkj5u

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
  • Create New...

:cap-Please Disable Your ADBlocker-:cap