Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
Stefan C.

Need help with some patches

    Recommended Posts

    Posted (edited)

    Hello! So, today i finally managed to install macOS Catalina 10.5.5 on my DELL Vostro 3490.

    Specs:

    - CPU: Intel i5 10210u with integrated graphcis only

    - 16 GB RAM

    - 2 SSDs

    - I2C HID Trackpad

    - Qualcomm QCA9377 Wifi

     

    I only succeed with Opencore 0.5.9 but i have some problems:

    Not working: Touchpad, Graphics, Sleep, Sound.

    Sometimes, it randomly freezes. Can anyone help me please? Thanks!

    EFI-DELL.zip

    Edited by Stefan C.

    Share this post


    Link to post
    Share on other sites
    5 hours ago, Stefan C. said:

    Thank you so much man!

    AUDIO- use device id and inject layout id with alcid=xx (xx is layout id for ur audio codec)

    <key>PciRoot(0x0)/Pci(0x1F,0x3)</key>
    <dict>
    <key>device-id</key>
    <data>cKEAAA==</data>
    </dict>

    try it for trackpad

    DSDT.I2C0.TPD0.zip

    if dont work back to previous dsdt. trackpad is full load

     

    • Like 1

    Share this post


    Link to post
    Share on other sites
    Posted (edited)

    Still no scroll with to fingers and no gestures. It is what it is. :)

    Thank you so much for your help, you're a genius!

     

    EDIT: After disabling the trackpad  and input plugin from Voodoo PS2 Controller it's working flawlessly.

    Audio is the only issue. Shows up on system preferences but no sound is coming up.

    Edited by Stefan C.

    Share this post


    Link to post
    Share on other sites
    On 6/28/2020 at 2:01 AM, Stefan C. said:

    Audio is the only issue. Shows up on system preferences but no sound is coming up.

    add dev id above and test some layouts

    Share this post


    Link to post
    Share on other sites

    use device id above

    Share this post


    Link to post
    Share on other sites
    4 minutes ago, Stefan C. said:

    @MaLd0n, look, it's above now. Still doesn't work.

    581N9p5.png

    Share this post


    Link to post
    Share on other sites
    14 minutes ago, Stefan C. said:

    @MaLd0n, did the same to mine. Tried with the dev id from your photo and with mine and I got nothing.

    u need dev id above + FakePCIID_Intel_HDMI_Audio.kext + FakePCIID.kext + alcid=x

    • Like 1

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×
    ×
    • Create New...