Jump to content
ūüéČ [ IMPORTANT ] Premium and Donators users ūüéČ √ó

PATCH FOR RYZEN 2700X


jackfrost4u

Recommended Posts

Hi, i donated and sent you a PM for patch with the file. Everything is working except bluetooth/wifi, and sleep. 

board-  https://www.gigabyte.com/us/Motherboard/B450-AORUS-PRO-WIFI-rev-10/support#support-dl-utility

card-  radeon RX 580. 8GB

Thanks again, this was a fast install. I just used your AMD efi folder  for post install and everything has been fine except those items. I read that i may have to get a card for the bluetooth/wifi; but mostly just wanting sleep to work if possible.  I attached my file again here just in case. 

 

Send me ryzen-mac.lan.zip donation.zip

Link to comment
Share on other sites

  • Administrators

DSDT.aml.zip

wifi/bt is intel?

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

1 hour ago, MaLd0n said:

yes, it is, thanks. i will try it out. 

  1. Wi-Fi 802.11 a/b/g/n/ac, supporting 2.4/5 GHz Dual-Band
  2. BLUETOOTH 4.2
  3. Support for 11ac wireless standard and up to 433 Mbps data rate
    * Actual data rate may vary depending on environment and equipment.
    * Intel WIFI driver only support for Win10-64bit

off topic.

do you if there is a way to control RGB fusion led's? I am trying to not have to boot into windows to control the lights. I have tried to run the app on a VM in osx but does not work. I also tried cross over office to try and install that way. also the trixx software to change the lights on the graphics cards. 

Link to comment
Share on other sites

  • Administrators
1 hour ago, jackfrost4u said:

do you if there is a way to control RGB fusion led's? I am trying to not have to boot into windows to control the lights. I have tried to run the app on a VM in osx but does not work. I also tried cross over office to try and install that way. also the trixx software to change the lights on the graphics cards. 

I think dont work. neede check if have one project about it

extract one new sendme

Bluetooth intel

https://github.com/zxystd/IntelBluetoothFirmware/releases

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

18 hours ago, MaLd0n said:

I think dont work. neede check if have one project about it

extract one new sendme

Bluetooth intel

https://github.com/zxystd/IntelBluetoothFirmware/releases

attached is a new one.. not sure if it makes a difference but prior i had it on an external ssd. now it is mounted in the machine.  sleep did not work on the last one. i still need to test that bluetooth download. wifi did not work , so more than likely the previous dsdt did not work. 

Send me ryzen-mac.lan.zip

Link to comment
Share on other sites

  • Administrators

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

1 hour ago, MaLd0n said:

thanks . i will try it out 

is there a fan control app you recommend? i know if smc fan control but i think it has issues for later osx versions.

 

1 hour ago, MaLd0n said:

thanks . i will try it out 

Link to comment
Share on other sites

with that last EFI folder you sent . Bluetooth is now working. i can toggle it on/off via the mbo bluetooth. wireless did not work; but that is ok. ( but i lost the sound card on the board, is there a kext i need to add? ) i will do full shutdown again and see if it comes back. 

18 minutes ago, jackfrost4u said:

with that last EFI folder you sent . Bluetooth is now working. i can toggle it on/off via the mbo bluetooth. wireless did not work; but that is ok. ( but i lost the sound card on the board, is there a kext i need to add? ) i will do full shutdown again and see if it comes back. 

I think sleep is not going to work like you said. I do not need wireless. It is a desktop and like ethernet. So at this time looking to get the soundcard back. It sees the sound for my monitor though.  I may plug in my sound to the monitor.  The other thing I noticed is the the fans for the graphics card are not on. The computer temp is fine. I will look to see if there are ways to get it the card fans working. They run ok under linux.   Radeon RX 580 8 GB nitro glow.       as far as fan program i saw this - https://www.tunabellysoftware.com/tgpro/.  thanks again for your help.

 

Link to comment
Share on other sites

  • Administrators

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

3 hours ago, MaLd0n said:

Audio is back if i boot off the external test install i did for testing. I cloned it to my external drive. I may make a thumb boot disk . I have another drive with ubuntu 20.04, for some reason they both keep competing for uefi boot. ubuntu put a folder in the EFI for mac os weird. My external test drive can see them both. I never had these issue with ubuntu dual boot. i may wipe that dive and use it for time machine back up. i will try the amd and keep you posted. 

4 minutes ago, jackfrost4u said:

Audio is back if i boot off the external test install i did for testing. I cloned it to my external drive. I may make a thumb boot disk . I have another drive with ubuntu 20.04, for some reason they both keep competing for uefi boot. ubuntu put a folder in the EFI for mac os weird. My external test drive can see them both. I never had these issue with ubuntu dual boot. i may wipe that dive and use it for time machine back up. i will try the amd and keep you posted. 

typo.. cloned to my internal drive.

Link to comment
Share on other sites

2 hours ago, jackfrost4u said:

Audio is back if i boot off the external test install i did for testing. I cloned it to my external drive. I may make a thumb boot disk . I have another drive with ubuntu 20.04, for some reason they both keep competing for uefi boot. ubuntu put a folder in the EFI for mac os weird. My external test drive can see them both. I never had these issue with ubuntu dual boot. i may wipe that dive and use it for time machine back up. i will try the amd and keep you posted. 

typo.. cloned to my internal drive.

so i think i will stay with your first patch. audio works. bluetooth and wifi is not a big deal. mostly was trying to get sleep to work. i will use the amd power management you added to see if that will get sleep and fan control going. thanks for your help. i will report back. As for linux. i will have to play with that other drive. it keeps wanting to put the efi boot loaded inside the efi mac os folder. very odd.  i may just put windows back on that drive not sure.

Link to comment
Share on other sites

  • Administrators

enjoy

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

On 6/19/2020 at 3:13 PM, MaLd0n said:

enjoy

there is a linux driver install for my card. can that be installed on osx? just curious 

 

On 6/19/2020 at 10:05 AM, jackfrost4u said:

Audio is back if i boot off the external test install i did for testing. I cloned it to my external drive. I may make a thumb boot disk . I have another drive with ubuntu 20.04, for some reason they both keep competing for uefi boot. ubuntu put a folder in the EFI for mac os weird. My external test drive can see them both. I never had these issue with ubuntu dual boot. i may wipe that dive and use it for time machine back up. i will try the amd and keep you posted. 

typo.. cloned to my internal drive.

so i think i will stay with your first patch. audio works. bluetooth and wifi is not a big deal. mostly was trying to get sleep to work. i will use the amd power management you added to see if that will get sleep and fan control going. thanks for your help. i will report back. As for linux. i will have to play with that other drive. it keeps wanting to put the efi boot loaded inside the efi mac os folder. very odd.  i may just put windows back on that drive not sure.

Link to comment
Share on other sites

  • Administrators
50 minutes ago, jackfrost4u said:

there is a linux driver install for my card. can that be installed on osx? just curious 

yes. have. but have some bugs

check

 

 

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

should i always be on the latest clover? i am on 5112, 5119 is available.

also i can see the temps for all my hard drives and CPU, I cannot see any fans at all , not just the GPU but i cannot see the speed for any case fans at all.

do you have any kexts, or is this not capable to with AMD?

thanks. 

 

 

11 hours ago, MaLd0n said:

yes. have. but have some bugs

check

 

 

thanks for the link for bluetooth/wifi

  • Like 1
Link to comment
Share on other sites

1 hour ago, jackfrost4u said:

should i always be on the latest clover? i am on 5112, 5119 is available.

also i can see the temps for all my hard drives and CPU, I cannot see any fans at all , not just the GPU but i cannot see the speed for any case fans at all.

do you have any kexts, or is this not capable to with AMD?

thanks. 

 

 

thanks for the link for bluetooth/wifi

 

I see that happened now comparing what I had in the kext folder to the newest one you sent with bluetooth working. You added to the two bluetooth kext and the realtex one for sound was removed. I also noticed you had the amd power management text in your latest.  what i will do is use your latest and add the sound kext back . then sound and bluetooth should work. I saw on your latest you removed null power management one and replaced with amd? can you have both at the same time?  also can this radeon kext be used ok? sorry for all the questions.  and should i be on latest clover with latest kext versions installed?  happy father's day if you are a dad. 

RadeonMonitor.kext.zip

21 minutes ago, jackfrost4u said:

 

I see that happened now comparing what I had in the kext folder to the newest one you sent with bluetooth working. You added to the two bluetooth kext and the realtex one for sound was removed. I also noticed you had the amd power management text in your latest.  what i will do is use your latest and add the sound kext back . then sound and bluetooth should work. I saw on your latest you removed null power management one and replaced with amd? can you have both at the same time?  also can this radeon kext be used ok? sorry for all the questions.  and should i be on latest clover with latest kext versions installed?  happy father's day if you are a dad. 

RadeonMonitor.kext.zip 16.63 kB · 1 download

the other two kext i was going to try are the one for the gigabyte board and the fake smc unless you think they are not needed. other kexts.zip

Link to comment
Share on other sites

  • Administrators

don't need nullcpupm kext

with last applealc kext use alcid=xx (xx is layout-id for ur audio codec)

this radeon monitor is from fakesmc, u can test

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

ok. thank you

59 minutes ago, MaLd0n said:

don't need nullcpupm kext

with last applealc kext use alcid=xx (xx is layout-id for ur audio codec)

this radeon monitor is from fakesmc, u can test

are you using textmate or xcode for that edit . can you screenshot?  what line taht is located. also is the value XX and real value or is it really just XX?

Link to comment
Share on other sites

  • Administrators

H1zG3QT.png

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

1 hour ago, MaLd0n said:

H1zG3QT.png

thanks. yeah. i lost my sound. i will update with that to XX.  bluetooth is on without dongle and toggles on /off. i will play with the radeon kext. 

config.plist.zip. attached is my config plist. i do not have that nvram listing. config.plist.zip.  i will probably leave this version of clover and not mess with that or the kext once i get sound going. i have sound via my monitor. i may reboot again and see if it comes back. 

 

sent you my EFI folder. -  http://s000.tinyupload.com/?file_id=08293550299594899362

and my latest run me -  http://s000.tinyupload.com/?file_id=04820790549551049870

Link to comment
Share on other sites

  • Administrators

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites

2 hours ago, MaLd0n said:

so with this one bluetooth toggle works, the amd power gadget works , i can see my fans now. no sound though. i will try to put the realtek kext back in. i saw that it is not in there.

RealtekRTL8111.kext.zip

4 hours ago, MaLd0n said:

H1zG3QT.png

the latest EFI you sent does not have the NVRAM part in the plist in it to change the alcid=XX.. i see also that the realtek one is for ethernet.  should i look for a sound kext?

 

Link to comment
Share on other sites

  • Administrators
5 hours ago, jackfrost4u said:

the latest EFI you sent does not have the NVRAM part in the plist in it to change the alcid=XX.. i see also that the realtek one is for ethernet.  should i look for a sound kext?

applealc don't work in ur case?

https://www.olarila.com/topic/6074-guide-easy-audio-solution-with-applealc-clover-and-opencore/

-Donations-

PayPal HERE - Stripe HERE - Ko-Fi HERE - BuyMeaCoffee HERE - Mercado Livre HERE

Skrill¬†[email protected]

BTC 1BDzsV4bw3DVCiffFAeNKsdEzqkPXNVrXR

ETH BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

BNB 0x10D1d656eCa00bD521f9b4A43B83098B8142e115

USDT BSC BEP20 0xb57cfdfa371fad1981910f0e8332409ab99f74d9

USDT TRC20 TUR6Z9AVS4AYzqPnULoHrfFvppRbhXmNbZ

PicPay @danielnmaldonado

PiX¬†@[email protected]

Problems with Paypal HERE

xcd5u2Y.png

Sign up for a Bybit account and claim exclusive rewards HERE

New ways to earn money with Linkvertise HERE

Link to comment
Share on other sites



×
×
  • Create New...