Jump to content
aleksandarciric

t540p Catalina 15.5.5 HD4600 post install

Recommended Posts

Hi!

Few days ago I successfully hacked my laptop with Olarila usb installer and by kindness of this forum got a patched DSDT.

Battery is working, Intel wifi working with autoloader, sound working. 

I am using Olarila Clover EFI folder for notebook chipsets.

I also got recommendation to use This guide to properly set up my IGPU.   

Thing is, my laptop wont boot with mentioned patch for 4600, it gets stuck on IOIGPU something...

 

I have pasted:

<key>PciRoot(0)/Pci(0x02,0)</key>
            <dict>
                <key>AAPL,ig-platform-id</key>
                <data>BgAmCg==</data>
                <key>device-id</key>
                <data>EgQAAA==</data>
                <key>framebuffer-cursormem</key>
                <data>AACQAA==</data>
                <key>framebuffer-patch-enable</key>
                <integer>1</integer>
                <key>hda-gfx</key>
                <string>onboard-1</string>
            </dict>

- lines into config plist, overwriting the old ones to no avail.

I have also tried HD 4600 4400 and 4200 config - no boot.

My igpu is in 7mb mode when I boot with backup config.plist from Olarila notebook folder.

 

Anybody can check my config plist and see what can be a case?

 

I am also having annoyance with frequent beachball and low responsiveness of the system, even though trim is enabled for ssd. - same case with trim disabled.

config.plist.zip

Link to comment
Share on other sites

  • Administrators

post one dump

Extract tables with F4 key in Clover boot screen, boot into system and run this app
https://www.olarila.com/files/Utils/RunMe.app.zip
https://www.youtube.com/watch?v=k9wmIfGLe3A

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

ok

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Just to update

Tried with Mojave, same thing. 

This time I get black screen with your latest EFI folder.

When I am using standard Notebook EFI folder and patched dsdt it boots fine but in 7mb mode.

 

I have noticed during boot that whatever green says something like " IGPU is set as 0416 should be 0412" - maybe that is a problem.

 

Also I was trying with open core, and created EFI folder and all patches following haswell laptop guide to the letter, but was not able to boot due to kernel panic coused by IGPU.

One thing I noticed is that my IGPU is not originaly on .GFX0 but on .VID - maybe that has something to do with a problem. 

 

Either way, thank you! I will try  with Catalina 15.5.3 since Catalina has better support for Intel Wifi

 

 

Edited by aleksandarciric
Link to comment
Share on other sites

  • Administrators

Intel Fake gfx 0x04128086

this igpu need it

but this patch have it

ZMyuJ0I.png

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...