Jump to content
jotaperez

Freezes in Catalina that don't happen in Mojave

Recommended Posts

Hi. My system is made up of the following hardware:

CPU: I7 7700 (not "k")
Motherboard: Gigabyte GA-H270 Gaming 3
Memories: Kingstone 2 x 8gb
GPU: MSI Radeon RX 570 4gb Armor

I tell you my problem. A few weeks ago I traded in my old nvidia GT 740 GPU (which worked perfectly on S, HS, M, and C) for a new MSI RX 570. I bought this GPU to make sure Mojave and Catalina compatibility was absolute. When installing it, I also installed iStat to test it, and soon the problems started ... The system started to freeze randomly (sometimes once a day, sometimes several times a day), with gray screens, sometimes in white, sometimes in black and other times in pink. I could only get out of these freezes by holding down the power button on the computer since the restart seemed to do nothing.

This happened to me on Catalina, which I installed on a separate SSD disk. I also have a separate Mojave installation on another separate disk, which works perfectly, without any freezes or freezes.

Both systems start with the same clover (which is in the EFI of Catalina's disk). But the freezes only happened in Catalina.

At first I thought the problem was FakeSMC and its sensors, so I removed them and replaced them with VirtualSMC and the few sensors that are currently available. But the problem continued.

The peak of the problem came a couple of days ago when I installed the Intel Power Gadget. When opened, the computer began to restart constantly. The team started perfectly, but after entering Catalina and logging in, it would restart again,

I wanted to uninstall iStat and Intel Power Gadget, but the system did not give me the necessary time to be able to close it and uninstall it since it restarted immediately after starting!

I came to the conclusion that the problem had to be iStat or Intel Power Gadget, since in Mojave I do not have them installed and the system works correctly.

Bottom line: I had to reinstall Catalina, this time without iStat or Intel Power Gadget. Obviously I am blind since I cannot know the temperatures of my CPU or GPU, because any application that I install to measure temperatures will make my computer freeze.

My RX 570 works in "headless" mode with the HD630 of my Gigabyte GA-H270 Gaming 3 motherboard. I use two monitors (one connected by HDMI and the other by DVI-D)

And when I thought that the problem had resulted (because for more than a day the system worked perfectly) today I had another freeze ... This makes me rule out problems due to FakeSMC (and its sensors) and also VirtualSMC and its sensors ...

The only kexts that I had installed in Clover's "Others" folder are lilu, NoVPAJpeg (for Mojave) VirtualSMC, WhateverGreen and AtherosE2200.

I will appreciate if you can guide me, because the truth is that I don't know what the problem may be

Thank you and sorry for having extended so much.

Link to comment
Share on other sites

  • Administrators

post ur efi folder here

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

fail

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

@MaLd0n thanks for your answer.

I was ahead of the game, and yesterday I downloaded this same EFI from the "Downloads" section. I installed it on a pendrive and started the system from it. It started perfectly and I used it ayud dudrante all afternoon and night until I turned off the computer, but this morning, when I started my system again, the error returned. It happened 2 times.

The first freeze occurred a few minutes after the system started, while checking emails in Thunderbird; the screens were gray and I had to turn off the system to be able to unlock it.

I rebooted the system and the second freeze happened by writing this answer on the forum: one monitor was black, the other was gray and I had to turn the system off again. This time, the monitor that connects via hdmi was blocked in black: the gigabyte logo, the clover interface, the system startup, the Catalina background, all remained on one screen while the other remained black but with the power led as if it were on so I deduce that it was receiving a signal. I could not log in because the logging screen I deduce was left on the monitor blocked.

I had to reboot the system, remove and reattach the locked monitor power cable to get the system to reboot on both monitors.

I am trying to replicate the failure in some way, but I realize that almost most of the time, the problem occurs within a few minutes of first starting the system in the morning. Once the system freezes, I turn it off and restart it, it is very difficult for it to appear again ... there may be a second freeze (like today) shortly after the first one has happened, but generally it does not occur again during the day...

If I search the console I can't find any registration error.

I will appreciate any help that can guide me in solving this problem.

Thank you!

Link to comment
Share on other sites

  • Administrators

DSDT.aml.zip

folder stay wrong

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

  • Administrators

just put my dsdt into clover/acpi/patched and use Olarila folder serie 100/200/300/400

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Thank you very much for your help! I have installed the SSDT in the folder that indicates me. I will test your configuration. Tomorrow morning will be a good time for this since the system usually freezes a few minutes after the first start of the day.

Can I ask you what errors you found in the zip that I sent you and that could be the cause of the freezes on my computer?

Thank you in advance.

Link to comment
Share on other sites

Buenas tardes!!.

Estoy intentando instalar Catalina Olarila pero en mitad de la instalación se congela. Me dijeron que se soluciona actualizando el firmware de Samsung 970 EVO Plus. Pues no ha sido así.

Este equipo monta:

Asus TUF Z390M-Pro Gaming, Core i7-9700K, XFX Radeon RX 580, Samsung 970 EVO Plus, HDD Seagate 2TB.

Espero respuesta y Gracias de antemano!!.

Link to comment
Share on other sites

1 hour ago, MaLd0n said:

just put my dsdt into clover/acpi/patched and use Olarila folder serie 100/200/300/400


I just installed Davinci Resolve to test. I took a video file and put it in the export queue. When I clicked "render" the computer rebooted ...

I had this problem the times I configured the smbios of my system as iMacPro1,1 ... which apparently is the configuration of smbios that owns its clover folder.

I will appreciate your help.
 
Link to comment
Share on other sites

  • Administrators
1 hour ago, jotaperez said:
I just installed Davinci Resolve to test. I took a video file and put it in the export queue. When I clicked "render" the computer rebooted

https://www.olarila.com/topic/5295-guide-hardware-encoder-hardware-decoder-video-processing-hevc-support-intel-quick-sync/

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Thanks for your reply.
Where should these parameters be entered?

 

-Kabylake and Coffeelake(8 Gen)

 

IntelGFX 0x59128086

ig-platform-id 0x59120003

Check InjectIntel

If I enable the igpu I would have to change the smbios to one compatible with my platform ... is that correct?

Edited by jotaperez
Link to comment
Share on other sites

1 hour ago, jotaperez said:

Thanks for your reply.
Where should these parameters be entered?

 

-Kabylake and Coffeelake(8 Gen)

 

IntelGFX 0x59128086

ig-platform-id 0x59120003

Check InjectIntel

If I enable the igpu I would have to change the smbios to one compatible with my platform ... is that correct?

Here you add IntelGFX on your config.plist

spacer.png

And here the other two options

spacer.png

and yes you should change your SMBIOS to one that has iGPU, because iMacPro1,1 it's without iGPU

Edited by snake881
Link to comment
Share on other sites

Thanks @snake881 for your reply.

I make a query: I understand that to be able to use the iMacPro1,1 settings, you have to disable the igpu in the bios, however in the guide indicated by MaLd0n above (https://www.olarila.com/topic/ 5295-guide-hardware-encoder-hardware-decoder-video-processing-hevc-support-intel-quick-sync /) in the third step indicates that you must enable intelHDGraphics ...

This is confusing for me since MaLd0n told me to use the folder series 100/200/300/400, and the configuration of this Clover is with iMacPro1,1

Thank you in advance.

Link to comment
Share on other sites

  • Administrators
5 minutes ago, jotaperez said:

This is confusing for me since MaLd0n told me to use the folder series 100/200/300/400, and the configuration of this Clover is with iMacPro1,1

have a 3 ways

1- iMacPro1,1 or MacPro7,1, have a native hardware accel, only Mojave e Catalina

2- Via IGPU, Intel Quick Sync

3- Shikigva=128 or 144 for example, for AMD cards without IGPU enable, only Catalina

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

4 minutes ago, MaLd0n said:

have a 3 ways

1- iMacPro1,1 or MacPro7,1, have a native hardware accel, only Mojave e Catalina

2- Via IGPU, Intel Quick Sync

3- Shikigva=128 or 144 for example, for AMD cards without IGPU enable, only Catalina

And what do you advise me considering that my cpu, gpu and motherboard correspond to smbios 18.2?

Link to comment
Share on other sites

  • Administrators

18,3

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

4 minutes ago, jotaperez said:

I must change the smbios iMacPro1,1 to smbios 18.3 of the folder series 100/200/300/400, enable igpu in the bios. It is right?

Do I keep everything else in folder series 100/200/300/400 as is?

Yes, you should do that, and if you have the kext whatevergreen and lilu, should change the boot args for one of this:

1- Use shikigva=80 or shikigva=16/ AMD GPU + IGPU(Internal Graphics)

in order to get working your AMD GPU and your iGPU. Remember that if you can't boot, your always has the USB installer of Olarila and you can use it to booting again

Link to comment
Share on other sites

Hi. I was doing some tests, both with my original clover and the one in the Oralila folder and I think the problem was solved by activating Platform Power Management in the bios (Gigabyte) which was disabled.

Can you confirm if the activation / deactivation of this parameter could be involved in system freezes?

Thanks since now!

Link to comment
Share on other sites

  • Administrators
17 minutes ago, jotaperez said:

Can you confirm if the activation / deactivation of this parameter could be involved in system freezes?

use bios in default with my full dsdt patch, just disable csm and enable internal graphics if need IQS

Donation with Paypal HERE

Donation with Stripe HERE

Donation with BuyMeaCoffee HERE

Donation with Mercado Livre HERE

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with BTC 33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3

Donation with PicPay @danielnmaldonado

Donation with PiX @danielnmaldonado@gmail.com

:guitar

Problems with Paypal Donate? Check HERE

Donated? Send me PM with files or use DSDT Patch Requests

6y0Bvfl.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...