Jump to content
  • Sky
  • Blueberry
  • Slate
  • Blackcurrant
  • Watermelon
  • Strawberry
  • Orange
  • Banana
  • Apple
  • Emerald
  • Chocolate
  • Charcoal
Sign in to follow this  
XInflict

Mojave don't recognize Intel Graphics HD 4000 as a GPU

    Recommended Posts

    #1
    I have a Gtx 970 installed, but I don't want to use it as Hardware Acceleration, only my HD 4000, but it isn't recognized by the system.
    This is my Config Attached, and I've tried a several number of things, Hackintool patches, The "An iDiot's Guide To Lilu and its Plug-ins" tutorial, Framebuffer for Intel Graphics, but none have solved my problem, every time I go to About This Mac I can't see my Intel Graphics on the Graphics/Display section.
    Help Please

    PS: 1 - It does work when I completely remove my GTX from my motherboard, but it is not a good option, because I have a windows system, and I use it to gaming, and want to use my Mac to work, as previously I was using Mac OS High Sierra.
    2 - When I connect my HDMI only to the onboard Input I got black screen, I can't even see my BIOS, completely black.
    3 - When I set on BIOS "Primary Display: IGPU", I got BIOS screen, but Clover simply doesn't boot, I got the blinking underline on the top left side of the screen.
    4 - When I tried any of the "Devices > Proprieties - AAPL,GfxYTile and disable-external-gpu" I got stuck at the Apple Logo. It still load until the end., very slowly, but it does not start.
    5 - I've tried to Inject Intel, it was no good
    6 - Tried boot-args: nv_disable=1 -wegnoegpu igfxframe=frame, in every possible combination with the previous described attempts, it was no good.
     
    I've attached my files on the thread, is there anything there that could be causing this issue?
    Clover Kexts:
    FakeSMC
    VoodooPS2Controller
    NullCPUPowerManagement
    Lilu
    WhateverGreen
    ApplePS2Controller
    AppleALC
    RealtekRTL8111
    AirportBrcmFixup

    Maybe I need some DSDT change?
    I've found a "[Guide] Disabling discrete graphics in dual-GPU laptops", but in my case it is a Desktop
    I've never changed anything that has anything to do with DSDT, could this be an issue?
    Thanks for the help!

    Screenshots Specs and Config.rar

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    Sign in to follow this  

    ×
    ×
    • Create New...