Jump to content
cmhafintosh

DSDT Request:132-YW-E179-FTW(evga nforce 790i ftw)

Recommended Posts

Bare with me I know this is a really long post, but I would rather you have the information and not need it than need it and not have it. Hopefully something good comes from this(my first post, woo!)

My ancient custom build, its about time for an upgrade, but I've spent the last week messing around trying to get stuff working and I've decided to finally ask for some help, anyways here is my current build.

Case: Cooler Master Haf 932 Black Edition

CPU: Socket 775 Intel Core 2 Quad Q9400 2.67Ghz

GFX: ASUS nVidia GTX 570 1280mb device ID 1081

MB: EVGA nForce 790i FTW (132-YW-E179-FTW) [mcp55]

HD:For OS/x 10.6.8 & 10.7.(2&3) 2 x78 GB WDC WD740GD-00FLC0

HD:Win7 1TB Internal Western Digital

RAM:2x2GB PatriotDDR3-1333MHz but it runs at 1067MHz with stock settings


with 10.6-10.6.8 audio works even before multishit, but nothing else does...

10.7+ can use multishit to fix audio, but it does not work initially.


Ethernet will work after installing nforceLan_0.64.6.mpkg (but it cuts out randomly and I have to disable and re-enable services; i have been trying to bridge my two ethernet ports to see if it helps at all)


I have not yet had any luck with my gfx card, and have tried multiple kexts, enablers, as well as inputting string to org.chameleon.boot

which seems to do little more than identify my card..no extra resolution settings..maybe I'm missing something if so I'm open to suggestions. Most of the gfx tinkering was done on 10.7.3, although I did some on 10.7.2, I'm about to reinstall 7.2 right now and try the Weezey Guide which had sourced netkas and seemed promising...but when I tried on 10.7.3 I just got a black screen after -v finished, or reboot loop after verbose boot finishes, another time froze at PCI Configuration Begin


If you've made it this far, thanks for reading, and if I get lucky enough to find someone awesome enough to help-hell yes you rule.

~Roman

DSDT Files.zip

Link to comment
Share on other sites

Just a quick update on my status since my last post

I finally got my Asus GTX 570 1280MB to work in 10.7.3, multi-resolutions but the color was kind of purple(ish) I know its a bit off topic for this subsection but I included it in my original post and to be courteous I wanted to make sure no one spent time explaining the process needlessly.

so far I have it working after I

Added device ID to NVDGAF100Hal.kext's info.plist

Added device ID to NVResman.kext's info.plist as well, although I don't think it was necessary

Used GeforceGLDriver.bundle & ATY_Init.kext from kexts.com

added Hex string to org.chameleon.boot.plist under device-properties and made sure than graphicsenabler/graphicsmode were both set to blank strings

lastly I deleted appleupstreamuserclient.kext just because people suggested it although it seemed to be running fine with it

and here is everything I used incase anyone is interested. : http://www.mediafire.com/?wc5h47xdbwgbubj


and about the dsdt, I'll take whatever help I can find, even it if is just some good reading material, as long as it isn't another video that shows how to patch a specific board with a patch file, haha information on how to determine what kind of hacks or fixes I might need to use is what I'm looking for, I'm open to surprises too just incase someone does decide to edit my dsdt for me ;)

thanks ~roman


EDIT: Color was fixed!! Deleted display profiles and rebooted, fixed!

Link to comment
Share on other sites

Ben over a year now, did you ever get it to work? I just got mine goin pretty good on 10.6.8, so then I thought what the hell. Go for broke, so I installed 10.8 and updated it to current. Few bugs, sleep only consist of monitors turning off and back on... No full power down, board won't see my hard drive unless I plug it into the red sata port or use IDE. With red port the os thinks its external, so I used the blocker kext. But that's only cosmetic. Sound works well with voodoo, when I use applehda I get no mic. I got the LAN ports to work with a kext, my gtx 260 was a bitch... Easy in snow, but damn hard in ml. Nvidia only supports the 285. But it's workin good now. I even use multi monitors. But yea, not using a dsdt either, just tons of Kext,s. some patched. Like the power management one. So i have deleted the null power one at this point.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.





×
  • Create New...
The popup will be closed in 15 seconds...